Contribute
Register

Ohchang's build: Gigabyte Z590 Vision G + i7-10700K + AMD RX580

Joined
Sep 3, 2018
Messages
62
Motherboard
Asrock X570 Taichi
CPU
Ryzen 9 5900X
Graphics
Radeon VII
Mobile Phone
  1. iOS
[Caution]
This is NOT a permanant solution.

Please use this way until a release newer version of Opencore and Hackintool.

---

I am testing A Z590 Asrock Taichi with Thunderbolt/USB 4, and with 11.3 no USB after reboot. But I unchecked XhciPortLimit with the Port Limit Patch, and I had a USB SSDT. All USB are working right now again
 
Joined
Dec 12, 2011
Messages
35
Motherboard
GIGABYTE Z590 Vision G
CPU
i7-11700K
Graphics
RX 6700 XT & RX 560
I shoud've check this, but I didn't. Cuz I don't use Windows at all.

Please use this SSDT-UIAC-Z590-VISION-G-V3.aml file.(MOD for windows)
After that, please check the 'unknown device' in Win10 device manager still there.

Thank you for your feedback.

Thanks again, this indeed fixed the issue.

fixed.jpg
 
Joined
Jan 26, 2014
Messages
12
Motherboard
Gigabyte
CPU
intel
Graphics
cpu
Hello, can you confirm if the Thunderbolt 3 ports/devices are functional in this build?

I cant seem to find the z490 Vision D anywhere and this motherboard is beautiful. I'm building an audio workstation and need Thunderbolt 3 ports to work, although thunderbolt 4 i'm sure i could live without.

Thank you!
Which build? The Vision G (Z490 or Z590) does not come with Thunderbolt ports. The Vision D Z490 has been discontinued by Gigabyte. There is a whole other thread on the Z590 which has a lot of work on the Z590 Vision D
 
Joined
May 11, 2011
Messages
1,419
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Hello, can you confirm if the Thunderbolt 3 ports/devices are functional in this build?

I cant seem to find the z490 Vision D anywhere and this motherboard is beautiful. I'm building an audio workstation and need Thunderbolt 3 ports to work, although thunderbolt 4 i'm sure i could live without.

Thank you!
I think you should go for the AMD B550 version of the Vision D instead. That's proven to be a solid system so far and it works with Thunderbolt 3. Check out CaseySJ's build of it here > https://www.tonymacx86.com/threads/...lt-3-amd-ryzen-7-3700x-amd-rx-5600-xt.304553/
 
Joined
Mar 19, 2011
Messages
24
Motherboard
motherboard make & model # > See Rules!
CPU
I5-2300
Graphics
GTS 450
Mac
  1. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Other
Very nice, great job! I'm interesting in the VisonLink USB-c port which suppose to act like Thunderbird, or this going to work in the future.
 
Joined
Oct 24, 2013
Messages
456
Motherboard
Gigabyte Z590 Vision D
CPU
i7-11700K OC @ 5.2GHz
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
I am testing A Z590 Asrock Taichi with Thunderbolt/USB 4, and with 11.3 no USB after reboot. But I unchecked XhciPortLimit with the Port Limit Patch, and I had a USB SSDT. All USB are working right now again
Hello,

How is Thunderbolt working for you on the Taichi? Are you thunderbolt devices detected in macOS? Do you have hot-plug working?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,071
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
USBPort.kext(from Hackintool) does not work in Big sur 11.3,

This is wrong. I don't have any problems with my Hackintool created USB kext. Been using the same kexts for a long time (2 years?).
 
Joined
Mar 5, 2021
Messages
41
Motherboard
GIGABYTE Z590 Vision-G
CPU
10700K
Graphics
RX580
This is wrong. I don't have any problems with my Hackintool created USB kext. Been using the same kexts for a long time (2 years?).
I've been using kext(from hackintool) for a long time also.
But it can not recognize USBPorts.kext in my Z590 Vision-G with or without XhciPortLimit at all.(even kernel patch)
While USBMap.kext works well with USB Port limit Kernel patch.

Why?
I don't know exactly. I heard and found about the broken XhciPortLimit patch, then I've found out just working solution in my gear. ;)
If there is something wrong in my fix, would you mind correct it?
 
Joined
Mar 31, 2011
Messages
636
Motherboard
Gigabyte GA-Z77-DS3H-F11a
CPU
i5-3570K OC @ 4.2GHz
Graphics
HD 4000
Mobile Phone
  1. Android
This is wrong. I don't have any problems with my Hackintool created USB kext. Been using the same kexts for a long time (2 years?).

There's a new USB Patcher in town called USBToolBox, it's still in Beta but it's supposed to overcome some of the issues that people have experienced from updating to macOS Big Sur.
I have zero experience with it myself as I have no issues my end but thought some of you might wanna check it out if you're interested :geek:
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
6,198
Motherboard
Gigabyte Z490i Aorus Ultra - OC 0.6.8
CPU
i5-10600K
Graphics
GT710 - 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
I've been using kext(from hackintool) for a long time also.
But it can not recognize USBPorts.kext in my Z590 Vision-G with or without XhciPortLimit at all.(even kernel patch)
While USBMap.kext works well with USB Port limit Kernel patch.

Why?
I don't know exactly. I heard and found about the broken XhciPortLimit patch, then I've found out just working solution in my gear. ;)
If there is something wrong in my fix, would you mind correct it?

Hi there.

I can confirm that USBPorts.kext works with Big Sur 11.3 and 500-series chipsets. :thumbup:

However there are problems with the XhciPortLimit quirk and the use of USBInjectAll. I'm sure the OC team know about it.

Catalina and Big Sur USB works as expected with USBPorts.kext on 500-series however I suspect ACPI implementations by different manufacturers may be a problem for some.

When you look inside USBMap.kext and compare it with USBPorts.kext you'll see there is no reason why one works and one doesn't.

Having said all that I am glad your system is working :thumbup:
 
Top