Contribute
Register

Ohchang's build: Gigabyte Z590 Vision G + i7-10700K + AMD RX580

Joined
Mar 30, 2011
Messages
14
Motherboard
GA-H370M-D3H
CPU
i5-8400
Graphics
UHD 630
Hello, can you confirm if the Thunderbolt 3 ports/devices are functional in this build?

I cant seem to find the z490 Vision D anywhere and this motherboard is beautiful. I'm building an audio workstation and need Thunderbolt 3 ports to work, although thunderbolt 4 i'm sure i could live without.

Thank you!
 
Joined
Mar 5, 2021
Messages
41
Motherboard
GIGABYTE Z590 Vision-G
CPU
10700K
Graphics
RX580
Just a quick hat tip and thank you @ohchang

Thanks to your help, my new Hackintosh is running smoothly for over 24h now. I made some adjustments to your config.plist using the "OpenCore Configurator."

My setup:
CPU: 11th Gen Intel Core i7-11700K @ 3.60GHz
Mainboard: Gigabyte Z590 VISION G (Bios F4d)
Memory: 4x 16GB DDR4-3200 Kingston HyperX Fury
GPU #1: AMD Radeon RX 6700 XT - Primary GPU on Windows
GPU #2: AMD Radeon RX 560 - Secondary GPU just for macOS

Win: PCIe 4.0 M.2 WD_BLACK SN850 NVMe SSD 1TB
Mac: PCIe 4.0 M.2 WD_BLACK SN850 NVMe SSD 1TB
Data: PCIe 3.0 M.2 ADATA XPG Spectrix S40G NVMe SSD 4TB

The new PCIe 4.0 disks are freaking hot
View attachment 515779

Wi-Fi: Fenvi T919 (BCM94360CD)
PSU: be quiet! Straight Power 11 750W
Case: be quiet! Pure Base 500DX

Because I need DRM, I use SMBIOS iMacPro1,1. I "disabled" the iGPU in the BIOS, because I do not need it.
It took me quite some time to "disable" the RX 6700 XT though. My current solution is not perfect but okay, it somehow works :D

Something that is a bit odd, ever since I used OpenCore I now see a new "unknown device" in my Windows 10 device manager that I cannot fix/install/uninstall/remove. :lol: A quick Google search suggests it has something todo with USB
View attachment 515778

I shoud've check this, but I didn't. Cuz I don't use Windows at all.

Please use this SSDT-UIAC-Z590-VISION-G-V3.aml file.(MOD for windows)
After that, please check the 'unknown device' in Win10 device manager still there.

Thank you for your feedback.
 

Attachments

  • SSDT-UIAC-Z590-VISION-G-V3.aml
    1.2 KB · Views: 86
Joined
Mar 5, 2021
Messages
41
Motherboard
GIGABYTE Z590 Vision-G
CPU
10700K
Graphics
RX580
21.04.27
Do NOT up date Big sur 11.3
Some USB ports map does not work in 11.3
I'll update UIAC files ASAP


Check this at #29
 
Last edited:
Joined
Mar 5, 2021
Messages
41
Motherboard
GIGABYTE Z590 Vision-G
CPU
10700K
Graphics
RX580
[Caution]
This is NOT a permanant solution.

Please use this way until a release newer version of Opencore and Hackintool.

Update 20.05.05
I can't use more than 16 USB ports after Big sur 11.3.1
So, I set 15 ports only eventually.
Check the link as below.

---
I checked Z590 Vision-G M/B only.
You don't need to apply this fix, if there are no issue with Big sur 11.3 USB.



Issue

USB port map(like USBPort.kext) settings do not work(partially or all) properly after Big sur 11.3 update.



Solution
Re-map usb ports and Apply Kernel patches.

Step 1. Re-map with USBMap(*python script)
USBPort.kext(from Hackintool) does not work in Big sur 11.3,
please re-map all USB ports of your system from the first.(using USBInjectall.kext)

Then replace old USBport.kext(Hackintool ver.)

USBMap script

(Attached file is USBMap.kext(USBMap ver.) only for Z590 Vision-G)



Step 2. Change Quirks to Kernel Patch
Apply 2 Kernel patches as below.
Then Uncheck Quirks patch : OC - Kernel - Quirks - XhciPortLimit - false(uncheck)


Identifier: com.apple.iokit.IOUSBHostFamily
Comment: USB Port limit patch #1/2 10.15.x (credit DalianSky)
Find: 83FB0F0F
Replace: 83FB3F0F

Identifier: com.apple.driver.usb.AppleUSBXHCI
Comment: USB Port limit patch #2/2 10.15.x (credit DalianSky)
Find: 83F90F0F
Replace: 83F93F0F
Screen Shot 2021-04-27 at 8.24.35 PM.png





Final
If you had not updated Big sur 11.3 with Z590 M/B yet,
I recommend just waiting until OC & Hackintool update :)

And if you need a Extra operating current, use SSDT for USBX or add some lines to USBMap.kext manually.

Code:
    <key>kUSBSleepPortCurrentLimit</key>
    <integer>2100</integer>
    <key>kUSBSleepPowerSupply</key>
    <integer>5100</integer>
    <key>kUSBWakePortCurrentLimit</key>
    <integer>2100</integer>
    <key>kUSBWakePowerSupply</key>
    <integer>5100</integer>
 

Attachments

  • USBMap.kext.zip
    1.3 KB · Views: 638
Last edited:
Joined
Dec 12, 2011
Messages
57
Motherboard
GIGABYTE Z590 Vision G
CPU
i7-11700K
Graphics
RX 6700 XT & RX 560
Interesting, I haven't updated yet, mainly because I did upgrade to 11.4 beta 1 when it was suggested that the RX 6700 XT might work (It did not). So I'm still under 11.4 beta 1... I will try your improvements later today.
 
Joined
Sep 3, 2018
Messages
65
Motherboard
Asrock X570 Taichi
CPU
Ryzen 9 5900X
Graphics
Radeon VII
Mobile Phone
  1. iOS
[Caution]
This is NOT a permanant solution.

Please use this way until a release newer version of Opencore and Hackintool.

---

I am testing A Z590 Asrock Taichi with Thunderbolt/USB 4, and with 11.3 no USB after reboot. But I unchecked XhciPortLimit with the Port Limit Patch, and I had a USB SSDT. All USB are working right now again
 
Joined
Dec 12, 2011
Messages
57
Motherboard
GIGABYTE Z590 Vision G
CPU
i7-11700K
Graphics
RX 6700 XT & RX 560
I shoud've check this, but I didn't. Cuz I don't use Windows at all.

Please use this SSDT-UIAC-Z590-VISION-G-V3.aml file.(MOD for windows)
After that, please check the 'unknown device' in Win10 device manager still there.

Thank you for your feedback.

Thanks again, this indeed fixed the issue.

fixed.jpg
 
Top