Ohchang's build: Gigabyte Z590 Vision G + i7-10700K + AMD RX580

Ok i found it..:)
It's better for me to use the last EFI attached folder for MacOS Monterey fresh installation???

I have these issues on OCC and when I chose boot from usb to begin the installation

Those errors show you that there is a mismatch between the version of OpenCore you are using the version your config.plist was originally written for.

Make sure the version of OpenCore Configurator app is the correct one for the version of OpenCore you are using. Load your new config.plist, make a small change, Save, then change it back and Save again. This will reformat the config.plist correctly.

Since the activation of AppleVTD I can no longer dualboot my Windows 10 using OpenCore. Instead, I need to press F12 and change the boot device. Is there any fix for that? For example, can I buy a USB-C network card (like the AX88179A) and just disable the Intel i225-V in the UEFI and be done with it (needing AppleVTD)?

Or can this be a solution? (inject AppleIntelI210Ethernet.kext from Monterey) - Tried this method, I get an IP, but cannot ping. So my current solution is a USB-C network card based on the AX88179A chipset.
Last edited:
Mini guide - EFI for Z590 Vision G Ver 0.8 update for Ventura

I didn't test in Ventura 13.3.x or newer cuz there are critical problems in Unicode(like Korean) NFD/NFC related issue.
This guide works well under Ventura 13.2.1(22D68).

1. Freezing and stuttering after Ventura 13.x update

→ Force to use injected KEXT driver(from Monterey) for Intel i225-V, These settings are not affect to WiFi/BT at all

* If you already updated to Ventura then freeze after boot-up, just un-plug ethernet cable.

No custom firmware,
No VT-D related settings like SSDT-DMAR.aml,
No Ethernet hardware setting manually.

- Custom firmware
I don't prefer custom firmware. Just so, I didn't try this solution.

- SSDT-DMAR.aml injection and related settings
I tested various solutions multiple times, but it does not work with Z590 Vision G. Freezing, stuttering, and stuck still appear.

[Procedure - DO NOT skip any step]

- Use Device properties same as Ver 0.7(same as below, device-id: F31588680)
device-id F2150000/F3150000 does not work at all, even with the Kernel patch.

                <string>Ethernet Controller</string>
                <string>Intel Ethernet Controller I225-V 2.5GbE</string>

- Add AppleIntelI210Ethernet.kext(ver 2.3.1 From Monterey or Bigsur) to the KEXT folder and config.plist also

- Add e1000=0 to boot-args in config.plist

- Set Ethernet hardware setting to Auto. There is no need to enable VT-d in BIOS (or disable DisableIoMapper in Kernel Quirks).
z590 eth plist.png

z590 eth.png

2. Not working FCPX/Compressor or H/W acceleration failure after the Ventura update

→ Edit IGPU Device properties(update later)

After the update to the Ventura, Apple/Adobe Pro apps do not work well. Even H/W acceleration failures occur frequently. Maybe something changed in the MacOS iGPU acceleration process.

- Change Device properties like as below


- This setting is incomplete but works well. (Export speed 10~20% slower than v0.7)

z590 igpu.png


Please refer to my github or attached file v0.8
Thanks :)
Last edited:
Welcome back @ohchang. :headbang: We were seriously worried about you. :wave:
Welcome back @ohchang. :headbang: We were seriously worried about you. :wave:
I recommend the above new way to set the Ethernet setting(without Apple VT-d); maybe it won't bother to boot with Windows.
I have seen it, thanks. I updated to OpenCore 0.9.1, macOS Ventura 13.3 (22E252), iMacPro1,1, BIOS F7b, AppleIntelI210Ethernet.kext 2.3.1 (downloaded from the Internet; Dated: Feb. 26, 2022; md5sum: 96e610a84ce38be006f4dde9109149b1).

The system is not crashing, I managed to get an IP from my router but I cannot browse the Web nor ping a host on the network. Similar to my previous attempts.

ping - no response
ping - no response
ping (my router) - no response

Once I switch over to Wi-Fi all of that works. Ideas?

Edit: Okay, I found a solution. I enforced a speed (1Gbps), aka disabled auto-negotiation. It did not work on the first attempt, but I switch back and forth multiple times, and then it eventually started to work, for whatever reason. I also booted into Windows, there, everything works out-of-the-box, even auto-negotiation, then back to macOS, ping works now :) Thank you.


  • broken.jpg
    113.4 KB · Views: 28
Last edited: