Contribute
Register

Ohchang's build: Gigabyte Z590 Vision G + i7-10700K + AMD RX580

Joined
Jun 4, 2018
Messages
7
Motherboard
Gigabyte Z590 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. Mac Pro
Mobile Phone
  1. Android
  2. iOS
@root2 I have the Same Hardware except the AMD RX 560 and a i9-10900K instead. But none if the USB Ports are working. Cant tell why, since Mouse and Keybord didnt work. Used ur EFI for a fresh Monteray Install. Its working until the select Language Dialog. :/
 
Joined
Dec 12, 2011
Messages
82
Motherboard
GIGABYTE Z590 Vision G
CPU
i7-11700K
Graphics
RX 6700 XT & RX 560
@Azimuth1 it offers both settings, but my network at home only supports 1 Gbit/s, thus I cannot test whether 2.5 Gbit/s actually works, or is only displayed.

@MASONicxx the USB ports don't work because you do use a different SMBios, right? If you use a different than iMacPro1,1 you will need to adjust the model section in the Info.plist of USBPorts.kext first.
 
Joined
Jun 4, 2018
Messages
7
Motherboard
Gigabyte Z590 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. Mac Pro
Mobile Phone
  1. Android
  2. iOS
@root2 i use ur EFI Folder :eek: and there is <string>iMacPro1,1</string>
 
Joined
Dec 12, 2011
Messages
82
Motherboard
GIGABYTE Z590 Vision G
CPU
i7-11700K
Graphics
RX 6700 XT & RX 560
@MASONicxx
Yeah, but for privacy reasons, I replaced the SMBios section of the config.plist with the dummy values from sample.plist (as described in the ReadMe.txt and the screenshots in my post) before uploading it to the forum. Have you generated a new SMBios using iMacPro1,1 and replaced it in your config.plist?
 
Joined
Jun 4, 2018
Messages
7
Motherboard
Gigabyte Z590 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. Mac Pro
Mobile Phone
  1. Android
  2. iOS
@root2 but i cant boot into a running system :( Is there a way under windows?
Edit: Didnt know there is a Windows Version of SMBiosGen. I fixed that, but have still the same Problem.

But i have a clue. I only use a Radeon 5700XT in Slot 1 Via DP. Is it possible that i see a still Image?
i hear sound. (reader). But i cant move the Mouse Cursor. I also switched Mouse and Keyboard to different Ports. No luck.
 
Last edited:
Joined
Nov 1, 2021
Messages
1
Motherboard
Gigabyte Z590 Vision G
CPU
i7 10700k
Graphics
Radeon 6800
Hey guys, I want to thank first @ohchang for creating this helpful thread, and the community for posting up updates.

Also, wanted to share my experience, i migrated from an Asrock z490m pro4 (everything was super stable) to a Vision G Z590 (wanted a white build), used USBports.kext, iMac20,1 on Big Sur 11.6 but Ethernet wouldn't work. Only fix that would work was thanks to @edoardoww, given on his post. Sleep is broken due to Ethernet though.

Planning on migrating to Monterey on the next OpenCore release, perhaps given that i225v is supported natively, stability with Ethernet will be better.
 
Joined
Sep 13, 2010
Messages
36
Motherboard
Gigabyte Z590 Vision G
CPU
i9-10900K
Graphics
RX 570
Anyone have success getting an on board optical drive to work with this setup?
 
Joined
Dec 12, 2011
Messages
82
Motherboard
GIGABYTE Z590 Vision G
CPU
i7-11700K
Graphics
RX 6700 XT & RX 560
I fear that even Apple doesn't support onboard optical drives for over 10 years now. You can try one using USB. :D

But in theory they should work over SATA. In the past (using Big Sur) I used an old SATA SSD for testing, which worked flawlessly (as long as you do not forget to activate the SATA controller in the BIOS).
 
Joined
Dec 9, 2017
Messages
54
Motherboard
Gigabyte Z590 VISION D
CPU
i7-11700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
My build and the previous one have two optical drives connected. The first one is an external LG BD writer connected via USB 3.0 and the second one is an internal 5.25" DVD drive connected to the onboard SATA controller. Both are fully functional.
 
Top