Contribute
Register

Official CustoMac Mini 2012 Guide and Notes (in progress)

Joined
May 27, 2013
Messages
21
Mac
Classic Mac
Mobile Phone
005.jpg

I am sorry I hadn't noticed that the thread has moved, where to?

will I permanantly have to boot into safe mode? Also, once I insert my GPU How do I do GraphicsEnabler=no

where is that an option?
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,569
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
View attachment 58386

I am sorry I hadn't noticed that the thread has moved, where to?

will I permanantly have to boot into safe mode? Also, once I insert my GPU How do I do GraphicsEnabler=no

where is that an option?

Yes thats a Kernel panic, you are lucky that you get to boot in safe mode which is good as we can remove the problem you have installed in MultiBeast. Can you post exactly what you installed in MultiBeast and reply in your Own thread here
Stuck at Apple Logo and Spinning Wheel
 
Joined
Dec 8, 2010
Messages
76
Motherboard
Gigabyte X58A-UD3R / Gigabyte H77N-Wifi
CPU
i7-950 / i3-3225
Graphics
Nvidia 8400GS (Asus fanless) / HD4000
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I have been using optical out for audio for quite some time due to the fact that the DSDT for HDMI Audio would not wake from sleep under 10mins.

So I had some time today and extracted my DSDT, added HDMI patch from toleda's editing kit. Works perfectly and added a patch for sleep. It is working like a charm. I thought if any of you are having issues with sleep that I would post my DSDT.aml here. Motherboard H77n-Wifi Bios version F2. Use at your own risk.

Thanks for sharing this. I gave it a try; with it I'm back with the slow wakes, just like with the DSDT from the database here. My current best bet is with the DSDT did myself, with Toleda's patches to HDMI audio. No slow wakes, but I do have some sleep problems - manual or auto sleep sometime require multiple invocations to sleep more than 1 second.

Would you have some pointers about your sleep patch to share? I'd like to read a bit more on that. Thanks!
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,569
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Thanks for sharing this. I gave it a try; with it I'm back with the slow wakes, just like with the DSDT from the database here. My current best bet is with the DSDT did myself, with Toleda's patches to HDMI audio. No slow wakes, but I do have some sleep problems - manual or auto sleep sometime require multiple invocations to sleep more than 1 second.

Would you have some pointers about your sleep patch to share? I'd like to read a bit more on that. Thanks!

I extracted my own DSDT, added the compile patch for errors+HDMI audio audio editing kit, toleda's of course added the SMBus patch and everything is working great.
 
Joined
Dec 8, 2010
Messages
76
Motherboard
Gigabyte X58A-UD3R / Gigabyte H77N-Wifi
CPU
i7-950 / i3-3225
Graphics
Nvidia 8400GS (Asus fanless) / HD4000
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I extracted my own DSDT, added the compile patch for errors+HDMI audio audio editing kit, toleda's of course added the SMBus patch and everything is working great.

Thanks. I'll search a bit about the SMBus patch; if I simply extract my DSDT and apply Toleda's patch for HDMI audio, the HDMI audio works and the wake works correctly. The only remaining thing is that I'd say about 50% of the times the computer is supposed to go to sleep, it wakes up 1 second later; then it does not always go to sleep again.
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,569
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Thanks. I'll search a bit about the SMBus patch; if I simply extract my DSDT and apply Toleda's patch for HDMI audio, the HDMI audio works and the wake works correctly. The only remaining thing is that I'd say about 50% of the times the computer is supposed to go to sleep, it wakes up 1 second later; then it does not always go to sleep again.

No problem. To save you some trouble may I suggest you take a look here PJALM's DSDT Patches - TonyMacX86. There are all in one DSDT's here also. I have tried the H77n DSDT and its works great. Pjalm has done some great work here.
 
Joined
Feb 3, 2013
Messages
4
Motherboard
OS X
CPU
i5
Graphics
Intel HD Graphics 3000
Mac
Classic Mac
Mobile Phone
Hi,

Trying to buid my first Customac.
MB: ga-z77n-wifi
CPU: i7-3770
Graphics: I'm willing to use integrated Intel HD 4000
RAM 16MB (recommended Corsair)

I'm trying for days already and still stuck to either safe mode or that famos AppleBluetoothHCIControllerUSBTransport ...

Tried different BIOS settings, upgraded BIOS, using DVI cable, reinstalled several times...

I'm thinking that maybe bluetooth is causing problems, because got kernel panic once messing with bluetooth. But even if I remove the card - still stuck.

Seem that I really need some help!

Veiksmi,
Janis
 
Joined
Dec 8, 2010
Messages
76
Motherboard
Gigabyte X58A-UD3R / Gigabyte H77N-Wifi
CPU
i7-950 / i3-3225
Graphics
Nvidia 8400GS (Asus fanless) / HD4000
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
No problem. To save you some trouble may I suggest you take a look here PJALM's DSDT Patches - TonyMacX86. There are all in one DSDT's here also. I have tried the H77n DSDT and its works great. Pjalm has done some great work here.

Thanks for this. It seems that my issue when the computer wakes up 1-2 secs after I request sleep might be caused by the "wake on Ethernet" toggle in the power settings. I turned it off (the h77 board does not support it anyway if I remember correctly) and it seems to resolve the issue with my DSDT or the one with the all-in-one patch from PJALM. At the moment I am sticking with my DSDT and I'll see if the issue is really resolved after a few days. Will need to research a bit what are all these patches for too.
 
Joined
Dec 8, 2010
Messages
76
Motherboard
Gigabyte X58A-UD3R / Gigabyte H77N-Wifi
CPU
i7-950 / i3-3225
Graphics
Nvidia 8400GS (Asus fanless) / HD4000
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Hi,

Trying to buid my first Customac.
MB: ga-z77n-wifi
CPU: i7-3770
Graphics: I'm willing to use integrated Intel HD 4000
RAM 16MB (recommended Corsair)

I'm trying for days already and still stuck to either safe mode or that famos AppleBluetoothHCIControllerUSBTransport ...

Tried different BIOS settings, upgraded BIOS, using DVI cable, reinstalled several times...

I'm thinking that maybe bluetooth is causing problems, because got kernel panic once messing with bluetooth. But even if I remove the card - still stuck.

Seem that I really need some help!

Veiksmi,
Janis

Did you turn off Vt-d in the BIOS? Does the system boots ok in safe mode? What options did you pick when running Multi-beast?
 
Joined
Feb 3, 2013
Messages
4
Motherboard
OS X
CPU
i5
Graphics
Intel HD Graphics 3000
Mac
Classic Mac
Mobile Phone
Hi,

Yes, I turned Vt-d off in BIOS.
Yes, system boots ok in safe mode.
I did several installs trying to play with Multibeast. But by default - recommended ones - without DSDT + network + sound drivers.

Veiksmi,
Jānis
 
Top