Contribute
Register

Solved > NVRAM Motherboards z390

Joined
Aug 9, 2012
Messages
121
Motherboard
Asus Maximus XI Hero (Wifi)
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
iOS
Hello friends!

Update Fix>


With Clover_v2.4k_r4919 now everything works perfect, EmuVariableUefi-64.efi + Clover Scripts are not necessary now.


Only AptioMemoryFix-64.efi, necessary now!!!

Captura de Pantalla 2019-04-06 a la(s) 11.22.45 p. m..png



Old Problem (Fixed)>
I would like to open this thread of discussion and help, with owners of z390 motherboards, there is currently no native nvram support for these boards, my Maximus XI Hero (WiFi), needs nvram emulated using EmuVariableUefi-64.efi + Clover Scripts.
However something seems to be wrong as it seems to not remember the last system chosen to boot, I have 4 systems (Linux, Windows 10, High Sierra and Mojave), probably something wrong in my Clover configuration or really something is not right.

My Rampage V Extreme works well and remembers the last system chosen to boot using nvram emulated as well.

For that reason I would like to know the experience of other people with these motherboards and the methods used to have nvram working.

Someone else with a motherboard Maximus XI Hero or Maximus XI Hero (WiFi), that can share your work.
 
Last edited:
Joined
Aug 9, 2012
Messages
121
Motherboard
Asus Maximus XI Hero (Wifi)
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
iOS
How do you have sleep working with only aptiomemoryfix? I tried but could not work it out
There are many other things that can make sleep not work.
Do you have a USB SSDT correctly configured? Do you use a Cooler AIO pump connected to any USB port? If you see your AIO Pump in your ioreg, maybe you should remove that port from your SSDT, or disconnect the AIO to see if your Hack is going to Sleep.
 
Joined
Sep 24, 2012
Messages
282
Motherboard
Gigabyte Z390 Aorus Master
CPU
i7-9900K
Graphics
GTX 760
Classic Mac
Power Mac
Mobile Phone
iOS
With Emuvariable Uefi i have working sleep. Yes i have a USB.kext, no Cooler iopump.

Does your sleep work with only aptiomemoryfix? What Darkmode you use? What is your setting for hibernatemode and proximitywake? Mine are the following.

With Aptiomemoryfix only, i can boot, but no sleep with darkwake=0 or darwake=8.
 

Attachments

Joined
Aug 9, 2012
Messages
121
Motherboard
Asus Maximus XI Hero (Wifi)
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
iOS
With Emuvariable Uefi i have working sleep. Yes i have a USB.kext, no Cooler iopump.

Does your sleep work with only aptiomemoryfix? What Darkmode you use? What is your setting for hibernatemode and proximitywake? Mine are the following.

With Aptiomemoryfix only, i can boot, but no sleep with darkwake=0 or darwake=8.
Yes, I only use ApfsDriverLoader-64.efi and AptioMemoryFix-64.efi in drivers64UEFI Folder.
I do not use any Darkwake boot flag
hibernatemode and proximitywake are similar like you.
 
Joined
Sep 24, 2012
Messages
282
Motherboard
Gigabyte Z390 Aorus Master
CPU
i7-9900K
Graphics
GTX 760
Classic Mac
Power Mac
Mobile Phone
iOS
Yes, I only use ApfsDriverLoader-64.efi and AptioMemoryFix-64.efi in drivers64UEFI Folder.
I do not use any Darkwake boot flag
hibernatemode and proximitywake are similar like you.
Could you share your efi without your serials? I dont get sleep to work with aptiomemoryfix
 
Top