Contribute
Register

NVME installation disable USB3.0 ports and viceversa

Joined
Dec 14, 2016
Messages
34
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
i7 6700k
Graphics
Gigabyte GTX 1070 G1 windforce
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Hello, i am an happy hackintosh user, some problems here and there but always fixed,

I installed my new MP510 nvme ssd, enabled on bios, used the "KernelAndKextPatches" fix to get him recognized and it worked, so i initialized the Drive to MacOs journaled (i need it to stream data not for OS) and copied some files in it, then i noticed that my USB3.0 external drive was not recognized so i found out USB3.0 ports was not working anymore.
I downloaded latest Multibeast and installed:
-7/8/98 Series USB support
-Increase Max port Limit 100 series

And USB 3.0 was working again , but my NVME drive was not recognized again.. The Kext patch still there so i don't know what to do now

Thanks for the help


RIG:
i7 6700K
Gigabyte z170 ud5 th
OS Sierra 10.12.6

Patch used is from this video
 
Joined
Aug 26, 2017
Messages
155
Motherboard
Z170X-UD5-TH
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Classic Mac
iMac, LC, Power Mac, Quadra
you need to boot on SDD first, then launch hackintool, and go to section PCI for get information on your NVME

 
Last edited:
Joined
Dec 14, 2016
Messages
34
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
i7 6700k
Graphics
Gigabyte GTX 1070 G1 windforce
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
you need to boot on SDD first, then launch hackintool, and go to section PCI for get information on your NVME
thanks but i've never heard of this software i see there are different guides but not for my issue, can you recommend something specific?
which information you need? is corsair MP510 gen3 x4M.2SSD
 
Joined
Aug 26, 2017
Messages
155
Motherboard
Z170X-UD5-TH
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Classic Mac
iMac, LC, Power Mac, Quadra
no you need to know what is the adress pci information to add to boot NVME
 
Joined
Dec 14, 2016
Messages
34
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
i7 6700k
Graphics
Gigabyte GTX 1070 G1 windforce
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
no you need to know what is the adress pci information to add to boot NVME
i am not trying to boot from nvme, i want to use it as internal drive to store files. i was able to do it, but now is not working anymore
 
Joined
Aug 26, 2017
Messages
155
Motherboard
Z170X-UD5-TH
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Classic Mac
iMac, LC, Power Mac, Quadra
you could use on another key linux to find with lspci -k address of pci without install, on virtual memory try
 
Last edited:
Joined
Dec 14, 2016
Messages
34
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
i7 6700k
Graphics
Gigabyte GTX 1070 G1 windforce
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
you could use on another key linux to find with lspc -k address of pci without install, on virtual memory try
thank you for your help but this makes no sense to me at all...can you plz explain in a more easy way? thanks
 
Joined
Aug 26, 2017
Messages
155
Motherboard
Z170X-UD5-TH
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Classic Mac
iMac, LC, Power Mac, Quadra
yes of course, you need a second usb key, you install for instance manjaro, linux, then you boot on you CM.
next, you choose to se in virtual, and launch then open in a terminal a shell and sudo lspci -k
(dont install )

you get le list of whole pci component
 
Joined
Dec 14, 2016
Messages
34
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
i7 6700k
Graphics
Gigabyte GTX 1070 G1 windforce
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
yes of course, you need a second usb key, you install for instance manjaro, linux, then you boot on you CM.
next, you choose to se in virtual, and launch then open in a terminal a shell and sudo lspci -k
(dont install )

you get le list of whole pci component
sounds crasy that i need to do such thing to let sierra recognize one hard disk, specially because it was working no problem until i restarted my hackintosh. When i restarted the USB 3.0 was not working so i installed USB 3.0 drivers and the nvme SSd was not recognized again, but i mean...it was working. motherboard sees it
 
Joined
Aug 26, 2017
Messages
155
Motherboard
Z170X-UD5-TH
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Classic Mac
iMac, LC, Power Mac, Quadra
if you could start mac os plz use hackintool application

then search your NVME drive
 
Top