Contribute
Register

nvidia-update - Simple way to install nVidia web drivers

bb1

Joined
Mar 10, 2019
Messages
1
Motherboard
MSI Z97 Gaming 3
CPU
Intel i7 4790
Graphics
Nvidia Geforce 1080 Ti
thank you so much!!
 
Joined
Jan 28, 2013
Messages
8
CPU
i5
Graphics
GTX 1060
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
help iam install comand! but dont work audio kext help??
 
Joined
Mar 16, 2019
Messages
3
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Hallo!
I’m ordinary macuser with medium level of skill. Don't have Hackintosh.
I’ve purchased this card:
https://www.msi.com/Graphics-card/GeForce-GTX-1060-ARMOR-6GD5X-OC/Overview
Web driver installed:
WebDriver-387.10.10.10.40.122.pkg
Instaled also:
NvidiaGraphicsFixup-1.2.5-2018-04-02 22.29.48
Lilu.kext
Used KextBeast to fix
But doesn’t work. Can't force to use NVIDIA Web Driver over Default macOS Driver. After restart macOS Driver reboot. New card is described as Display in System Report.
Card not recognized.
Have You any idea? Can’t find solution on web. Don’t wat to use Clover, not familiar at all. I don’t understan this hackintosh voodoo.
Please, help me. You're my only hope, Obi-Wan Kenobi...
Screen Shot 2019-03-16 at 14.04.07.png
Screen Shot 2019-03-16 at 16.43.34.png
Screen Shot 2019-03-16 at 16.47.57.png
Screen Shot 2019-03-16 at 16.48.14.png
Screen Shot 2019-03-16 at 16.48.35.png
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,393
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Instaled also:
NvidiaGraphicsFixup-1.2.5
NvidiaGraphicsFixup.kext is deprecated - Now part of WhateverGreen.kext.
For a real Mac you might try macvidcards.com.
 
Joined
Sep 11, 2012
Messages
421
Motherboard
Gigabyte X79-UP4
CPU
i7-3930
Graphics
WX4100
Mac
  1. Mac Pro
It'll install the most recent non-blacklisted driver, which at the moment is 378.10.10.10.25.106.

Presently only 387.10.10.10.25.156 and 387.10.10.10.25.157 are blacklisted - https://github.com/Benjamin-Dobell/nvidia-update/blob/master/BLACKLIST.

EDIT: By the way, it does output which driver it's installed.

You can also run it as often as you like and it'll only download drivers and make changes if necessary (unless you download the script and specifically run it with --force).

For example, at the moment, anyone already running 378.10.10.10.25.106 who runs the script will just see the following:

~ bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh)
Downloading driver blacklist...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 40 100 40 0 0 101 0 --:--:-- --:--:-- --:--:-- 102

Downloading driver list...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 54650 100 54650 0 0 41229 0 0:00:01 0:00:01 --:--:-- 41214

The latest driver revision is 378.10.10.10.25.106

378.10.10.10.25.106 is already installed.​
Hi - just tried the script in Terminal -it installed 123 or 125 on High Sierra 10.3.6. Now I get black screen and cant boot into High Sierra. I have Whatever Green and Lilu in my kext folder. Any ideas?
 
Joined
Feb 10, 2013
Messages
6
Motherboard
GA-Z170X-UD3
CPU
i5-6600k
Graphics
Asus GTX 1070
I'm running 10.14.4 Mojave hackintosh, ran your script and its apparently working.
  • Monitor is recognized
  • Running 144 Hz
I have distortion when using:
  • chrome
I have not installed the lilu or whatever kext because I don't really know how to do that. But after 1 reboot, I'm not seeing any problems.

Will update after using Blender, other GPU intensive apps.
UPDATE:
  • Unable to run Blender 2.8. Crashes every time I try to open it. If you can help, I can provide the error printout.

Anyone else able to run blender using a different GPU?
 
Last edited:
Joined
May 10, 2019
Messages
16
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Raedon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Followed this and now on boot up I get stuck here:
 

Attachments

  • IMG_2822.jpeg
    IMG_2822.jpeg
    2.7 MB · Views: 205
Joined
Aug 2, 2012
Messages
54
Motherboard
10.8.3
CPU
Intel Xeon 2690
Graphics
GTX-660ti
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Hello, thank you for this great script as well.
Installed fine, updated everything, and now I see from the NVidia toolbar:
415248


My question is, I think I'm one of those users who's still struggling with
NVIDIA GeForce GTX 660 Ti 2047 MB
and its compatibility with High Sierra. I'm experiencing artifacts that render this OS install useless:
Screen Shot 2019-07-06 at 11.23.33 AM.png
This happens after about 20 minutes using the system, and almost immediately as I try some heavy photo processing applications.
Any advice on where should I go from here?

Just for additional info, I tried upgrading to Mojave, but for some reason I get panic on install that comes from apple kext, so I am waiting for Catalina to move out of beta 2 a few month.

Thank you.
 
Top