Contribute
Register

nvidia-update - Simple way to install nVidia web drivers

Joined
Nov 6, 2010
Messages
97
Motherboard
Gigabyte H370M-DS3H
CPU
i7-8770
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I have been using hackintosh system nearly for years. I was always following the guidlines of tonymacosx site. Now I felt like pissed off. I was building my new system according to tonymacosx buyer's guide, like I did before many years ago. I didn't read forums recently, because I didn't have time for that. So I went for tonymacosx buyer's guide. I saw many nvidia cards in the recommended section. I chose one gtx 1060 from there. However, I didn't notice that nvidia graphics are not supported by mojave. I thought buyer's guide is o.k. I ordered gtx 1060 card and it arrived, and I just started read this forum about the installation then I realized the nvidia gtx1060 still not supported in mojave. Ooops! I have the card I cannot return it here my country. I can't use it with mojave.
Please remove nvidia graphics from your buyer's guide section if it is not supported by the latest macosx os mojave. I trusted tonymacosx buyer's guide but it let me down....
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,318
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I trusted tonymacosx buyer's guide but it let me down....
Buyer's Guide said:
PLEASE NOTE: NVIDIA has not released graphics drivers for MacOS Mojave yet- for now AMD Radeon graphics are the only non-Intel graphics that work in MacOS Mojave.
 
Joined
Jul 29, 2012
Messages
144
Motherboard
ASRock Z390 Phantom Gaming ITX
CPU
i9-9900K
Graphics
RX 5700
Mac
  1. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Today I updated my High Sierra installation to the latest 10.13.6 and now this script doesn't work. Nvidia logo in the task bar shows that I'm using Nvidia drivers but I have zero acceleration and only 7mb graphics memory shown in "about this mac".. Any thoughts?
 
Joined
Jan 20, 2018
Messages
129
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8086K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
I just installed the latest Nvidia webdriver, reboot > works
 
Joined
Apr 18, 2011
Messages
170
Motherboard
Dell Precision 3620
CPU
Xeon E1275v5
Graphics
nVidia GT 730
GeForce 750Ti 2Gb

Worked perfectly last time I used it on Sierra.
Skipped High Sierra.
Tried Mojave 10.14.2
It works OK-ish with just Clover nVidia inject.

But decided to try the latest .113 web drivers anyway (even there would be no acceleration & in fact these drivers give nothing more)
But on reboot only get error and no display

Symbols are unresolved
Kext com.nvidia.web.GeForceWeb failed to load (error 0xdc008016)

Seen same error mentioned here
Code:
h t t p : / / bbs_pcbeta_com/viewthread-1790691-1-1_html

Anybody has any ideas? (no problem if not)

I wonder if that is due to by the script for force installation?

https://i.postimg.cc/W4f9h5z1/IMG-1817.jpg

 
Last edited:
Joined
May 20, 2012
Messages
24
Motherboard
GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
GTX 980 Ti
Mac
  1. iMac
Mobile Phone
  1. Android
Today I updated my High Sierra installation to the latest 10.13.6 and now this script doesn't work. Nvidia logo in the task bar shows that I'm using Nvidia drivers but I have zero acceleration and only 7mb graphics memory shown in "about this mac".. Any thoughts?
Did you ever find a solution. IM in the same boat.
 
Joined
Feb 24, 2018
Messages
40
Motherboard
Asus Maximus Hero IX
CPU
I7-7700K
Graphics
Vega 64
Mac
  1. iMac
I was always able to get nvidia graphics working up to and including 10.13.6. However with the lack of support in Mojave I moved AMD last fall. I'd recommend to anyone struggling with nvidia to do the same. Its just so much easier having native support. I went with the
Sapphire 11265-09-20G Radeon Pulse RX 580 4GB GDDR5 and have not regretted the switch.

This is literally what I recently did, I sold the 1070 and bought a Sapphire Vega 64, I was getting lag on the mouse and now it worked smoothly without issues.
 
Joined
Jul 22, 2013
Messages
50
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 590
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I just did a clean install of 10.13.6 (moving up from Sierra), and the OS X native drivers were possibly not working well. I get these weird artifacts all over my screens. Unfortunately I somehow ended up with build 17G2208 of High Sierra, which was apparently intended for laptops. About to restart after running this script; hopefully the 387.10.10.10.40.118 driver will fix the issue, since NVIDIA will not be releasing a driver specifically for 17G2208.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,449
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
About to restart after running this script; hopefully the 387.10.10.10.40.118 driver will fix the issue, since NVIDIA will not be releasing a driver specifically for 17G2208.
Update to the latest macOS High Sierra build 17G5019 - See here
Nvidia Web Driver available here.
 
Top