nvidia-update - Simple way to install nVidia web drivers

So is this last one a bad release? (talking about the nvidia driver)

I guess it's somewhat subjective, presumably the new drivers fix or improve something.

However, based on user feedback, the general consensus is yes, they're bad. Hence why they've been added to the blacklist.
bash: /dev/fd/63: Permission denied

bash-3.2$ (23) Failed writing body

Your error actually has nothing to do with nvidia-update, curl isn't working. Unfortunately, if you can't get curl to work then your system is likely in a pretty bad state.

I'd suggest launching Disk Utility and running "First Aid" on your disk. Hopefully it's just a permissions issue. Otherwise, something even more funky is going - unfortunately I can't really help you much beyond that. You can try running with sudo, but it really shouldn't be necessary.
Waaaaait... hold up.

@kingkongw24 Ignore my previous post. You've not copied the complete command. Please copy and paste the complete command.

OMG, that was such a noob mistake. thank you so much for clarifying this for me lol.

its now running, and asked for the password and now installing .106

Thank you so much!!

Rebooted and now BAM! thank you so much.
Last edited:
Absolutely! Here is my entire EFI Drive Compressed. I hope this helps someone and saves them from what I had to go through LOL. Here's my hardware...

ga-z270x-Gaming 5

Good Luck Guys!
I will create a final build thread as well.

Wohooo !!

Been trying like crazy to get this working, and your EFI folder finally did the trick ! :D

One thing I noticed though was that the driver I got installed is .102
At one time after one of my earlier attempts, I did get the .156 installed. I've just used the script to install.

What is it that determines what version gets installed ?


Well not is all good it seems. If I boot from my USB stick to get to clover and then into MacOS alls is good. However if I boot from the UEFI OS (I assume this is what MultiBeast provides) then into MacOSI don't get the drivers running.

It also seems that if I update MacOS, after a restart there's still an update (the same) to install. Very strange. :D
Last edited:
I tried 161 and chrome was sloooooow, went back to trusty old 103 (patched) and all is well again.
Hey, I was wondering... does a bad web driver can affect proper shutdown?
Up until today, i was using my hack with half the time shutdown working properly and half of the time the hack would
start if I move the mouse or touch the keyboard even though its all disabled in the BIOS, I never actually gave it a second thought and was just happy that my hack worked.

But then after using this method of installing a web driver suddenly my hack shuts down properly and won't wake up if I touch the mouse or the keyboard, could it be related?
was I just blindly installing web drivers just because they were "new and compatible"?