Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for OS X 10.11.6 (346.03.15)

Status
Not open for further replies.

MacMan

Administrator
Staff member
Joined
Feb 2, 2010
Messages
7,987
Motherboard
ASUS TUF Z390-PRO GAMING - 2606 - UEFI
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS

WonkeyDonkey

Moderator
Joined
Aug 31, 2010
Messages
3,898
Motherboard
Asrock Z87E-ITX
CPU
i7-4770S
Graphics
GTX 760
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Joined
Feb 17, 2014
Messages
38
Motherboard
GA-H170-Gaming 3
CPU
i7 7700K
Graphics
GTX 780
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi i need your help im stuck.

After security update my Hackintosh stop sending video signal to my monitor. However it is still working i can use it by teamviewer. I installed new drives WebDriver-346.03.15f06.pkg but no video yet.

I need to modify something?

Thanks in Advance!

Hi I just solved it was a problem with my system definition i have iMac17,1 so i need to patch kext i used Clover Method 1.

Problem 4: Monitor goes to sleep at the end of the boot sequence when using iMac15,1 or iMac17,1 or MacPro 6,1 system definition

Fix: modify the AppleGraphicsDevicePolicy.kext as pointed out by PikeRAlpha here. We have two options, using Clover's built in kext patching (preferred) or manually editing the kext. Using Clover to patch the kext on the fly is preferred because it does not get over written after each OS X update. If you do it manually you will have to make the edits after each update.

Method 1:

NOTE:
This method does not currently work with macOS Sierra 10.12, please use method 2 below and run the AGDPFix v1.3 utility.
  1. Open your Clover config.plist using text edit and scroll till you see <key>KernelAndKextPatches</key>
  2. In that section you will want to add the following:

    <key>KextsToPatch</key>
    <array>
    <dict>
    <key>Comment</key>
    <string>(c)Pike R. Alpha</string>
    <key>Find</key>
    <data>
    Ym9hcmQtaWQ=
    </data>
    <key>Name</key>
    <string>AppleGraphicsDevicePolicy</string>
    <key>Replace</key>
    <data>
    Ym9hcmQtaXg=
    </data>
    </dict>
  3. Save your config and now your kext will be patched when you boot by changing board-id to board-ix.


Method 2:


Use Shilohh's AGDPfix found here: http://www.tonymacx86.com/threads/b...-imac-15-or-imac-17-system-definition.183113/


Method 3:


  1. Open Terminal
  2. Enter this command (it is one line)

    sudo nano /System/Library/Extensions/AppleGraphicsControl.kext/Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/Info.plist
  3. Arrow down to where you see <key>ConfigMap</key>
  4. For the iMac15,1 locate the board-id "Mac-42FD25EABCABB274" and change string below it from "Config2" to "none". For the MacPro6,1 you will do the same thing but for the board-id "Mac-F60DEB81FF30ACF6". For the iMac17,1 you'll have to see which board-id is declared in your config.plist SMBIOS: "Mac-B809C3757DA9BB8D" or "Mac-65CE76090165799A" or "Mac-DB15BD556843C820" and change the appropriate entry to "none".
  5. Save the file by pressing Ctrl+O, then enter.
  6. Exit by pressing Ctrl+X
  7. Rebuild the kernel cache using the following two commands in terminal:


    sudo kextcache -system-prelinked-kernel
    sudo kextcache -system-caches
  8. Reboot


NOTE:
you may need to use kext-dev-mode=1 if not already using it to allow the modified kext. For El Capitan you will need to at least partially disable SIP to allow the now unsigned kext.

----------------------------


I Hope this could help someone.

Kindle Regards!
 
Joined
May 19, 2016
Messages
11
Motherboard
MSI H97 GAMING 3
CPU
i7-4790K
Graphics
GTX 960
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi i need your help im stuck.

After security update my Hackintosh stop sending video signal to my monitor. However it is still working i can use it by teamviewer. I installed new drives WebDriver-346.03.15f06.pkg but no video yet.

I need to modify something?

Thanks in Advance!

Try boot with nv_disable=1

Then install the nvidia web driver
 
Status
Not open for further replies.
Top