Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for OS X 10.11.4 (346.03.06)

Joined
Jan 14, 2011
Messages
64
Motherboard
Gigabyte Z390 M Gaming
CPU
i7-9700K
Graphics
RX 590
Mac
  1. MacBook Pro
just like me, now i disabled GPU performance on both Pts and Ai to fix those errors, then it runs a bit slow :banghead:

I tested Photoshop quickness. Almost no difference whether the graphics card is turned on or not.


MBP mid 2012, GTX 650 512 MB, 16 GB RAM
10.9.5


PS 2015.1.2
Load a picture: 0,2 s
Test With GraKa: 16 s
Test without GraKa: 16 s

PS CS 6
Load a picture: 0,2 s
Test With GraKa: 15 s
Test without GraKa: 16 s

PS CS 5
Load a picture: 0,2 s
Test With GraKa: 18 s
Test without GraKa: 17 s



Hack i5-4690k, GTX 960 4GB, 8 GB RAM
10.114

PS 2015.1.2
Load a picture: 0,1-0,2 s
Test With GraKa: 14 s
Test without GraKa: 15 s

PS CS 6
Load a picture: 0,2 s
Test With GraKa: 12-13 s
Test without GraKa: 13 s

PS CS 5
Load a picture: 0,2 s
Test With GraKa: 12-13 s
Test without GraKa: 12-13 s
 

Attachments

  • Photoshop Speed Test.zip
    2.7 MB · Views: 143
Joined
Jan 13, 2011
Messages
12
Motherboard
ASUS H170I-PLUS D3
CPU
i3-6100
Graphics
GT 710
Mobile Phone
  1. Android
Hi! I'm using Adobe Photoshop CC 2015 with this version of graphics drivers (340.03.06) and this adjusts on "Preferences" without troubles. But if I adjust to "Drawing Mode to "Advanced"....... squares, and more squares.
 

Attachments

  • Captura de pantalla 2016-03-25 a las 1.34.40 p.m..png
    Captura de pantalla 2016-03-25 a las 1.34.40 p.m..png
    341.1 KB · Views: 496
Joined
Mar 24, 2016
Messages
4
Mac
Classic Mac
Mobile Phone
Hi guys, I cannot get my asus GTX 750 1GB card to run. When I switch to nvidia web driver & reboot it goes back to the OS X default graphic card driver. Searched and i found have to add "nvda_drv=1" in to the boot flag, but when i do this i got a black screen. Any suggestion for my case? Thanks.
I'm using this driver and OS X 10.11.4
 
Joined
Jul 18, 2014
Messages
25
Mac
Classic Mac
Mobile Phone
Am I imagining things, or does 10.11.4 add native support for Maxwell GPUs? I took the 10.11.4 update through the App Store, and when I've done that in the past, I've had to manually set the nv_disable=1 boot flag to get it to boot so I can install the latest nVidia driver, then reboot with nvda_drv=1 as usual. This time when taking the update, it rebooted while I was out of the room, and booted just fine without me changing any boot flags. It claimed to be using the native driver. Transitions, etc. were nice and smooth, unlike what happens when booting with nv_disable=1, but all of the translucency effects (in the dock, Finder windows, etc.) were gone, as you would expect.

So, either 10.11.4 supports Maxwell natively (albeit incompletely), or the 10.11.3 nVidia driver partially works under 10.11.4 with the nvda_drv=1 flag.

I guess the way to test that without messing too much with my system would be to make a fresh Unibeast installer with the 10.11.4 installer and see if that boots without nv_disable=1. Not sure I want to download a 6.20 GB file just for that, though...

EDIT: This was on a GTX 960.
 
Joined
Feb 19, 2016
Messages
26
Motherboard
Gigabyte GA-Z170X G5
CPU
Intel i7 6700K
Graphics
Asus STRIX GTX1070
Mobile Phone
  1. iOS
Hi! I'm using Adobe Photoshop CC 2015 with this version of graphics drivers (340.03.06) and this adjusts on "Preferences" without troubles. But if I adjust to "Drawing Mode to "Advanced"....... squares, and more squares.

This was the case in 10.11.3 as well. The new web driver is doing it as well, however the beta driver seems so far to not cause this issue for me. Photoshop seems to be dog slow though for some reason with a canvas of only 5120x2440 (quad size of screen resolution) my old 2011 27" iMac handled this much better (ati 6990m as far as i remember).

Noticed btw with the beta driver at least if photoshop is in normal view mode the gpu mem was running 400ghz, gpu core 891mhz, when switching to fullscreen w menubar, 1.2mhz on gpu core and 6ghz on gpu mem and it seemed to be a lot faster but still not as fast as on the 2011 27" iMac.. go figure

Tested on Skylake 6700k, gtx970, 32gb mem, Wacom 27QHDT.
 
Joined
Jan 14, 2011
Messages
64
Motherboard
Gigabyte Z390 M Gaming
CPU
i7-9700K
Graphics
RX 590
Mac
  1. MacBook Pro
This was the case in 10.11.3 as well...

Tested on Skylake 6700k, gtx970, 32gb mem, Wacom 27QHDT.


Hello.
Test your machine with my PS Speed test (above as an attachment)! My hack with 4690K and 8 GB RAM is slightly faster than MBP 2012 i7-3615 and 16 GB RAM. See my results above.
 
Joined
Feb 19, 2016
Messages
26
Motherboard
Gigabyte GA-Z170X G5
CPU
Intel i7 6700K
Graphics
Asus STRIX GTX1070
Mobile Phone
  1. iOS
Both with gfx accell and without where ~8sec..
 
Joined
Aug 24, 2011
Messages
32
Motherboard
Gigabyte Z170X Gaming 7
CPU
i7 6700 SkyLake
Graphics
Titan X
Mac
Classic Mac
Mobile Phone
Hi guys, I cannot get my asus GTX 750 1GB card to run. When I switch to nvidia web driver & reboot it goes back to the OS X default graphic card driver. Searched and i found have to add "nvda_drv=1" in to the boot flag, but when i do this i got a black screen. Any suggestion for my case? Thanks.
I'm using this driver and OS X 10.11.4

I had a similar problem I changed the SMBIOS back to: McPro5,1 and fixed the black screen
 
Joined
Mar 24, 2016
Messages
4
Mac
Classic Mac
Mobile Phone
I had a similar problem I changed the SMBIOS back to: McPro5,1 and fixed the black screen

Thanks but tried this and i got a kernel panic. :mrgreen:. I'll wait for another solution.
My spec : MSI B75-G43, i3 3240, GTX 750. Thank you
 
Joined
Aug 2, 2011
Messages
27
Motherboard
I still didn't read
CPU
the RULES
Graphics
so ignore me
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have the gtx 980 ti, now I have the new version OS X 10.11.4 and nothing works for me, I just can boot with nv_disble=1

Help me please ..!
 
Top