Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for OS X 10.11.1 (346.03.03)

Joined
Sep 30, 2015
Messages
44
Motherboard
Asus P8H61-I r2.0
CPU
i7-3770K
Graphics
R9 290X
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
iOS
Here's a quick method to update from 10.11.0 if you have a Maxwell card. The older drivers package does not work with 10.11.1.

If you're using a NVIDIA 'Maxwell' GeForce GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, or TITAN X graphics card:

1. Install the 10.11.1 update, and reboot.
2. At Clover boot screen click Options
3. Press Enter on Boot Args line and add nv_disable=1 boot argument, then press Escape
4. Boot into system with no graphics acceleration
5. Install the new drivers.
6. Reboot normally.

:thumbup:
when I add nvda_drv=1 .. it will just boot black screen.. when I boot inject nvidia flickering screen and this
Screen Shot 2015-10-22 at 3.34.04 PM.jpg

when i try no nvidia inject.. flickering screen and web driver is not being selected -.- argh this is pissing me off 2 days fixing it .. still no luck... :(( can somebody help me????!!
 
Joined
Sep 10, 2015
Messages
14
Motherboard
ThinkPad T440P 20AN006MUS (Clover)
CPU
i7-4600M
Graphics
HD 4600 + GT 730M (1600x900)
Mac
iMac
Mobile Phone
Android
when I add nvda_drv=1 .. it will just boot black screen.. when I boot inject nvidia flickering screen and this
View attachment 158128

when i try no nvidia inject.. flickering screen and web driver is not being selected -.- argh this is pissing me off 2 days fixing it .. still no luck... :(( can somebody help me????!!
Have you tried booting into verbose mode with nvda_drv=1? That did it for me.
 
Joined
Dec 13, 2013
Messages
12
Motherboard
Asus P8H61-M LE USB 3.0
CPU
Core i3 2100 (2nd Gen) 3.1Ghz
Graphics
ASUS GTX 750Ti OC 2GB
Mac
MacBook Pro
Classic Mac
Mobile Phone
Hi,

I have Asus GTX 750Ti and I update 10.11 to 10.11.1 I have a correct resolution which is 1366x768 but it can't detect my Nvidia Card, it say's "Display 4Mb" sometimes "NVidia GTX 750Ti 0MB".

I already installed latest NVidia web driver (WebDriver-346.03.03f01) and I used nvda_drv=1 for my clover boot flag. But still have problem on display. (Slow movement because of flickering white horizontal lines).

Thank you very much
 
Joined
Oct 22, 2015
Messages
8
Motherboard
GA-Z97-D3H
CPU
i7-4790K
Mac
Classic Mac
Mobile Phone
Android
Dear Tony, please tell me, this card will be supported? EVGA GTX 970 FTW +. I want to buy it, but very much afraid that it will not operate correctly at Hackintosh. :headbang:
 
Joined
Jun 15, 2012
Messages
417
Motherboard
Z370 AORUS Gaming 7-F13
CPU
i7-8700K OC @ 5.1Ghz
Graphics
GTX 1080 Ti
Mac
MacBook Pro, Mac Pro
Classic Mac
Performa
Mobile Phone
iOS
Is it possible to install the updated driver before you update to 10.11.1 so you don't have to touch boot flags?
Yes. It's actually how I like to do it. you'll need Flat Package Editor

1. Download the 10.11.1 driver package. Open it in FPE. Extract distro file.
2. Open it in textedit or whatever. Change system version check from 10.11.1 to 10.11.0 and build number to 10.11.0's build number. Save changes.
3. Delete the distro file that's in the package now, within FPE app.
4. Copy edited one in it's place. Save package and close FPE
5. Run installer. Now installer will happily install 10.11.1 driver into 10.11.0. DO NOT RESTART WHEN INSTALLER IS DONE
6. This will sound awkward, but once the install is finished and asking you to restart, force quit installer. This is required otherwise the 10.11.1 installer will throw an error because of the other "in progress" install (that's actually good and done now).
7. Run 10.11.1 update. When this asks you to reboot, it's ok to do so this time.

VERY IMPORTANT. Once you've installed 10.11.1 driver you must make sure you install 10.11.1 update right away. If you reboot at all before 10.11.1 is installed, the new driver you installed won't run on 10.11.0 if you reboot before updating to 10.11.1.
 
Joined
May 15, 2011
Messages
259
Motherboard
ASrock z370 Fatal1ty Gaming mini-ITX/ac
CPU
Intel Core i7 8700K @ 3.7GHz (4.7GHz Turbo)
Graphics
Intel UHD630/Gigabyte GTX 1070 Mini ITX
Mac
Mac Pro
Mobile Phone
iOS
After installing the new driver I get this. No nvd or nv disable command works. :(

lol, apparently it works if you DO NOT use nvda_drv=1. So, after the update, remove nvda_drv=1 command from boot flags, then it should work.
 

Attachments

Joined
Mar 10, 2013
Messages
31
Motherboard
Asus Sabertooth Z97 M2
CPU
i5-4690k
Graphics
Asus GTX 960
Mac
iMac
Classic Mac
Mobile Phone
I use 10.11.1 update over 10.11GM. After update I got massage that need to update web drivers. I did it and restart. No problems boot with Strix GTX 960 (nvda_drv=1) everything works but noticed that Memory stuck on 810Mhz minimum in HWmonitor. So memory clock can rise but not downclock and stay on 810Mhz....Is that bug or reality?
 
Joined
Jan 3, 2011
Messages
371
Motherboard
Asus TUF Sabertooth X99
CPU
Intel Core i7 5950k @ 4.4Ghz
Graphics
Radeon RX Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
it just go black screen.. it won't boot up :(
Hi, was this happening with El Capitan 10.11 or is this happening with 10.11.1 only?

Were you able to fix the problem?
 
Top