Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS Sierra 10.12.6 (378.05.05.25)

Joined
Jul 18, 2017
Messages
1
Oh my god, I have been trying to make my GTX 1070 work on 10.12.4. Thought why not try out 10.12.6 and the new driver and it FINALLY WORKS!!! Thanks so much!
 
Joined
Aug 2, 2012
Messages
35
Motherboard
ASUS ROG RAMPAGE V EDITION 10
CPU
E5-2696 v4
Graphics
Vega 64
Mac
  1. Mac Pro
I just came here to say that this update installed this morning has fixed a load of problems I was having on my recent build - GTX1080 Sierra Asus Maxiumus IX 7700K o/c 4.5GHz 64Gb.

I was having problems with my 3 screens not being detected at initial boot, black screens and Xcode not displaying 3D assets in the SceneKit editor - now they all seem to be working! outstanding!
How? Do you have the Lilu.kext or have you applied the AGPDFix? Can you tell us which steps you've done? What's your config.plist?
I updated and I still have the 3 screens problem on initial boot. Deep sleep problem on multiple display is still present too.

Thanks!
 
Joined
Sep 23, 2016
Messages
25
Motherboard
GA-Z270M-D3H
CPU
I7 7700
Graphics
ASUS ROG STRIX GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
How? Do you have the Lilu.kext or have you applied the AGPDFix? Can you tell us which steps you've done? What's your config.plist?
I updated and I still have the 3 screens problem on initial boot. Deep sleep problem on multiple display is still present too.

Thanks!
i just installed sierra 10.12.6 today. everything works fine except the asus gtx1080 graphic card. it just wont detect it.
i have the lilu.kext and nvidiafixup one too, i tried all iMac 14,1 and 14,2 and 17,1 and 18,1 and many none work. i have web drivers enabled in the config.plist and also the latest web drivers installed in the hackintosh rig.
(p.s. i m on kaby lake i7 7700) can you suggest me a fix ?
also added ssdt-uiac.aml (dont know what it is for but a guide said so did it.)
also inject intel is deselected.
 
Joined
May 28, 2017
Messages
2
Motherboard
Asus b150m-c/br
CPU
i7 6700
Graphics
GTX 970
Mobile Phone
  1. iOS
Hi.

I have a GTX 970 and I'm trying to install the 10.12.6 driver.

After the instalation I go to the settings and try to change from the default nvidia drivers to the web driver, when i make the change it asks to reboot, but it always comeback to the other option, it won't stick.

My mobo is b150m-c/br

And I'm having trouble with sound too.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,818
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hi.

I have a GTX 970 and I'm trying to install the 10.12.6 driver.

After the instalation I go to the settings and try to change from the default nvidia drivers to the web driver, when i make the change it asks to reboot, but it always comeback to the other option, it won't stick.

My mobo is b150m-c/br

And I'm having trouble with sound too.
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you

BIOS - Disable Integrated graphics - Set PEG as Primary
Use a digital connection - DVI or HDMI - VGA is not supported.
Boot with nv_disable=1
May need to update Clover
Install web drivers
Config.plist - Do not inject Intel or Nvidia graphics and no ig-platform-id
Config.plist - Disable SIP fully - CsrActiveConfig 0x67
Edit config.plist - NvidiaWeb = true as per Link
May need to emulate native NVRAM - Problem 6
Remove nv_disable=1 from config.plist
May need to install Lilu.kext and NvidiaGraphicsFixup.kext to /Library/Extensions
 
Joined
May 30, 2016
Messages
570
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
  2. SE/30
Mobile Phone
  1. iOS
Hi.

I have a GTX 970 and I'm trying to install the 10.12.6 driver.

After the instalation I go to the settings and try to change from the default nvidia drivers to the web driver, when i make the change it asks to reboot, but it always comeback to the other option, it won't stick.

My mobo is b150m-c/br

And I'm having trouble with sound too.

sounds like your motherboard dosent support nvmam. have to load EmuVariableUefi-64.efi for it to remember the change.
 
Joined
May 28, 2017
Messages
2
Motherboard
Asus b150m-c/br
CPU
i7 6700
Graphics
GTX 970
Mobile Phone
  1. iOS
BIOS - Disable Integrated graphics - Set PEG as Primary
Use a digital connection - DVI or HDMI - VGA is not supported.
Boot with nv_disable=1
May need to update Clover
Install web drivers
Config.plist - Do not inject Intel or Nvidia graphics and no ig-platform-id
Config.plist - Disable SIP fully - CsrActiveConfig 0x67
Edit config.plist - NvidiaWeb = true as per Link
May need to emulate native NVRAM - Problem 6
Remove nv_disable=1 from config.plist
May need to install Lilu.kext and NvidiaGraphicsFixup.kext to /Library/Extensions

sounds like your motherboard dosent support nvmam. have to load EmuVariableUefi-64.efi for it to remember the change.

After a lot of fight i managed to make it work.

Follow the P1LGRIM steps.

Thanks guys
 
Top