Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS Sierra 10.12.6 (378.05.05.25)

Joined
Mar 1, 2011
Messages
41
Motherboard
Mac Pro 6,1
CPU
i7-4960X
Graphics
NVIDIA GTX970
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
I´m in the same way. GTX-970 + X79-UDP4 mainboard.

- Sierra 10.12.6 (16G1314)
- Nvidia WebDriver-378.05.05.25f07
- Webdriver Boot Flag
- uncheck nv_disable = 1
- iMac 14,2
- nvram
- Clover 4411

No kernel loaded, so... no screen acceleration. 4K panel running in 1600x1200 Resolution


Any ideas to solve it?
 
Last edited:
Joined
May 31, 2016
Messages
504
Motherboard
Z170X-UD5 TH
CPU
6700K
Graphics
GTX1080 (Asus ROG Strix)
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
PowerBook, Quadra
Mobile Phone
iOS
Security Update 2018-002 (10.12.6 16G1314) breaks Quicksync functionality (encode and decode), as least on iMac 17,1 (Z170/6700K)

Lilu 1.2.3
Shiki 2.2.6
NvidiaGraphicsFixup 1.2.4

Edit: False alarm. Quicksync still working. Took 6 rebuilds of the Dyld Cache:
Code:
sudo update_dyld_shared_cache -force
 
Last edited:
Joined
May 9, 2015
Messages
34
Motherboard
Gigabyte GA-Z97N-WIFI
CPU
Intel i5-4460
Graphics
Gigabyte GTX 960 2GB
@ all:

Any solution for 10.12.6 and the Nvida driver problem = graphic Display 7 MB? thanks
 
Joined
Nov 23, 2015
Messages
15
Motherboard
Asus Z97 Gryphon
CPU
i7 4790K
Graphics
Nvidia GTX 750
Mac
MacBook Pro
Mobile Phone
iOS
I had the same problem with a GTX 970 after the 10.12.6 security update.
Updated to the latest web + CUDA driver... still stuck at 1080p resolution.

I saw the suggestions above regarding nvda_drv etc, and since I was on an old version of Clover (39xx) I updated to the latest one.

Now stuck in a reboot loop. Any ideas ?

At this point I'd like to completely nuke the Clover config or even start again from Unibeast and upgrade to High Sierra.


 
Joined
Oct 2, 2017
Messages
6
Motherboard
Gigabyte AORUS GA-Z270X-Gaming 7 - 1.0
CPU
Intel Core i7 7700K - 4.2 GHz
Graphics
Gigabyte GeForce GTX 1070 G1 Gaming
I fixed it after i tried all the options.
My fix was:

NO flag at all in Plist Boot. NOR nvda_drv=1 NOR nv_disable=1
both off and it worked.
At graphics section also no flags at all.
smbios 14,2 Imac

Multibeast:
Boot mode + Emulated NVRAM was essential.
 

Attachments

Joined
Mar 15, 2017
Messages
82
Motherboard
ASUS X99-A II
CPU
i7 6800K
Graphics
GTX 1080Ti
Mac
MacBook Pro
Mobile Phone
iOS
it seems that nv updated the driver for 10.12.6 to f08 without any new release of security update. do any one know what is the diff?
 
Joined
Feb 9, 2011
Messages
26
Motherboard
GA-P55A-UD4 (rev. 2.0)
CPU
Intel Core i5 760
Graphics
AMD R9 280X
Mac
Mac mini
Classic Mac
Power Mac
No idea, but of note is that f07 is no longer in the Nvidia's Apple Updater XML, just f06 and the latest f08. So I guess some kind of hotfix on their part.

EDIT: Just updated (with updated Clover just to be sure), and no problems, single restart and up and running with f08...
 
Last edited:
Joined
Jun 18, 2010
Messages
81
Motherboard
z170x ud3 ultra + clover
CPU
6700k + z170
Graphics
1080 gtx 2560 x 1440 x2
Mac
iMac, MacBook Pro, Mac mini, Mac Pro
Classic Mac
128K, 512K, Classic, Lisa, Plus, Power Mac, PowerBook, Quadra
Mobile Phone
iOS
it seems that nv updated the driver for 10.12.6 to f08 without any new release of security update. do any one know what is the diff?
Update for Cuda 9.1 perhaps?
 
Joined
Dec 4, 2014
Messages
73
Motherboard
Asus Rampage IV Black Edition - 0801
CPU
i7-4820K
Graphics
GTX 1070 Ti
Mac
Mac Pro
I noticed that 1070 Ti is absent from the list of cards in the OP; Is that intentional or an oversight?
In the High Sierra 10.13.1 thread and onward it's listed.
 
Top