Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS Sierra 10.12.5 (378.05.05.15)

Joined
May 17, 2017
Messages
8
Motherboard
ASUS X99-AII
CPU
i7 3.4GHz 6-core
Graphics
NVIDIA GeForce GTX 980 4095 MB
Mac
Mac Pro
#13
I updated to 10.12.5 last night. After reboot I was on the default drivers, and got an NVIDIA update popup so went through with that. After finishing the NVIDIA update and a reboot, my displays go black as the graphics drivers are loaded at boot. I'm not able to get any video.

Any thoughts on the cause? Is there an easy way to roll back the drivers to the previous version? I wasn't having any video problems until the OSX update.

EDIT: fixed my problem by running AGDPfix.app again.
 
Last edited:
Joined
Feb 11, 2010
Messages
247
Motherboard
Gigabyte Z170N-Wifi
CPU
Intel i5 6600K
Graphics
MSI GTX 1050 TI 4GT LP
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
#14
Can I update the drivers first and then update to 10.12.5?
 
Joined
Apr 7, 2017
Messages
20
Motherboard
Asus h81m-cs/br
CPU
i5 4690k
Graphics
G1 Gaming 1060 6gb
Mobile Phone
iOS
#15
Anyone knows if this fix the HDMI audio problem with Nvidia GTX 10xx series ?
I using hackintosh for 2 months now, and I tried everything but my output HDMI still undetected in audio panel.
 
Joined
Mar 14, 2015
Messages
129
Mobile Phone
Android
#16
Anyone knows if this fix the HDMI audio problem with Nvidia GTX 10xx series ?
I using hackintosh for 2 months now, and I tried everything but my output HDMI still undetected in audio panel.
tried following toleda's DSDT patching guide?web drivers aren't going to fix HDMI audio in any of the cards :p
@niclasc no the update will show after you boot to 10.12.5
 
Joined
Jun 16, 2010
Messages
180
Motherboard
Gigabyte GA-Z270X-Gaming-K7
CPU
i5-7600K
Graphics
RX 560
#17
Unfortunately, the updated drivers did not fix the wake-up from sleep problem of a scrambled and flickering screen for GTX 1060 owners. :(
Lol, Drivers Don't Work For My GTX 1060 6GB, What A Shame -_-.
Really? I had that happen only once under 10.12.4 but haven't had it happen since - even after updating to 10.12.5 and the latest Web Drivers. I'm using a DP cable, if that makes any difference. I'll check it again when I get home from work later.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,366
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
#18
Really? I had that happen only once under 10.12.4 but haven't had it happen since - even after updating to 10.12.5 and the latest Web Drivers. I'm using a DP cable, if that makes any difference. I'll check it again when I get home from work later.
I'm using two DVI connections for dual monitor use.
 
Joined
Jun 16, 2010
Messages
180
Motherboard
Gigabyte GA-Z270X-Gaming-K7
CPU
i5-7600K
Graphics
RX 560
#19
I'm using two DVI connections for dual monitor use.
Just woke mine up from sleep. Video is fine with my GTX 1060 (Although it's giving me the "* did not eject properly" external drive message).
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,366
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
#20
Just woke mine up from sleep. Video is fine with my GTX 1060 (Although it's giving me the "* did not eject properly" external drive message).
What are the boxes checked in your System Preferences Energy Saver pane?
 
Top