Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS Sierra 10.12.0 (367.15.10.05)

Joined
Sep 8, 2011
Messages
29
Motherboard
Asrock H97M-itx/ac
CPU
i7 4770k
Graphics
Asus GTX 970 mini 4GB
Mobile Phone
Android, iOS
i upgrade from EI to Sierra.
And installed the latest Nvidia Web driver for my GTX970.
Unfortunately, i cannot startup properly after reboot. And i cannot modify the config.plist on Clover boot manager.
Anyone can help or tell me how to add "NvidiaWeb=1" on Clover boot manager ?
Thank a lots
 
Joined
Jul 6, 2013
Messages
177
Motherboard
Z170N-Gaming 5
CPU
i5 6600k
Graphics
GTX 950 Ti Boost
Mac
MacBook Pro
Mobile Phone
iOS
I have it working on 17,1 Sierra - no problem (not on a z170 though but on an Maximus VIII Hero)
What did you have to do?
 
Joined
Jan 2, 2015
Messages
34
Motherboard
ASUS H97M-E
CPU
Intel i5 4460
Graphics
MSI GTX 750 2GB
Mobile Phone
i upgrade from EI to Sierra.
And installed the latest Nvidia Web driver for my GTX970.
Unfortunately, i cannot startup properly after reboot. And i cannot modify the config.plist on Clover boot manager.
Anyone can help or tell me how to add "NvidiaWeb=1" on Clover boot manager ?
Thank a lots
Here's the thing. I couldn't boot either. My PC would skip Clover and boot straight to Windows.
But, I have a dualboot system, on the same SSD. And UEFI wasn't showing Clover in hardrive boot order. Just Windows Boot Manager.

I couldn't boot after upgrading to Sierra, either.
Here's what I did:
1. Boot from USB (any Mac OS X USB, I've actually previously created macOS Sierra USB, just in case something goes wrong. An El Capitan Installation USB will do just fine (I think).)
2. Even that required some changes while booting. You need to NOT USE safe mode, otherwise you can't mount EFI later (I couldn't). Try verbose & without caches. I had a few kernel panics, also... Anyways, whatever works for you, just get it to boot in your installation.
3. After booting, use efi mount script v3, and after mounting, go to /EFI/Microsoft/Boot/ , find bootmfgw.efi & rename it, to something like bootmfgw.efi.bckp
4. After that, Restart, go to BIOS/UEFI, and change Hard Drive Boot priority, to whatever works for you. Personally, BIOS made a "UEFI OS..." entry for me.
5. But then again, I couldn't boot to Windows now, even though macOS worked.
6. So I mount EFI again, and just changed my .bckp back to bootmfgw.efi, since I made an option in BIOS to boot Clover. I thought I'd give it a shot, and it worked.
7. Restart & Boom, both work now, and Windows partition is selected as default, which is super nice, since before, it was macOS, and I use W10 a lot more. I couldn't change the default, back then, so this is nice.

Also, you can't edit config.plist with Clover Config. Use efi mount script, find config.plist and open with text editor, then add nvidia web, like tonymacx86 EXPLAINED.

My GTX 750 still works without that. Just got nvda_drv=1, like I had in El Cpt.

The thing is, I got everything except audio to work. After upgrading to Sierra, my audio is gone. I relied on multibeast before, to give me audio for ALC887 and now there's no multibeast for Sierra.
Funny thing is, I hear something coming from the speakers, like static, IDK, even though there are no audio devices shown

I just got dualboot to work again, haven't messed with the audio yet.
 
Joined
Dec 13, 2015
Messages
7
Motherboard
ASUS H170M-PLUS
CPU
i5-6600
Graphics
GTX970
I have it working on 17,1 Sierra - no problem (not on a z170 though but on an Maximus VIII Hero)
Can you explain the steps you had to do to get 17,1 working? It seems like lots of others are having problems.
 
Joined
Aug 22, 2012
Messages
68
Motherboard
MSI Z170A SLI PLUS
CPU
i7-7700K
Graphics
GTX 1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS, Other
Instantly restarts for me and my 970 unless I set my Onboard Graphics as my default option in my bios and use my 970 to power my secondary 4k monitor which works oddly. Sooo, I can use my onboard graphics and my 970 together but can't use just my 970 to boot. very weird.


UPDATE: ISSUE HAS BEEN FIXED WITH A SIMPLE CHANGE TO iMac 13,2... Working perfectly now
 
Last edited:
Joined
Jan 31, 2016
Messages
22
Motherboard
Gigabyte Z97X-UD3H
CPU
Intel i5 4690K
Graphics
EVGA GTX 750 FTW
Mac
iMac
Mobile Phone
Android
Top