Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.4 (387.10.10.10.30)

Joined
Nov 13, 2011
Messages
60
Motherboard
GA-Z77X-UD5H 10.13.6
CPU
i7 3770K
Graphics
2x GTX 980 Ti
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac Pro
Mobile Phone
iOS
Do I understand correctly that if I do, the second card won't function with the latest NVidia Driver and Cuda driver and I will need to install an older version?
Correct.
 
Joined
Jan 24, 2016
Messages
97
Motherboard
z170i
CPU
6700K
Graphics
Radeon 580
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
iOS
10.13.4 with 387.10.10.10.106 has solved all UI lags I was seeing. I was able to remove lilu and nvidiaGraphicsFixup as well.
Hmmm. This may have been present with .106, but I'm definitely noticing system freezes when closing tabs in Safari under .107. No more than a half second, but enough to be jarring. Anyone else observing this?
 
Joined
Mar 7, 2011
Messages
151
Motherboard
Asus Sabertooth Z170 Mark 1
CPU
i7-6700K
Graphics
GTX 1070
Mobile Phone
Android, iOS
Hmmm. This may have been present with .106, but I'm definitely noticing system freezes when closing tabs in Safari under .107. No more than a half second, but enough to be jarring. Anyone else observing this?
yes when loading new page or closing slight freeze
 
Joined
Aug 19, 2012
Messages
182
Motherboard
GigaByte Z390 AORUS Master
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Plus, Power Mac, Quadra
Mobile Phone
iOS
Hmmm. This may have been present with .106, but I'm definitely noticing system freezes when closing tabs in Safari under .107. No more than a half second, but enough to be jarring. Anyone else observing this?
Same here, this is starting to get really annoying. What is happening over at Nvidia? They seemed to be on top of this stuff, and now with the 3-4 recent drivers they seem to have issues.
 
Joined
Aug 19, 2012
Messages
182
Motherboard
GigaByte Z390 AORUS Master
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Plus, Power Mac, Quadra
Mobile Phone
iOS
Ok, downgraded to 378.10.10.10.25.106 and it seems to have made Safari a whole lot more responsive, and in addition I was having some weird artifacts and issues in Resolve 15 which now appear to be gone.

For anyone interested in how to revert back to 378.10.10.10.25.106, simply copy and paste this into your Terminal:

Code:
bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh) 378.10.10.10.25.106
 
Joined
Nov 13, 2011
Messages
60
Motherboard
GA-Z77X-UD5H 10.13.6
CPU
i7 3770K
Graphics
2x GTX 980 Ti
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac Pro
Mobile Phone
iOS
Same here, this is starting to get really annoying. What is happening over at Nvidia? They seemed to be on top of this stuff, and now with the 3-4 recent drivers they seem to have issues.
I have a hard time imagining NVIDIA changing their code base to not support multiple cards. That's just not in their interest. I think Apple screws this up big time.
 
Joined
Sep 13, 2010
Messages
35
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
Done, I solved the problem. I used partially this method.
After one week, nothing is good. :( After a few boot comes the message that the driver is incompatible with the system, and boot loop are the result.
1. I boot with recovery mode
2. remove the NVDAStartup.kext and set the SIP 0x0, and reboot
3. uninstall the Nvidia driver
4. reboot
5. install the Nvidia driver, set the SIP 0x67
6. boot with new Nvidia driver
7. All is done, everything is working fine (except the audio, that is lost), until few reboot or shutdown and boot and after the system is going the boot loop and everything starts from beginning. :(

I ran out of ideas.

boot-v.png
 
Last edited:
Joined
Sep 13, 2010
Messages
35
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
You could try pasting this into a terminal
Code:
bash <(curl -s https://vulgo.github.io/webdriver) 387.10.10.10.30.107
Now I'm try it. After installed the clean system, I installed the three kexts:
And after that, I ran the script.

Code:
bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh)
Now the system is done, and I go to sleep.
I'll see what's coming in the morning.
I will sleep with crossed fingers...
 
Joined
Sep 24, 2013
Messages
119
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
Vega
Mac
iMac, MacBook Pro
Classic Mac
eMac, iMac, Power Mac
Mobile Phone
iOS
Chili, if what you've done isn't enough, try the guide located here -- #265. We have similar systems, and I run the latest NVIDIA web driver 387.10.10.10.30.107 and CUDA driver 396.64. Both work perfectly on my system. Following #265, look at your settings in UEFI (BIOS). Don't use "OtherOS", set to "Windows 8". Set CSM to "Never". Follow the ILikeHackinosh guide. Drop MATS table. Use Dart=0. Cheers!
 
Last edited:
Joined
Dec 16, 2012
Messages
86
Motherboard
Gigabyte GA-Z77X-UP5-TH F12 (GA-Z77X-UP5-TH)
CPU
INTEL i7 3770K
Graphics
Radeon RX 580 8 GB (GV-RX580GAMING-8GD)
Mac
MacBook Pro
Mobile Phone
Android
387.10.10.10.30.107 finally fixed my graphic lagging issue !! it took like , 5 months for nvidia to realise the problem and fix it?? what a joke.
 
Top