Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.4 (387.10.10.10.30)

Status
Not open for further replies.
Joined
May 27, 2011
Messages
221
Motherboard
Asus Z370-A Prime
CPU
i7-8700K
Graphics
Vega 64
Classic Mac
  1. 512K
Mobile Phone
  1. iOS
The GUI is smooth indeed. Uningine benches are crashing. In Both, Valley and Heaven I see good performances but its not smooth, its lagging and eventually it wil stop and come back to the startup GUI of the benches. It looks like that explicit choose "Benchmark" instead of the demo makes it worse. Also Vsync lower settings make a difference but it will stop eventually. I see also sometimes a few "blue" artefacts in the forrest of Valley, when the screen freezes. Also games like Company Of Heroes 2 will crash after a while. Temps are fine. I hear the fan speed up and temps are not hitting above 70-72 degrees. No problems at all in windows.

Any idea? I think we are close indeed. But its not perfect yet.

P.S. this was a short version of the crash log of Company of Heroes 2

Code:
Crashed Thread:        15  Render Thread  Dispatch queue: OpenGLMT

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000058
Exception Note:        EXC_CORPSE_NOTIFY

and I see GPU Hung and GPU restarts in the logging:

Code:
com.apple.message.domain: com.apple.ioacceleratorfamily.gpu_hang
com.apple.message.responsible: true
com.apple.message.application_identifier: com.Unigine.Heaven
com.apple.message.application_version: 4.0
com.apple.message.device_name: NVIDIA GeForce GTX 1080 Ti

Code:
com.apple.message.domain: com.apple.crashreporter.writereport.gpuRestart
com.apple.message.signature: Kernel

It looks almost that's running too hot but the temps shows decent values. Also in Windows no issues at all.

I found the issue. It looks my card is dying. Well not dead but it can't keep up with the EVGA FTW3 factory clocks anymore (1569MHz Base Clock/1683MHz Boost Clock). Maybe the ambient temperatures which are 10 degrees higher then normal this issue is now appearing. In windows the issues were similar. Lagging / Crashing etc. Also DirectX Hung errors. I decided to start MSI Afterburner where I limited the total power usage to 90%. The results with this setting were that the OpenGL benches were smooth again. But its not possible to limit the power usage in OSX. So I flashed temporarily the EVGA to the EVGA Founders Edition where the fans are permanently active and with lower clocks. And now its stable again. Well much better.
I also found out that probably I'm not the only one. EVGA has recently introduced the FTW3 also with stock clocks calling it the
EVGA GeForce GTX 1080 Ti FTW3 DT.

full.png
 
Joined
Apr 12, 2011
Messages
94
Motherboard
GA-Z270X-UD5
CPU
i7 7700k
Graphics
Sapphire Nitro+ RX 580 8GB
Mac
  1. MacBook Pro
Classic Mac
  1. 128K
  2. 512K
  3. Classic
  4. Performa
  5. Quadra
Mobile Phone
  1. iOS
Wait peoples... You can't delete Lilu & NvidiaFixup while using iMac 17.x/18.x/MacPro6.x definitions.

?

I use the iMac 18,3 profile without Lilu or NvidiaFixUp on the latest web drivers and don't have any issues.
 
Joined
Feb 2, 2018
Messages
4
Motherboard
Asus ROG Maximus X Hero Z370
CPU
I7-8700K
Graphics
Gigabyte AORUS 1080 Ti Xtreme
Mac
  1. MacBook Pro
?

I use the iMac 18,3 profile without Lilu or NvidiaFixUp on the latest web drivers and don't have any issues.

i also removed nvidiaFixUp with the latest web driver and haven't noticed any issue. I'm on iMac 18,3, 1080 ti and 8700k (iGPU disabled).

I still keep Lilu around cuz i heard it's needed for sound and other stuff.
 

irz

Joined
Jul 11, 2017
Messages
58
Motherboard
ASUS Z170I Pro Gaming
CPU
i7-7700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Don't You use Hardware Encoding Support on your systems? If you using this option you should iGPU made ON/Auto. Also you need IntelFixup & nvidiaFixUp.
 
Joined
Feb 2, 2018
Messages
4
Motherboard
Asus ROG Maximus X Hero Z370
CPU
I7-8700K
Graphics
Gigabyte AORUS 1080 Ti Xtreme
Mac
  1. MacBook Pro
Don't You use Hardware Encoding Support on your systems? If you using this option you should iGPU made ON/Auto. Also you need IntelFixup & nvidiaFixUp.

i tried making it work but failed. Hardware encoding was detected in MacX, but didn't actually do anything. Intel Power Gadget shows 0 GHz on iGPU, and the BruceX test doesn't show any improvements at all. So I turned it off..
 
Last edited:
Joined
Jul 13, 2016
Messages
8
Motherboard
ASUS ROG Z270H
CPU
INTEL i7 7700K Kaby Lake 4.2 GHz
Graphics
nVidia GeForce GTX 1070
Mobile Phone
  1. iOS
Iv'e got the latest 30.106 drivers, with the latest nvidiagraphicsfixup and lilu. Everything works great except I am getting a 1-2 second freeze when closing tabs in safari. Iv'e seen a couple of other people here have this problem too. Is there a solution to this?
 
Joined
Oct 14, 2015
Messages
36
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8086K
Graphics
UHD 630, GTX 1080 TI
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Iv'e got the latest 30.106 drivers, with the latest nvidiagraphicsfixup and lilu. Everything works great except I am getting a 1-2 second freeze when closing tabs in safari. Iv'e seen a couple of other people here have this problem too. Is there a solution to this?

had the same issue, try this workaround, fixed it for me:

  1. Close Safari
  2. Open the Terminal app (Applications > Utilities > Terminal)
  3. Enter the following command: defaults write com.apple.Safari IncludeInternalDebugMenu 1
  4. Then hit return
  5. Now relaunch Safari
  6. You will see the Debug menu in Safari’s menubar
  7. Click Debug
  8. Select Drawing/Compositing Flags
  9. Choose “Disable Canvas Accelerated Drawing” and “Disable Full Page Accelerated Drawing”.
  10. Now check to see if your problem is fixed.
 
Joined
Jul 13, 2016
Messages
8
Motherboard
ASUS ROG Z270H
CPU
INTEL i7 7700K Kaby Lake 4.2 GHz
Graphics
nVidia GeForce GTX 1070
Mobile Phone
  1. iOS
had the same issue, try this workaround, fixed it for me:

  1. Close Safari
  2. Open the Terminal app (Applications > Utilities > Terminal)
  3. Enter the following command: defaults write com.apple.Safari IncludeInternalDebugMenu 1
  4. Then hit return
  5. Now relaunch Safari
  6. You will see the Debug menu in Safari’s menubar
  7. Click Debug
  8. Select Drawing/Compositing Flags
  9. Choose “Disable Canvas Accelerated Drawing” and “Disable Full Page Accelerated Drawing”.
  10. Now check to see if your problem is fixed.

Thank you, this worked for me too! The lag is gone completely. Will use this until a real solution is presented.
 
Joined
Apr 30, 2020
Messages
32
Motherboard
Asus Prime Z370-A
CPU
i7 9700K
Graphics
Sapphire RX 5700 XT Pulse
Mobile Phone
  1. iOS
After update to 10.13.4 and driver 387.10.10.10.106, I report a finally fully functional build, without lags or glitches. Further in depth analysis is required to check the perfs, but first glance seems all nice. It took Nvidia only a "few" tries to nail it, I'd like to say "good job", but I won't.
Though, my GTX950 is still working at x2 instead of x16 in sys report....Valley benchmark gives me a score of 720 at everything max and resolution of 2560 x 1440.
 
Joined
Jan 24, 2016
Messages
96
Motherboard
z170i
CPU
6700K
Graphics
Radeon 580
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
10.13.4 with 387.10.10.10.106 has solved all UI lags I was seeing. I was able to remove lilu and nvidiaGraphicsFixup as well.
 
Status
Not open for further replies.
Top