NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.3 (387.

Not open for further replies.
I do not know if it's because of the smbios, but i think it's because of for the architecture of the graphic.

in my 980 work ok but with lag in finder and gtx 680 and 640gt perfect

So I did it and it works fine and no legging
This post has become so much confusing.
This method is the most simple and rocks.
Uninstalled Nvidia drivers, removed the card from the MoBo, turned on, executed then shutted down, inserted the card back and turned on. It works. No cares about the SIP or the SMBIOS.

High sierra's loading bar doesn't fill up when the graphics card is not in

Internal graphics are turned on
Last edited:
I've been getting horrible performance and WindowServer crashes with Nvidia on High Sierra. Performance on 1000-series cards was always awful in macOS but with this driver the computer isn't even usable. I think Nvidia cards in hacks are dead at this point, I know I won't be buying Nvidia again. The buyers guide should be updated, Nvidia is definitely the wrong choice now.
I think Nvidia cards in hacks are dead at this point, I know I won't be buying Nvidia again.
That might solve your problem. What's interesting is that for some there are no problems with these drivers.
That might solve your problem. What's interesting is that for some there are no problems with these drivers.

Dude if the 70% of the users are complaining about performances (and I myself am, even if it's usable it was laggy), the drivers aren't good.

I myself will not buy Nvidia again, as on macOS they've problems with OpenCL softwares, are worse optimized, and every update waiting for the web drivers is a pain.

The new AMDs are basically plug and play, no hassle no driver problems.
Hackintosh never was a stable thing. If you want stable you buy apple hardware.
Has anyone tried .156 or .157 with the latest macOS 10.13.4 public beta?
I've been using the new .156 driver for several hours now, which I was finally able to install correctly yesterday by fully uninstalling previous (patched) .106 one and installing (and using) new driver with SIP fully enabled (which btw I prefer. I generally only disable SIP to use patched unupdated NVidia Web Driver on new macOS).

I didn't experience any type of lag or bad performances, all is smooth and fully accelerated, being on macOS UI, the Web or on Games (tested on The Talos Principle with all options set to Ultra at 1920x1200 and AA to x8).

My setup is a Gigabyte Z87N-WiFi motherboard with Intel Core i7 4770k CPU overclocked at 4.3GHz (so Haswell generation), KFA2 HOF NVidia GeForce 980 Ti 6GB, 16GB RAM, 1TB Crucial SSD.
Integrated Intel iGPU is disabled at BIOS level, and I don't use any Lilu based patching .kext (no NvidiaGraphicsFixUp for example, and of course not even the Lilu.kext), also I use OsxAptioFix3Drv-64.efi instead of OsxAptioFix2Drv-64.efi and I don't use the EmuVariableUefi-64.efi.
Also my SMBIOS is based on iMac 14,2 SMBIOS generated by Clover Configurator, but with real iMac 14,2 Serial number and Board Serial number and Trust option checked (always been that way since I use the Web driver, being on Sierra or High Sierra).

At first the new .156 didn't work at all, not even booting (stuck on black screen (after apple logo + loading bar approx half loaded) with spinning wheel forever), at this time I was using patched .106 driver with SIP disable (0x67) of course (otherwise patched driver don't work) and I just tried to install the .156 version upon the existing patched .106, and so with SIP disabled. I tried this at least 3 times (probably even more) changing some parameters in Clover (trying boot with or without SIP...etc Trying with NVWebDriverLibValFix, Lilu, NvidiaGraphicxFixup) or trying to regenerate kext cache manually, nothing worked. In all cases the driver was never fully uninstalled and SIP was never enabled during installation and nothing worked.

I've read others saying on other forum that SIP should be enabled during driver installation for this new driver (even though it wasn't the case for previous High Sierra releases) and it's better to uninstall old driver first, so I tried it without much hope considering all the failures I had with this .156 driver before. But to my surprise, it worked. I booted disabling web driver (unchecking "NvidiaWeb" option in Clover) with SIP fully activated (0x0), uninstalled old driver (in VESA mode so), rebooted still in VESA mode and SIP fully activated (0x0) and installed new .156 driver, checked security & confidentiality preferences for NVidia Corp kext approval (which in my case wasn't asked), and rebooted, still with SIP fully activated (0x0) but this time with Nvidia Web Clover option activated.
Note that I never used "nv_disable" or "nvda_driver" boot flags are they are not required anymore and useless since Clover introduced the "Nvidia Web" option, in fact my boot flags parameter is totally empty (i.e: no boot flag at all).
Last edited:
Not open for further replies.