Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.0 (378.10.10.10.15)

Status
Not open for further replies.
Joined
Jan 11, 2012
Messages
39
Motherboard
Intel Server S5520HCR
CPU
Intel Xeon E5620 2.4 Ghz - 16GB DDR3
Graphics
Zotac GTX 970 4GB DDR5
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
Classic Mac
  1. LC
Mobile Phone
  1. Android
  2. iOS
new update nvidia drivers,... any try if work with cuda ? i need Cuda
 
Joined
Jul 24, 2015
Messages
2,257
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
NICE!

I got busy installing the new Windows Fall Update fresh. Then got distracted by a couple of Steam games after making sure the game library was good on the back up drive. XD

EDIT, yup if I only connect 1 display to the HDMI port, then I can do 0x67 all the way. Damn.
Half the problem is hardware/configuration. The other half, could be that with SIP disabled and without the kexts approved we just need that list of IDs in 'csr-data' NVRAM variable (good fit for config.plist maybe). Or once in the database they just load too, irrespective of SIP.
 
Last edited:
Joined
May 11, 2010
Messages
129
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
Core i5-6600K @ 4.6GHz
Graphics
Gigabyte Gaming G1 GTX 1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Interesting note: in the comments Pike R Alpha says he runs his system with SIP fully enabled and loads all unsigned kexts via the boot loader. I know this is pushing against years of inertia in this community and a bit like tilting at windmills, but it really seems like that's how things should be run in general. Guess I'm experimenting tonight...
I’m still on 10.12.6 and running with SIP fully enabled (after years of kext-dev-mode=1 and SIP 0x3), works like a charm. Clover injection is definitely the way to go
 
Joined
Feb 3, 2011
Messages
1,364
Motherboard
Gigabyte Z390 AORUS Ultra
CPU
i9-9900K
Graphics
RX 590
kext-dev-mode=1 is still a mystery to me been told that it stopped working after el capitan
 
Joined
Jul 24, 2015
Messages
2,257
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
I’m still on 10.12.6 and running with SIP fully enabled (after years of kext-dev-mode=1 and SIP 0x3), works like a charm. Clover injection is definitely the way to go
Waiting to see if there's an H310 board next year with a native Intel ethernet controller, injected FakeSMC might be the only kext required.
kext-dev-mode=1 is still a mystery to me been told that it stopped working after el capitan
Yes it does nothing.
 
Joined
Feb 21, 2017
Messages
200
Motherboard
HP Envy 17-U275CL
CPU
i7-8550U
Graphics
GTX MX150 / HD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I’m still on 10.12.6 and running with SIP fully enabled (after years of kext-dev-mode=1 and SIP 0x3), works like a charm. Clover injection is definitely the way to go


I have only been running with SIP enabled for a couple of days. In High Sierra, I was unable to install the drivers for my USB DI device. They would install and gatekeeper would pop up but the device would never initialize. The light would stay red. I uninstalled the drivers rebooted with 0x67 and installed them and it was all good. Not sure about Sierra. It may have worked fine with that.
 
Joined
Feb 21, 2017
Messages
200
Motherboard
HP Envy 17-U275CL
CPU
i7-8550U
Graphics
GTX MX150 / HD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Waiting to see if there's an H310 board next year with a native Intel ethernet controller, injected FakeSMC might be the only kext required.
Yes it does nothing.

Wait what? A board where only FakeSMC is required?
 
Joined
Feb 21, 2017
Messages
200
Motherboard
HP Envy 17-U275CL
CPU
i7-8550U
Graphics
GTX MX150 / HD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Well, the only Hackintosh specific kext...
Yeah, that is what I mean. So all the other parts on the board work OOB? That is sick! I want one now too.
 
Status
Not open for further replies.
Top