Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.0 (378.10.10.10.15)

Status
Not open for further replies.
Joined
Jul 27, 2011
Messages
3
Motherboard
Gigabyte Z97X-UD3H
CPU
Intel I7 4790K
Graphics
GTX660ti
Mac
  1. MacBook Air
  2. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
After 3 attempts at doing upgrade from 10.12 and having lock up issues after installing latest driver for 1080ti....I decided to do a full re-install and did the above mentioned SIP settings to do that without error. Everything was perfect with zero lockups on screensaver activation or looking at color profile tab. Both of which would lock everything in its tracks.

What I found out was the issue was the G-Sync!......When I enabled that my lock up problems came back!
Anybody able to enable G-Sync without issues?....I can still choose the 165hz refresh without it on.
Working great so far!......Hope this helps if you had G-Sync enabled in 10.12 and did upgrade to 10.13.
Thanks for all the help!
 
Joined
Oct 9, 2017
Messages
18
Motherboard
ASUS Z170I Pro Gaming
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. iMac
One note that might help a few: If you're getting stuck at the Apple logo during boot after installing the web drivers and you're using emulated NVRAM (EmuVariableUefi-64.ef) you might have to add the -nvda_drv=1 boot flag on the first boot after installing the web drivers.
 
Joined
Jul 24, 2015
Messages
2,257
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
Hmm. Well, Im'a sleep. When I get up I'll try a couple more installs. One with both displays connected, - install 0x67, then to 0x0 for .120 install - then rebooting 0x67.... The next test will be with 1 display straight up 0x67 all the way through.
Done my own tests on a clean install. CSR set to 0x3FF in config.plist, boot into fresh High Sierra, run only my script, reboot and everything works. Reboot with CSR 0x3, everything works. No errors. No gatekeepers. Single monitor connected throughout as i have to boot with only one plugged in anyways (out of my 6 displays).

Screen Shot 2017-10-18 at 09.14.33.png


Code:
vulgos-iMac:~ vulgo$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *480.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk3         240.0 GB   disk0s2
   3:         Microsoft Reserved                         16.8 MB    disk0s3
   4:                 Apple_APFS Container disk4         51.5 GB    disk0s4
   5:       Microsoft Basic Data Windows                 62.4 GB    disk0s5
   6:           Windows Recovery                         471.9 MB   disk0s6
   7:           Linux Filesystem                         41.9 GB    disk0s7

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk1
   1:                        ZFS                         320.1 GB   disk1s1
   2: 6A945A3B-1DD2-11B2-99A6-080020736631               8.4 MB     disk1s9

/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk2
   1:                        ZFS                         320.1 GB   disk2s1
   2: 6A945A3B-1DD2-11B2-99A6-080020736631               8.4 MB     disk2s9

/dev/disk3 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +240.0 GB   disk3
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            162.4 GB   disk3s1
   2:                APFS Volume Preboot                 18.9 MB    disk3s2
   3:                APFS Volume Recovery                519.9 MB   disk3s3
   4:                APFS Volume VM                      20.5 KB    disk3s4

/dev/disk4 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +51.5 GB    disk4
                                 Physical Store disk0s4
   1:                APFS Volume HighSierra              11.3 GB    disk4s1
   2:                APFS Volume Preboot                 20.0 MB    disk4s2
   3:                APFS Volume Recovery                519.9 MB   disk4s3
   4:                APFS Volume VM                      2.1 GB     disk4s4

vulgos-iMac:~ vulgo$ diskutil mountdisk disk0s1
Volume(s) mounted successfully
vulgos-iMac:EFI vulgo$ sudo /Volumes/EFI/altnvweb-120.sh

Alternative Installer for WebDriver-378.10.10.10.15.120

Downloading package...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 62.1M  100 62.1M    0     0  2434k      0  0:00:26  0:00:26 --:--:-- 2714k
Extracting...
387207 blocks
Approving kexts...
Installing...
Updating caches...
KernelCache ID: DA0EC1820DBF57DE71EC643A0018C6BB
Complete.


You should reboot now.

vulgos-iMac:EFI vulgo$
 

Attachments

  • Screen Shot 2017-10-18 at 01.40.04.png
    Screen Shot 2017-10-18 at 01.40.04.png
    747 KB · Views: 171
  • Screen Shot 2017-10-18 at 01.47.28.png
    Screen Shot 2017-10-18 at 01.47.28.png
    282.5 KB · Views: 182
  • Screen Shot 2017-10-18 at 08.54.44.png
    Screen Shot 2017-10-18 at 08.54.44.png
    438.5 KB · Views: 169
  • Screen Shot 2017-10-18 at 09.11.51.png
    Screen Shot 2017-10-18 at 09.11.51.png
    99.3 KB · Views: 136
  • screenshot3.png
    screenshot3.png
    7 KB · Views: 159
Joined
Oct 13, 2017
Messages
19
Motherboard
Asus Z97-A
CPU
i7 4790k CPU
Graphics
ATI Radeon HD 5670
Upgraded to .120 without any issue. I did the error message but just pressed Continue.

I made no changes to SIP.
 
Joined
Oct 13, 2017
Messages
19
Motherboard
Asus Z97-A
CPU
i7 4790k CPU
Graphics
ATI Radeon HD 5670
Is there any change log of .120? I like to see whats new or bug fixes.
 
Joined
Sep 18, 2017
Messages
6
hello, i have the 17A405 if i install the drivers directly the hackintosh restarts continuously, i also tried installing the method from the terminal the result was stable but i did not istall drivers, help me
 

Attachments

  • A5D4A321-7434-460D-A772-00BE6CE17CCB.png
    A5D4A321-7434-460D-A772-00BE6CE17CCB.png
    79.9 KB · Views: 138
Joined
May 12, 2011
Messages
10
Motherboard
HP Omen 870-224
CPU
i5-7400
Graphics
GTX 1060 3GB
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
What I found out was the issue was the G-Sync!......When I enabled that my lock up problems came back!
Anybody able to enable G-Sync without issues?....I can still choose the 165hz refresh without it on.
Working great so far!......Hope this helps if you had G-Sync enabled in 10.12 and did upgrade to 10.13.
Thanks for all the help!

I have the same issues with G-Sync, constant freezing. It would be great to get it working but so far no luck.
GTX 1060 3GB..
 
Joined
Feb 21, 2017
Messages
200
Motherboard
HP Envy 17-U275CL
CPU
i7-8550U
Graphics
GTX MX150 / HD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Done my own tests on a clean install. CSR set to 0x3FF in config.plist, boot into fresh High Sierra, run only my script, reboot and everything works. Reboot with CSR 0x3, everything works. No errors. No gatekeepers. Single monitor connected throughout as i have to boot with only one plugged in anyways (out of my 6 displays).

View attachment 286617

Code:
vulgos-iMac:~ vulgo$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *480.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk3         240.0 GB   disk0s2
   3:         Microsoft Reserved                         16.8 MB    disk0s3
   4:                 Apple_APFS Container disk4         51.5 GB    disk0s4
   5:       Microsoft Basic Data Windows                 62.4 GB    disk0s5
   6:           Windows Recovery                         471.9 MB   disk0s6
   7:           Linux Filesystem                         41.9 GB    disk0s7

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk1
   1:                        ZFS                         320.1 GB   disk1s1
   2: 6A945A3B-1DD2-11B2-99A6-080020736631               8.4 MB     disk1s9

/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk2
   1:                        ZFS                         320.1 GB   disk2s1
   2: 6A945A3B-1DD2-11B2-99A6-080020736631               8.4 MB     disk2s9

/dev/disk3 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +240.0 GB   disk3
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            162.4 GB   disk3s1
   2:                APFS Volume Preboot                 18.9 MB    disk3s2
   3:                APFS Volume Recovery                519.9 MB   disk3s3
   4:                APFS Volume VM                      20.5 KB    disk3s4

/dev/disk4 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +51.5 GB    disk4
                                 Physical Store disk0s4
   1:                APFS Volume HighSierra              11.3 GB    disk4s1
   2:                APFS Volume Preboot                 20.0 MB    disk4s2
   3:                APFS Volume Recovery                519.9 MB   disk4s3
   4:                APFS Volume VM                      2.1 GB     disk4s4

vulgos-iMac:~ vulgo$ diskutil mountdisk disk0s1
Volume(s) mounted successfully
vulgos-iMac:EFI vulgo$ sudo /Volumes/EFI/altnvweb-120.sh

Alternative Installer for WebDriver-378.10.10.10.15.120

Downloading package...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 62.1M  100 62.1M    0     0  2434k      0  0:00:26  0:00:26 --:--:-- 2714k
Extracting...
387207 blocks
Approving kexts...
Installing...
Updating caches...
KernelCache ID: DA0EC1820DBF57DE71EC643A0018C6BB
Complete.


You should reboot now.

vulgos-iMac:EFI vulgo$


NICE!

I got busy installing the new Windows Fall Update fresh. Then got distracted by a couple of Steam games after making sure the game library was good on the back up drive. XD

EDIT, yup if I only connect 1 display to the HDMI port, then I can do 0x67 all the way. Damn.
 
Last edited:
Joined
Feb 6, 2017
Messages
34
Motherboard
Gigabyte GA-170X-UD3 Ultra (rev 1.0)
CPU
i7-6700k
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Upgraded to .120 without any issue. I did the error message but just pressed Continue.

I made no changes to SIP.
Me too... All I did was update Lilu.kext to 1.2.0 and relevant related kext. Then I update via NVidia Device Manager. I got the error message too but I just keep continue.
 
Status
Not open for further replies.
Top