Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.0 (378.10.10.10.15)

Status
Not open for further replies.
Joined
Mar 9, 2011
Messages
692
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Ok, I got the nvidia drivers to work properly. It will still give you an error on instal but the drivers will work properly.

All I did is enable internal graphics. I have the HD4600 and all the necessary patches and once you restart the system will boot.
Previously there were issues with graphical errors in safari but it looks like it’s not happening anymore (needs further testing).

Once you boot successfully with igpu and nvidia graphics (leave the hdmi or DP in your Nvidia card), reboot. Disable the internal graphics and try to boot again.

For me it works I hope it works for you guys!

Ps. This is a double post, can a mod please delete the other. I didn’t realise there was a nvidia thread. Thanks
 
Joined
Jan 14, 2016
Messages
29
Motherboard
ASUS Z390-E Gaming
CPU
i5 9600k @ 5.2GHz all core
Graphics
Asus Strix 2070 (Blocked)
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Classic Mac
  1. Classic
Mobile Phone
  1. iOS
Some of the board ID and serial have been edited, so be aware of that. Took me forever to get mine working, so I'll help where I can.


Plist Edit PRO must have key :
Screen Shot 2017-09-26 at 11.22.17 PM.png
 

Attachments

  • config.plist
    4.4 KB · Views: 412
Last edited:
Joined
Jan 14, 2016
Messages
29
Motherboard
ASUS Z390-E Gaming
CPU
i5 9600k @ 5.2GHz all core
Graphics
Asus Strix 2070 (Blocked)
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Classic Mac
  1. Classic
Mobile Phone
  1. iOS
thing is, I had iGPU enabled from the beginning and without success.
I didn't. I did an App Store Upgrade from 10.12.6, to 10.13 and just had to use the installer for Webdrivers and fix my audio.

Download plisteditor pro if you don't have it and compare my config to yours. That's your best bet.
 
Joined
Jul 1, 2015
Messages
72
Motherboard
ASUS B150M-K D3
CPU
Intel Core i5 6500
Graphics
Gigabyte Geforce GTX 960
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Color Classic
  2. eMac
  3. iBook
  4. iMac
  5. Power Mac
  6. Xserve
Mobile Phone
  1. Android
  2. iOS
For those of you with issues, did you upgrade through App Store like suggested, or do a clean install? I just upgraded from 10.12.6, and had no issues with the driver or getting sound to work. Boots up faster than my real Macs....
Clean install
 
Joined
Jan 14, 2016
Messages
29
Motherboard
ASUS Z390-E Gaming
CPU
i5 9600k @ 5.2GHz all core
Graphics
Asus Strix 2070 (Blocked)
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Classic Mac
  1. Classic
Mobile Phone
  1. iOS
@wow456 & @Wolfie81, any chance you two can add a boot argument of -v for verbose mode and see where it gets hung at? Or -x for safe mode to see if we can get in to compare configs?
 
Joined
Oct 10, 2012
Messages
584
Motherboard
<< need manufacturer and model # >> See Forum Rules !!
CPU
6700k
Graphics
1080ti FTW3
Mac
  1. iMac
WORKING! For anyone having issues (cause has been found).

1. Install the NVIDIA web drivers
2. Download the latest Lilu.kext @ https://github.com/vit9696/Lilu/releases
3. Place kext in EFI/others.


Reboot and enjoy :)
 
Status
Not open for further replies.
Top