Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.0 (378.10.10.10.15)

Status
Not open for further replies.
Joined
Jun 30, 2017
Messages
5
Motherboard
Asus z170 pro gaming aura
CPU
Core i7 6700
Graphics
Gtx 1060 6g
I give up now. 50 times New installation still not working for me. Going back to Mac os sierra, won't go high again. I GIVE UP ON U HIGH
 
Joined
Apr 7, 2017
Messages
19
Motherboard
I still didn't read
CPU
the RULES
Graphics
so IGNORE me!
Mobile Phone
  1. Android
Guys someone helps me ? when I try to install Nvidia web drivers , the installation don't gets complete without forcing , I get a error in the middle of installation and if I force the installation to continue, when I restart my monitor don't get video signal. What I should do ??
 
Joined
Oct 10, 2012
Messages
131
Motherboard
Asus ProART Z490-Creator 10G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. Mac Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Managed to get the Nvidia drivers working for my 970 as per Stork's instructions in Post #2, experiencing graphical glitches that are bearable for now. I noticed that after installing other drivers (steel series mouse and waves audio) that they would only install correctly if SIP was enabled (0x0), and I click “allow” in security preferences. This left me in the unfortunate situation where enabling SIP would put me in a boot loop due to the Nvidia drivers breaking. The only workaround was to delete the Nvidia drivers via the USB installers Terminal feature, boot in, install all the other drivers then reinstall Nvidia drivers. Finally disabling SIP and rebooting.

If anyone has a better workaround for enabling sip to install other drivers without breaking graphics please share.

Thank you so much to everyone on this thread for getting me up and running :)
 
Joined
Apr 7, 2017
Messages
19
Motherboard
I still didn't read
CPU
the RULES
Graphics
so IGNORE me!
Mobile Phone
  1. Android
Managed to get the Nvidia drivers working for my 970 as per Stork's instructions in Post #2, experiencing graphical glitches that are bearable for now. I noticed that after installing other drivers (steel series mouse and waves audio) that they would only install correctly if SIP was enabled (0x0), and I click “allow” in security preferences. This left me in the unfortunate situation where enabling SIP would put me in a boot loop due to the Nvidia drivers breaking. The only workaround was to delete the Nvidia drivers via the USB installers Terminal feature, boot in, install all the other drivers then reinstall Nvidia drivers. Finally disabling SIP and rebooting.

If anyone has a better workaround for enabling sip to install other drivers without breaking graphics please share.

Thank you so much to everyone on this thread for getting me up and running :)

OMG, dude! After I done everything from Stork's post , my driver now working , thank you so much! I very happy right now, that instructions should be in the main 1# post.
 
Joined
Jul 16, 2017
Messages
5
Motherboard
Gigabyte B85M-D3H
CPU
Intel i5 4440
Graphics
Asus Strix Nvidia GTX 970
Managed to get the Nvidia drivers working for my 970 as per Stork's instructions in Post #2, experiencing graphical glitches that are bearable for now. I noticed that after installing other drivers (steel series mouse and waves audio) that they would only install correctly if SIP was enabled (0x0), and I click “allow” in security preferences. This left me in the unfortunate situation where enabling SIP would put me in a boot loop due to the Nvidia drivers breaking. The only workaround was to delete the Nvidia drivers via the USB installers Terminal feature, boot in, install all the other drivers then reinstall Nvidia drivers. Finally disabling SIP and rebooting.

If anyone has a better workaround for enabling sip to install other drivers without breaking graphics please share.

Thank you so much to everyone on this thread for getting me up and running :)
Thanks. Bro! I finally got it to work after numerous fails and reinstall. I saw your post and and first thing I did was to mount my partition via EFI Mounter and change rt variables of csr config active to 0x0 and install Nvidia web driver. Then, before restarting I change value of csr config active to 0x67, and, Voila, it is working great. Thanks For The Help.
 
Joined
Jul 25, 2012
Messages
143
Motherboard
<< need manufacturer and model # >> See Forum Rules !!
CPU
i3-6320
Graphics
GTX 750
Mobile Phone
  1. iOS
Video cards supported

Native...I mean supported by macOS Natively. without kext or webdriver
You can find them here: https://everymac.com, which Mac support which graphics card natively = used in their models. But you must seek only for High Sierra supported models. Of course, every model from apple supported High Sierra have native macOS kext supported build-in graphics cards for and only for that model. That is why all hackintoshers emulate models numbers for example iMac14,2, for example. You can't install hackintosh with old Nvidia GTX 650 with emulated iMac17,1 model because original iMac17,1 don't have this card, so you must emulate model iMac14,2 for this old GTX650 card if you want natively macOS kext be working, etc.
 
Last edited:
Joined
Apr 19, 2014
Messages
25
Motherboard
Asus ROG Z270F Strix
CPU
I7-7700K
Graphics
Vega 64
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
  2. SE
Mobile Phone
  1. iOS
ok. after getting the Nvidia drivers loaded

set sip/csr to 0x2EF

then reboot and run the audio script
but type this before you reboot


sudo touch /Library/Extensions /System/Library/Extensions
sudo kextcache -u /

see my thread here, I have a pretty similar setup to you
https://www.tonymacx86.com/threads/success-6700k-1080-ti-asus-ranger-viii.233625/#post-1596358

Okay so I'm back in action (thanks Time Machine backup from Recovery Boot!). But I'm still a little leery about running the Toleda script again. I've followed your instructions up until running, "audio_cloverALC-130_v0.3.command" what specifically did you input for the script? Thanks!
 
Joined
May 22, 2011
Messages
129
Motherboard
ASUS ROG MAXIMUS VIII GENE
CPU
i7 6700
Graphics
GTX 1070
Mobile Phone
  1. iOS
Hi
Is there any list of all supported Video Cards ( NATIVE ) by Sierra and High Sierra ?
AMD and NVIDIA ?
I use more Adobe Apps ( Photoshop, Lightroom, etc ) more for photography...
What you sugest is best ? i need 10 bit ...for 32" 4k Display, 10 bit dispaly !!!

Most of the AMD cards do work, some may require little kext modifications to get native support as the OS has implemented them in code. Right now on nvidia side, only old Fermi based cards and maybe one or two Maxwell are supported. Anything else requires a Web driver which is not same as native. It tries its best to give its best performance but many things lack specially HW decode/encode. Since macs are optimised for OpenCL its based you choose a card for AMD. After 10.12.6 and with whatevergreen kext, things for AMD in hackintosh have changed quite lot, many work OOB. Look into Polaris GPUs. Also just keep in mind, some XFX cards need additional tweaking since XFX likes to modify their vBIOS, so just stay away from them. Gigabyte or Sapphire are best options.
 
Joined
May 22, 2011
Messages
129
Motherboard
ASUS ROG MAXIMUS VIII GENE
CPU
i7 6700
Graphics
GTX 1070
Mobile Phone
  1. iOS
Has anyone been able to get HW decode/encode to work with Pascal GPUs? Thought Metal 2 could have changed all that with support for eGPU, but I still find video playback or quicktime screen recording utilizing my CPU cores rather than my GPU.
 
Joined
Sep 11, 2014
Messages
29
Motherboard
ASUS Sabertooth x79
CPU
i7-3820
Graphics
GTX 650 Ti
OK I got it. Just like people are saying. Combine post 1 with post 2. What I forgot what to select "Yes" to Inject Kexts. But the procedure was disable SIP, reboot, install NVIDIA Drivers, enable sip, configure clover, reboot with PCIE as main display rather than iGPU. Thanks team.
 
Status
Not open for further replies.
Top