Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.0 (378.10.10.10.15)

Status
Not open for further replies.
Joined
Jul 24, 2015
Messages
2,257
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
How could it be done?
Note that SIP has changed (several times) since El Capitan. The new Secure Kernel Extension Loading feature aka Gatekeeper prompt can be disabled in CSR flags, but 0x67, 0x03 and 0x00 will leave it enabled along with other protections, as you can see in the Clover screenshot and csrstat output.

screenshot2.png


Code:
csrstat v1.7 Copyright (c) 2015-2017 by Pike R. Alpha
System Integrity Protection status: enabled (0x00000067) (Custom Configuration).

Configuration:
    Apple Internal............: 0 (disabled)
    Kext Signing Restrictions.: 1 (disabled)
    Task for PID Restrictions.: 1 (disabled)
    Filesystem Protections....: 1 (disabled)
    Debugging Restrictions....: 0 (enabled)
    DTrace Restrictions.......: 1 (disabled)
    NVRAM Protections.........: 1 (disabled)
    Device Configuration......: 0 (enabled)
    BaseSystem Verification...: 0 (enabled)
    User Approved Kext Loading: 0 (enabled)

This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,825
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
But why would you want to turn SIP on? It will cause OsxAptioFixDrv errors and prevent you to boot. I wouldn't recommend it or do it. You're choice.
I know, I know. It doesn't make sense...But, it was the only solution I found that worked.

Nvidia's installer is flawed...that's the bottom line. So, you have to try things to make the installer to work. SIP enabled (0x0) works. But, note that, right after the installation, before rebooting, I turn the SIP "semi" off (0x3) as I described in the procedures in Post #2. Bottom line...Nvidia's installer is flawed.
 
Joined
Jun 9, 2013
Messages
10,755
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
I know, I know. It doesn't make sense...But, it was the only solution I found that worked.

Nvidia's installer is flawed...that's the bottom line. So, you have to try things to make the installer to work. SIP enabled (0x0) works. But, note that, right after the installation, before rebooting, I turn the SIP "semi" off (0x3) as I described in the procedures in Post #2. Bottom line...Nvidia's installer is flawed.

Bit of a strange one. I think the Nvidia Web Drivers have problems. My only concern is that setting CsrActiveConfig to 0x0 may cause issues with Booting on first boot for some people.
 
Joined
Sep 27, 2017
Messages
3
Motherboard
b250m-d3h
CPU
Intel Core i7 7700k
Graphics
NVIDIA GeForce GTX 1070 8G
I can confirm this worked for me! Just installing NVWebDriverLibValFix.kext with Kext Wizard (or any other kext tool). Then installed Nvidia drivers which gave me an error (no matter). Then i enabled Nvidia Web Driver on Clover and that's it!


Thank you very much!
It works for me too.It can be the easy way to due with this issue.
 
Joined
Nov 7, 2014
Messages
40
Motherboard
Dell Vostro 3350
CPU
i3-2310M
Graphics
HD 3000
Mobile Phone
  1. Android
I successfully installed HS already and I'm experiencing severe graphical issues. Resolution itself is fine--but there's no wallpaper, broken images (they just look like colorized noise), and just extreme flickering. With vanilla macOS installs in the past, I just add the bootflag GraphicsEnabler=Yes and everything is fully functional in terms of graphics.

I can boot into the system more usably at a bad resolution with nv_disable=1.

Would this possibly fix my problem? I'm running on a GeForce GT 620 (trash, I know--but for now it's all I've got). :)
 
Joined
May 11, 2013
Messages
199
Motherboard
GA-Z170x-UD5-TH
CPU
i7-6700k
Graphics
MSI GeForce GTX 1080Ti Gaming X
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
GA-Z170X-UD5-TH
1080 Ti
17.1 iMac definitions
High Sierra Confirmed

Installed using Stork's instructions in Post #2 and did not have a message with “a window with a message like "The [...] kext is not signed and, in the Security and Privacy System Preference pane, you can approve its installation" (or something like that);”
Perhaps Nvidia updated the installer?

after I got to black screen after boot -> shared screen in from my Macbook and installed AGDPfix v.1.3 (you need change SIP to 0x67 for that, 0x3 won't cut it)
Updated audio using Toleda script and everything is back to normal.

Boot times are much longer than on Sierra - back then everything booted in a minute or so, now it is 3-5. Will see how stable it will fly :)
 
Status
Not open for further replies.
Top