Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.0 (378.10.10.10.15)

Status
Not open for further replies.
Joined
Jun 9, 2013
Messages
10,755
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
but as guided i should enable SIP (0x0) to install nvidia drivers, am i doing something worng?

Bad idea. Kext Injection wont work if SIP is enabled. (System Integrity Protection) will prevent you installing kexts to L/E.
 
Joined
Sep 27, 2010
Messages
37
Motherboard
Z370
CPU
I9-9900k
Graphics
RX580
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
Bad idea. Kext Injection wont work if SIP is enabled. (System Integrity Protection) will prevent you installing kexts to L/E.

As STORK guide says:
......
:ch: Mount the HS drive's EFI partition and change the SIP setting (CsrActiveConfig) from MultiBeast's default 0x3 to 0x0 which turns on SIP and save;

:ch: Make sure that the Security and Privacy System Preference pane General tab setting for "Allow apps downloaded from:" is set to "App Store and identified developers";

:ch: Reboot;

......

How could it be done?
 
Joined
Jun 9, 2013
Messages
10,755
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
As STORK guide says:
......
:ch: Mount the HS drive's EFI partition and change the SIP setting (CsrActiveConfig) from MultiBeast's default 0x3 to 0x0 which turns on SIP and save;

:ch: Make sure that the Security and Privacy System Preference pane General tab setting for "Allow apps downloaded from:" is set to "App Store and identified developers";

:ch: Reboot;

......

How could it be done?

But why would you want to turn SIP on? It will cause OsxAptioFixDrv errors and prevent you to boot. I wouldn't recommend it or do it. You're choice.
 
Joined
Sep 27, 2010
Messages
37
Motherboard
Z370
CPU
I9-9900k
Graphics
RX580
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
But why would you want to turn SIP on? It will cause OsxAptioFixDrv errors and prevent you to boot. I wouldn't recommend it or do it. You're choice.
i agree with you but Stork's guide to install nvidia driver tell to enable SIP.
 
Joined
Jun 9, 2013
Messages
10,755
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
i agree with you but Stork's guide to install nvidia driver tell to enable SIP.

Okay then. So change CsrActiveConfig to 0x0. Don't moan if you cant boot.
 
Joined
Jul 24, 2015
Messages
2,257
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
I can boot fine with SIP enabled. But if the kernel cache gets rebuilt unsigned kexts will get excluded.
Code:
csrstat v1.7 Copyright (c) 2015-2017 by Pike R. Alpha
System Integrity Protection status: enabled (0x00000000)

Configuration:
    Apple Internal............: 0 (disabled)
    Kext Signing Restrictions.: 0 (enabled)
    Task for PID Restrictions.: 0 (enabled)
    Filesystem Protections....: 0 (enabled)
    Debugging Restrictions....: 0 (enabled)
    DTrace Restrictions.......: 0 (enabled)
    NVRAM Protections.........: 0 (enabled)
    Device Configuration......: 0 (enabled)
    BaseSystem Verification...: 0 (enabled)
    User Approved Kext Loading: 0 (enabled)
 

aol

Joined
Apr 14, 2011
Messages
503
Motherboard
GA-Z370-HD3P
CPU
i7-8700K
Graphics
RX570
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Does it happen on all Nvidia cards from 10xx generation?
Just getting back to try and solve this after attempting earlier in the week. Have read through the thread but what's the latest for this issue:
I have a GTX 1060 SSC

When I tried to install several days ago I didn't get the black screen instead it hung during startup and I got the overlapping spinning progress wheel.

Anyone with this card have success? Tips? Warnings?

Thanks!
Anyone with a

EVGA GTX 1060 SSC 6GB

manage to get these drivers to work?
The 1060s are notorious for flickering/tearing, but I see in another post in this thread that 1050s and 1070s have their own issues, possibly not as severe as 1060s. 1080s seem to be immune but not sure. 1060s have several display-wake and system-wake behaviors: tearing/flickering on one or both monitors, one screen not waking or going to an 8-bit palette. Unplugging and replugging, triggering display sleep then rewaking, or possibly rebooting will fix.

But the 1060s work on Sierra and High Sierra.

You want to make sure the only way you're enabling the nvidia web drivers is the nvidiaweb true in config.plist. If you have issues starting up that nv_disable=1 doesn't fix, you need to boot safe/recovery/single user or use another computer and shell in and remove GeForce*.kext and NVDA*.kext from /S/L/E or /L/E. If you're using SMBIOS iMac14,2 just reboot and you should be in VESA mode, and you should be able to install the drivers. If you're using another SMBIOS you may need lilu.kext and NvidiaDriverFixup.kext. Other kexts (iMac.kext, shiki.kext) and other GPU settings in config.plist settings may interfere with booting High Sierra.
 
Joined
Jul 24, 2015
Messages
2,257
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
How could it be done?
Note that SIP has changed (several times) since El Capitan. The new Secure Kernel Extension Loading feature aka Gatekeeper prompt can be disabled in CSR flags, but 0x67, 0x03 and 0x00 will leave it enabled along with other protections, as you can see in the Clover screenshot and csrstat output.

screenshot2.png


Code:
csrstat v1.7 Copyright (c) 2015-2017 by Pike R. Alpha
System Integrity Protection status: enabled (0x00000067) (Custom Configuration).

Configuration:
    Apple Internal............: 0 (disabled)
    Kext Signing Restrictions.: 1 (disabled)
    Task for PID Restrictions.: 1 (disabled)
    Filesystem Protections....: 1 (disabled)
    Debugging Restrictions....: 0 (enabled)
    DTrace Restrictions.......: 1 (disabled)
    NVRAM Protections.........: 1 (disabled)
    Device Configuration......: 0 (enabled)
    BaseSystem Verification...: 0 (enabled)
    User Approved Kext Loading: 0 (enabled)

This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.
 
Status
Not open for further replies.
Top