Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.0 (378.10.10.10.15)

Status
Not open for further replies.
Joined
Jul 1, 2015
Messages
72
Motherboard
ASUS B150M-K D3
CPU
Intel Core i5 6500
Graphics
Gigabyte Geforce GTX 960
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Color Classic
  2. eMac
  3. iBook
  4. iMac
  5. Power Mac
  6. Xserve
Mobile Phone
  1. Android
  2. iOS
This is a joke, I have done every way and nothing works
 
Joined
Sep 27, 2017
Messages
4
Okay. Make sure though that your config.plist is set to inject kexts. That NvidiaWeb is enabled and nv_disable is not on. (Same as with Sierra).

I have almost the exact same hardware setup as you, and have been wrestling with this all day. Which system definition are you using? Any chance you could upload you EFI folder?
 
Joined
Feb 21, 2017
Messages
200
Motherboard
HP Envy 17-U275CL
CPU
i7-8550U
Graphics
GTX MX150 / HD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I have almost the exact same hardware setup as you, and have been wrestling with this all day. Which system definition are you using? Any chance you could upload you EFI folder?


iMac 18,3

That EFI will work on almost any 200 series with Nvidia. I haven't found one it doesn't work with. Some MSI boards you need to replace OsxAptioFix2Drv-64.efi with OsxAptioFix2Drv-free2000.efi. But other than that it works fine. You can add SSDTs and what not later but for the most part it works 100. The good thing is, there really isn't any post install. Once you've finished installing Sierra you simply copy the EFI folder onto the EFI partition on the hard drive and boot from there. No fussing around with adding kexts after. I haven't tried adding to an APFS formatted drive, my boot drive is not the same as my High Sierra one.
 

Attachments

  • EFI.zip
    5.5 MB · Views: 179
Last edited:
Joined
Jul 1, 2015
Messages
72
Motherboard
ASUS B150M-K D3
CPU
Intel Core i5 6500
Graphics
Gigabyte Geforce GTX 960
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Color Classic
  2. eMac
  3. iBook
  4. iMac
  5. Power Mac
  6. Xserve
Mobile Phone
  1. Android
  2. iOS
ok got it working :)
I had to put NVWebDriverLibValFix.kext on clover kext/others and used sudo touch /Library/Extensions/ /System/Library/Extensions/ after install drivers(booted with SIP activated for the Nvidia drivers install) gatekeeper asked me for permission and done.
My problem now is I can't use 10bits color, if I change it to 10bits with SwitchResX it goes black screen.
Any work around?

i disabled NVWebDriverLibValFix.kext after and it still works.


Tell me your way, I have the same card
 
Joined
May 2, 2016
Messages
41
Motherboard
ASUS P8Z77-V DELUXE
CPU
i5-3570K
Graphics
NVIDIA GTX 770
Mac
  1. iMac
This is a joke, I have done every way and nothing works

Yep, nothing works. Seems everyone has a different method (SIP enabled, not enabled) and different order of installing kexts or using /not using AGDP fix, etc, etc. This is a mess.
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
I had no issues with a GTX 970, iMac15,1 using Lili.kext and NvidiaGraphicsFixup.kext.
 
Joined
Jun 5, 2017
Messages
6
Motherboard
Asus Prime X570
CPU
Ryzen 3900X
Graphics
RTX 2080
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Are you getting the wake from sleep screen issues like aol?
I have almost the exact same hardware setup as you, and have been wrestling with this all day. Which system definition are you using? Any chance you could upload you EFI folder?
After updating and not able to boot what i did was after updating clover, installing High sierra and installing Nvida web driver i replaced my backup config file that i had from Sierra 12.6 and got it to boot high sierra.
 
Joined
May 2, 2016
Messages
41
Motherboard
ASUS P8Z77-V DELUXE
CPU
i5-3570K
Graphics
NVIDIA GTX 770
Mac
  1. iMac
iMac 18,3

For me the NVWebDriverLibValFix.kext does not work at all. Once nvidia web driver is installed, my PC just keep restarting after booting, nothing I do get pass that point, nor I can enter the OS (-x doesn´t work, nor disabling Nvidia web flag in Clover, nor nv_disable=1, etc).

My card is a GTX 1080, not sure if anyone here has had success with this card and the Nvidia web drivers released today for High Sierra, my SMBIOS is 18,3 as well (with a i7-7700K CPU). So far, any of the methods described here in this threads have worked for me.
 
Joined
Nov 18, 2015
Messages
209
Motherboard
GIGABYTE Z490 Vision D
CPU
i9-10850K
Graphics
RX Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm completely stuck.
Followed instructions from tonymacx86.com to "Update Directly to High Sierra"
Updated the Nvidia Web drivers without changing my SIP setting (not sure what they were)
Computer now boots to a black screen.
Tried "nv-disable=1" boot option in Clover and can't seem to get past the black screen.

Thoughts? Step by step directions are sorely needed.

Please and Thanks.
 
Joined
Feb 21, 2017
Messages
200
Motherboard
HP Envy 17-U275CL
CPU
i7-8550U
Graphics
GTX MX150 / HD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
For me the NVWebDriverLibValFix.kext does not work at all. Once nvidia web driver is installed, my PC just keep restarting after booting, nothing I do get pass that point, nor I can enter the OS (-x doesn´t work, nor disabling Nvidia web flag in Clover, nor nv_disable=1, etc).

My card is a GTX 1080, not sure if anyone here has had success with this card and the Nvidia web drivers released today for High Sierra, my SMBIOS is 18,3 as well (with a i7-7700K CPU). So far, any of the methods described here in this threads have worked for me.


Well there are different factors involved. I posted an EFI a couple posts back. I bet if you;


Note if you do not have a 200 series motherboard, remove the 200 series injector kext from the EFI before getting started.

Wipe a USB stick 8GB or greater

Format it GUID OSX Journaled

Use the createinstallmedia command to turn the HighSierra install app into a USB installer.

Then install the latest Clover to that USB stick.

Selecting only the top two UEFI options only

Then copying that EFI I posted onto the EFI partition of your newly created vanilla installer REPLACING what is there.

It will boot you through the install of High Sierra and you will be able to install the web drivers.
 
Status
Not open for further replies.
Top