Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.0 (378.10.10.10.15)

Status
Not open for further replies.
Joined
Sep 2, 2016
Messages
29
Motherboard
ASROCK LGA
CPU
i3 Quad
Graphics
GTX 1050Ti
Mac
  1. Mac Pro
Classic Mac
  1. Classic
I am currently away from my desktop, but I am anticipating a possible fix for the graphical issues experienced by all owners of GTX 1060s.

This BETTER have fixed it. I just want to wake my machine up and have it work without my having to re-log every time.
 
Joined
May 28, 2016
Messages
406
Motherboard
Gigabyte Z170N-WIFI (ITX)
CPU
i7-6700K
Graphics
R9 380X
Mobile Phone
  1. iOS
Bad idea enabling SIP. SIP needs to be disabled at all times on a Hackintosh. (CsrActiveConfig 0x67).
.. no. I have SIP enabled all the time.

Thats not to say there's any advantage of having so, but I do.
 
Joined
Mar 22, 2016
Messages
12
Motherboard
ASRock Taichi Z270
CPU
i7-7700K
Graphics
RX 580
Mobile Phone
  1. Android
I am new to Hackintosh and also to this forum.

I have tried almost everything suggested in this thread, after having the SIP enabled I was able to have the nVidia web drivers installed, but on reboot, I am stuck with this line showing on a blank screen
"IOConsoleUsers : gIOScreenLockState 3, ...."

then the screen goes blank and again the same line shows up.

I am able to get into the OS only using the -x and nvda_drv=1 checked at boot in clover.
Any help would be appreciated.

In spite of the problem I reported earlier. When I boot into the OS using -x and nvda_drv=1 in clover after the driver is successfully installed,
I find the screen resolution much higher. Does this point to any clue's anyone? Has anyone with the same graphics card GTX TITAN X managed to get it working under High Sierra 10.13?
Screen Shot 2017-09-28 at 12.18.14 AM.png
 
Last edited:
Joined
Jun 9, 2013
Messages
10,755
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
.. no. I have SIP enabled all the time.

Thats not to say there's any advantage of having so, but I do.

Not a good idea. Will cause issues with booting & Kext Injection.
 
Joined
Jan 7, 2011
Messages
166
Motherboard
Gigabyte Z68MX-UD2H-B3
CPU
i7-2600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Classic Mac
  1. 512K
  2. iBook
  3. iMac
  4. LC
  5. Performa
  6. Plus
  7. PowerBook
  8. SE
  9. SE/30
I am currently away from my desktop, but I am anticipating a possible fix for the graphical issues experienced by all owners of GTX 1060s.

This BETTER have fixed it. I just want to wake my machine up and have it work without my having to re-log every time.

I don't think it's reasonable to expect nVidia to fix an issue only experienced by Hackintosh owners.
 
Joined
Aug 2, 2012
Messages
34
Motherboard
ASUS ROG RAMPAGE V EDITION 10
CPU
E5-2696 v4
Graphics
Vega 64
Mac
  1. Mac Pro
Any news about the multiple displays problem on screens wake? I'm still on 10.12.6 and I still have this problem, I wonder if NVidia fixed it with the new drivers, does anyone had it and tested if it's disappeared?

Thanks
 
Joined
Dec 1, 2015
Messages
9
Motherboard
Asus Maximus VIII Hero
CPU
Intel i7 6700k
Graphics
MSI GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have updated my Sierra to High Sierra without any issues. I have also installed the webdriver. It runs smoothly only the shutdown takes longer also on my macbook pro original takes so long to shutdown..
 
Joined
Feb 6, 2017
Messages
34
Motherboard
Gigabyte GA-170X-UD3 Ultra (rev 1.0)
CPU
i7-6700k
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
For those of you with issues, did you upgrade through App Store like suggested, or do a clean install? I just upgraded from 10.12.6, and had no issues with the driver or getting sound to work. Boots up faster than my real Macs....
I did the same, upgraded from 10.12.6 and I got issue with driver and got black screen
 

aol

Joined
Apr 14, 2011
Messages
503
Motherboard
GA-Z370-HD3P
CPU
i7-8700K
Graphics
RX570
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
FWIW on my 10.13 with the new Nvidia web drivers on a 1060 6GB, the screen flickering issues after sleep not only haven't gone away, they got worse. Now I put the system to sleep, wake it up, and after a few moments BOTH monitors (used to be one monitor mainly) go completely (worse, I think) wonky, and to boot, using my "put display to sleep with hot corner then wake up" fix no longer works cleanly. I've only tried this once so far, but on one monitor I lose the mouse completely.

Ug.
 
Joined
Feb 21, 2017
Messages
200
Motherboard
HP Envy 17-U275CL
CPU
i7-8550U
Graphics
GTX MX150 / HD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
My SMBIOS has an iMac 18,2, as is a Kaby Lake i7 7700K, shall this work with this fix or I have to change definition?
I am pretty sure 18,2 allows for Nvidia. So you do not need the NvidiaGraphicsFixUp / Lilu or AGDP patch to make it load, so try just injecting or installing NVWebDriverLibValFix.kext see if you get past the black screen.


With iMac 17,1 15,1 Mac Pro 6,1 (and possibly others) it will not allow Nvidia to load and give a black screen unless you use NvidiaGraphicsFixUp / Lilu or AGDP patch.

So in some cases on here, like me, my black screen was only related to NVWebDriverLibValFix.kext. Oh make sure to enable Nvidia Web in the config.plist( I use SMBIOS 18,3).

But reading through the entire thread again, it seems like there are many factors involved. I hope it works for you.
 
Last edited:
Status
Not open for further replies.
Top