Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for 10.10.0 (343.01.01) with 'Maxwell' GeForce GTX 970 an

Joined
Oct 18, 2014
Messages
7
Motherboard
Gigabyte Z97x-SLI
CPU
Intel 4790S
Graphics
Asus Geforce GTX 750
Mac
Mac Pro
Classic Mac
Power Mac
Mobile Phone
iOS
Alright so, I'm a fresh new hackintosh user and I try my best to follow the forums for my list of parts, but it's very overwhelming. First, my specs are Mobo:Gigabyte Z97x-sli
Processor: Intel 4790S
Graphics: Asus Geforce GTX 750 (not the "ti")
Last night when i did my first install I decided to go with Sierra. After I got it running to the desktop I wanted to smooth out all the bugs. The main bug I am having an encounter with is the ability to use my graphics card. I tried everything from watching youtube videos to scouring this site on every thread. No luck. I decided to downgrade to El Capitan and see if that would help me with anything. Still encountering the same issues.

So here is the description of my issue and if anyone would be willing to help I would greatly appreciate that!
OSX boots up just fine and uses the mobo graphics and everything works properly. From there I decided to try and get it to run off the graphics card. I did this multiple ways, as I reinstalled a fresh copy of OSX almost every time I couldn't get it to work. The first time I just tried doing the "inject nvidia" through the Multibeast application. That did nothing, but tell me what kind of card I had in my computer. 2. The second way I downloaded the web drivers for the card and installed them. After my computer restarted and booted off the ssd it would just show a blank screen like nothing was connected to the monitor. (BTW I am using an HDMI cable because I am connected to a TV as my monitor). To fix this issue I would have to type into the boot args "nv_disable=1" to just get the computer to boot. The "nvda=1" line of code or however it goes was also written in there. It is written in there every time. So after I get back to the desktop screen and go to "about mac" I can see what graphics card I have and it says "0mb" of it is in use. I read on a forum somewhere that to fix this I would have to go into the boot loader, like when I'm restarting the computer and go to inject graphics and put a "+" for nvidia. It was already there though.


I am a Novice at all the programming, and changing the code like the kexts and using clover and all that. It's confusing to me and I'm trying to learn. If there is anyone that would be willing to help me solve this issue, and help me gain full access to my graphics card I would greatly appreciate that! I'm hoping that this will fix my other issue with audio as I'm using an HDMI cable and used the Altec 1150 in the multibeast set up. Thanks again!
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,109
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
GTX 970
Mac
MacBook Pro
Classic Mac
PowerBook
Mobile Phone
iOS
Alright so, I'm a fresh new hackintosh user and I try my best to follow the forums for my list of parts, but it's very overwhelming. First, my specs are Mobo:Gigabyte Z97x-sli
Processor: Intel 4790S
Graphics: Asus Geforce GTX 750 (not the "ti")
Last night when i did my first install I decided to go with Sierra. After I got it running to the desktop I wanted to smooth out all the bugs. The main bug I am having an encounter with is the ability to use my graphics card. I tried everything from watching youtube videos to scouring this site on every thread. No luck. I decided to downgrade to El Capitan and see if that would help me with anything. Still encountering the same issues.

So here is the description of my issue and if anyone would be willing to help I would greatly appreciate that!
OSX boots up just fine and uses the mobo graphics and everything works properly. From there I decided to try and get it to run off the graphics card. I did this multiple ways, as I reinstalled a fresh copy of OSX almost every time I couldn't get it to work. The first time I just tried doing the "inject nvidia" through the Multibeast application. That did nothing, but tell me what kind of card I had in my computer. 2. The second way I downloaded the web drivers for the card and installed them. After my computer restarted and booted off the ssd it would just show a blank screen like nothing was connected to the monitor. (BTW I am using an HDMI cable because I am connected to a TV as my monitor). To fix this issue I would have to type into the boot args "nv_disable=1" to just get the computer to boot. The "nvda=1" line of code or however it goes was also written in there. It is written in there every time. So after I get back to the desktop screen and go to "about mac" I can see what graphics card I have and it says "0mb" of it is in use. I read on a forum somewhere that to fix this I would have to go into the boot loader, like when I'm restarting the computer and go to inject graphics and put a "+" for nvidia. It was already there though.


I am a Novice at all the programming, and changing the code like the kexts and using clover and all that. It's confusing to me and I'm trying to learn. If there is anyone that would be willing to help me solve this issue, and help me gain full access to my graphics card I would greatly appreciate that! I'm hoping that this will fix my other issue with audio as I'm using an HDMI cable and used the Altec 1150 in the multibeast set up. Thanks again!
You will have to flash your GPU with a different vbios. Asus GTX 750/750ti cards do not work with HDMI in OS X without doing that. There is no other way besides getting a different brand GPU.

PS: next time create your own thread rather than posting in an unrelated thread that has been dead for 6 months.
 
Top