Contribute
Register

Nvidia GTX970 and High Sierra

Status
Not open for further replies.
Joined
Oct 9, 2015
Messages
16
Motherboard
Gigabyte Z97x-UD5H
CPU
i7
Graphics
GTX 970
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
I just upgraded from Yosemite to High Sierra. Seems like I managed to get the system working smoothly, except for a few issues, one of which is the noise coming from the graphics card.

It seems like the fans are constantly working at full speed (or going up and down in speed all the time). I wasn't experiencing such issues in Yosemite. The fans would usually speed up when working on video rendering or similar tasks. Now I hear them all the time...I was hoping someone here could get me in the right direction to fix this.
 
Joined
Oct 9, 2015
Messages
16
Motherboard
Gigabyte Z97x-UD5H
CPU
i7
Graphics
GTX 970
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Have you installed the Nvidia Web driver yet? High Sierra will not have a native driver for that card and will use a generic video driver that gives no hardware acceleration and probably no power/fan profiles.
I installed the web driver. I am not sure is it functioning properly though (everything looks and feels fine, except this issue with fans). Is there a way to check if hardware acceleration is working as intended?
 
Joined
Oct 9, 2015
Messages
16
Motherboard
Gigabyte Z97x-UD5H
CPU
i7
Graphics
GTX 970
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
If hardware acceleration is not working you will notice it right away at the sign in screen upon boot up. There will be lines and flicker from slow refresh when you enter that screen. Also, once in the desktop you will notice sluggishness with things like moving program windows around on the desktop.

Also, Check the Nvidia Web driver widget in the top right corner of the of the task bar (or whatever it's called. Sorry, I'm new to Mac and my main computing is still done in Windows). It's up there by the time and date and audio symbol. Anyway, open that up and it well tell you whether or not the Nvidia Web driver is actually active.
There's no flickering, as I mentioned before, everything looks and feels fine, and the web driver is indeed selected and active. The only real issue is I constantly hear the fans, they sound the same way as they sounded when I was e.g. rendering a video in Yosemite.
 
Status
Not open for further replies.
Top