Contribute
Register

NVIDIA GTX 650 Ti 2GB Boost

which graphics card manufacturer is recommended for GTX 650 Ti 2GB Boost ?


  • Total voters
    143
Status
Not open for further replies.
Joined
Apr 16, 2013
Messages
45
Motherboard
HackPro G5
CPU
i5-3750 3.4ghz
Graphics
EVGA GTX 650 Ti Boost SC
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
Hi all, I don't think this is too much of a thread hijack but I'm wondering if anyone has any concept of whether this card or the similarly sized 660 would fit in a build I'm doing inside an old G5 tower. I know someone on here mentioned they have a G5 build and figured I'd throw it out to the group.

Excuse my lack of technical terms but I'm just starting to figure out my first Hackintosh build and this is the one piece that is concerning me, in terms of fitting the right GFX into the system. Here's the motherboard I'm planning on using, too:


[TR="bgcolor: #F2F2F2"]
GIGABYTE GA-B75M-D3P
 
Joined
Mar 7, 2013
Messages
92
Motherboard
GA-X99M-Gaming 5
CPU
i7-5820K
Graphics
RX560
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello.
I purchased the gigabyte gtx 550 ti boost. My problem is that I can't get display port to work.
Hdmi works. Haven't tried dvi. Profiler it's show k106 for I'd. I'm thinking I may have a kext problem. I had a gtx 660 installed. Which the displayed worked. I returned that card for a cheaper 550 ti boost. I never reinstalled 10.8.3. I just popped in the new 550 ti boost.
I really don't wanna reinstall. I set up a raid boot drive. So it's kinda a pain.
Mom running a z77n-wifi with i5 3570k. Any help would be great!!
thx guys.
 
Joined
Apr 8, 2011
Messages
32
Motherboard
Still looking.
CPU
Still looking.
Graphics
Still looking.
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello.
I purchased the gigabyte gtx 550 ti boost. My problem is that I can't get display port to work.
Hdmi works. Haven't tried dvi. Profiler it's show k106 for I'd. I'm thinking I may have a kext problem. I had a gtx 660 installed. Which the displayed worked. I returned that card for a cheaper 550 ti boost. I never reinstalled 10.8.3. I just popped in the new 550 ti boost.
I really don't wanna reinstall. I set up a raid boot drive. So it's kinda a pain.
Mom running a z77n-wifi with i5 3570k. Any help would be great!!
thx guys.

Have you installed the drivers from Nvidia ?

I don't know if i'm right...but i think 5xx work with Lion and 6xx work with Mountain Lion.
I have the same config than you but i'm running an HD4000.
 
Joined
Mar 7, 2013
Messages
92
Motherboard
GA-X99M-Gaming 5
CPU
i7-5820K
Graphics
RX560
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Thx for the response. Actually It's a gtx 650 ti boost. From the new buyers guide.
Should I install the drivers from Nivida ? Which ones ?
 
Joined
Apr 8, 2011
Messages
32
Motherboard
Still looking.
CPU
Still looking.
Graphics
Still looking.
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thx for the response. Actually It's a gtx 650 ti boost. From the new buyers guide.
Should I install the drivers from Nivida ? Which ones ?

If you have 10.8.3, you don't need any because it is supposed to be natively.

Which brand do you have ? EVGA, Gigabyte, etc ?

I'm planning to buy it but i don't know which one to choose.
I'm thinking about EVGA and Gigabyte.
 
Joined
Mar 7, 2013
Messages
92
Motherboard
GA-X99M-Gaming 5
CPU
i7-5820K
Graphics
RX560
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I've purchased the gigabyte version from the April buyers guide.
I figured it was supported natively with 10.8.3.
 
Status
Not open for further replies.
Top