NVidia 140M on a T61 - anyone got this working?

Discussion in 'Lion Laptop Support' started by paul778, May 15, 2012.

  1. paul778

    paul778

    Joined:
    Jun 22, 2011
    Messages:
    2
    May 15, 2012 at 9:23 PM #1
    paul778

    paul778

    Joined:
    Jun 22, 2011
    Messages:
    2
    Going around a little in circles. I've already installed Lion 10.7.3 on my desktop machine and am now trying to get it working on my old laptop.

    It's a Lenovo T61, and I can get it to boot up to 10.7.3 using UniBeast with PCIRootUID=0 and GraphicsEnabler=no. I'm stuck on the Video card - NVidia 140M - and getting it to work right. I've tried with the basic vanilla setup and get this error on startup.

    : Kext com.apple.GeForce - library kext com.apple.NVDAResman not found.
    : Can't load kext com.apple.GeForce - failed to resolve library dependencies.
    : Kext com.apple.GeForce failed to load (0xdc00800e).
    : Failed to load kext com.apple.GeForce (error 0xdc00800e).
    : Couldn't alloc class "NVKernel"

    When I try to use NVEnabler I get a 'NVEnabler::probe failed' message and then the machine reboots. NB: All I have done to enable NVEnabler is load the kext, rebuild perms and cache.

    Have I missed something, or does this card just not work with Lion?

    cheers

    Paul
     
  2. paul778

    paul778

    Joined:
    Jun 22, 2011
    Messages:
    2
    May 16, 2012 at 10:05 PM #2
    paul778

    paul778

    Joined:
    Jun 22, 2011
    Messages:
    2
    As an update to the above...

    I've managed to get a little further in...

    If I install a valid MacPro3,1 profile with MultiBeast first I can install the latest NVidia driver ( 2502-Retail_270.00.00f01.dmg ). I can then boot the machine with GraphicsEnabler=no and get the proper native resolution of the screen. However, I am still struggling to get this to work with GraphicsEnabler=yes. Are there any tricks involved in getting GE working?

    cheers
     
  3. westnylefx

    westnylefx

    Joined:
    Jun 8, 2012
    Messages:
    12
    Jun 29, 2012 at 1:12 PM #3
    westnylefx

    westnylefx

    Joined:
    Jun 8, 2012
    Messages:
    12
    You dont need GE=Yes...
     

Share This Page