Contribute
Register

NootedRed — AMD Radeon Graphics — macOS Sonoma

As mentioned above I'm back on the 450 motherboard and the new HyperX monitor is incredibly nice, the 240 MHz refresh rate is staggering and the bump to 16 GB VRAM makes a huge difference. Yeah I'm sold!.

Screenshot 2023-08-09 at 5.31.42 PM.png
 
@Edhawk have you disabled CSM as well?.
 
  1. I disabled Above 4G Decoding in the BIOS, added ncpi=0x3000 in boot args, and disabled CSM at the very start before installing macOS or Windows.
  2. I've tried 1GB, 2GB, 4GB and 8GB for VRAM.
  3. Removed my native Apple WiFi/BT card (on PCIe adapter).
  4. Disabled WiFi/BT in bios, also physically removed the built-in MediaTek card.
Only way I can get the system to boot when using the APU is by adding WhateverGreen.kext to the OC setup, and removing NootedRed.kext. But that means no acceleration in macOS, as only 7MB of VRAM is visible.

I'm going to try with both enabled and see what sort of mess that makes!
 
In my setup I don't have the WhateverGreen.kext installed. These were the last BIOS settings I used on a ASUS motherboard, try disabling IOMMU.

IMG_4426.jpeg


Screenshot 2023-08-09 at 6.15.11 PM.png
 
This is the contents of my OC 0.9.4 EFI, as used on the Asus B550 system. It works perfectly with an AMD dGPU and WEG installed in place of NootedRed.

Screenshot 2023-08-09 at 23.27.32.png

Booting with NootedRed.kext (the one you linked on the other page) leads to a kernel panic, as shown in the photo below.

Screenshot 2023-08-09 at 22.51.25.png

This happens every time I boot the system without WEG!

As for the BIOS settings I used the same as you except for these two:
SR-IOV Support is disabled
I have no idea what IOMMU is set as, but it could be enabled, if that is the default setting.

I'll check and switch them to match your settings, to see if that makes any difference when booting with NootedRed.
 
Changed the BIOS settings to match yours and still can't boot with NootedRed. Exactly the same error shown in the verbose text.

Something to think about tomorrow!
 
Changed the bios settings to match yours and still can't boot with NootedRed.
You're really close because I recognize that verbose message that you posted. Have you tried MacPro7,1 SMBIOS, I have clean installed and booted using that.
 
@Edhawk do you have any Device Properties in your config?. It was advised by ChefKissinc on his GitHub Discussion page to remove them.
 
@Edhawk just a couple of other things I forgot to mention;

• You're using RestrictEvents.kext, add boot arg revblock=media.
• Did you read this post, #26, on my other thread?.
 
@Edhawk another option is to try ChefKissIncs version of the AMD_Vanilla Patches, I just booted with them from a EFI on a USB stick.

Screenshot 2023-08-10 at 9.07.42 AM.png
 
Back
Top