Contribute
Register

No Sound - Realtek ALC AppleHDA [Guide]

Status
Not open for further replies.
Joined
Oct 11, 2010
Messages
728
Motherboard
X299-WU8
CPU
i9-9880XE
Graphics
Vega 64
Mac
  1. iMac
  2. Mac Pro
Oh thats why ...I just know its not Realtek Any option for Creative codec CA0132
 
Joined
Oct 11, 2010
Messages
728
Motherboard
X299-WU8
CPU
i9-9880XE
Graphics
Vega 64
Mac
  1. iMac
  2. Mac Pro
Hi toleda can you help for me add devices HDEF and HDAU for x99 gaming g1 wifi to DSDT my bios version F10b
I upload my dsdt.aml
 

Attachments

  • dsdt-ga-x99 gaming g1 wifi.zip
    19.8 KB · Views: 54
Joined
May 17, 2015
Messages
22
Motherboard
Gigabyte GA-Z97MX-GAMING 5
CPU
Intel Core i7-4790K
Graphics
EVGA Nvidia GeForce GT740 SC
Mobile Phone
  1. iOS
No Sound - Realtek ALC1150 AppleHDA Trouble shooting (June2015)

  1. Description of audio problem

After several config’s, I had Audio, now there is NO Audio.


  1. OS X version/motherboard model/BIOS version/processor/graphics

OS X10.10.3 (UniBeast/Chimera)

Gigabyte GA-Z97MX-GAMING 5 (BIOS F4) - Documentation states I have ALC1150 Audio Codec
Intel Core i7-4790K 4.0GHz
EVGA Nvidia GeForce GT 740 SC
Crucial Ballistix Tactical (32GB)


3 . Procedure/Guide Used


    1. Terminal Saved Output (if Terminal script run)
      1. realtekALC
      2. AppleHDA8Series
      3. cloverALC

Did not run Terminal Script.


I have done several steps for Audio that may have complicated the issue.



  • After successful install of Yosemite, I installed the ALC1150 driver by itself. I had no Audio.
  • I installed a VoodDoo driver. Audio worked.
  • Following Forum advice, I removed the VooDoo driver from the Extensions (and Pref Panes). Audio seems to have worked for a short time, but then stopped.
  • I re-installed ALC1150 WITH the 'Optional EFI Bootloader Support' (not realizing this was for Clover). No Audio.
  • I re-installed ALC1150 WITH 'Audio: ID 1'. No Audio.



  1. Copy of IOReg (Tools 1.1) or IOJones (Tools 1.2)
    1. IOReg/File/Save a Copy As…, verify file (no ioreg.txt)
    2. IOJones/Save..

I did not use any of these Tools.



  1. System/Library/Extensions/AppleHDA.kext

View attachment AppleHDA.kext.zip

AppleHDA.png


  1. System/Library/Extensions/AppleHDAxxx.kext (if installed).

None Installed.


  1. Console/All Messages/kernel Sound Assertions - select/Save Selection As:

Many of my early Kernel Panics seemed to be Graphic Card related and when I install the newest Nvidia Driver, things were working well (with VooDoo installed), So I won't put any images of those early Kernel Panics. They all seemed to have something like 'IOPCIFamily.kext' 'IOAPCIFamily.kext' 'IOGraphicsFamily.kext'.

My Most recent panic was a 'IOBluetoothFamily.kext'

I haven't had any that seem Audio related. And since I installed ALC1150 AND Audio:ID1' I haven't yet had any issues with Waking from Sleep or any Kernel Panics.


  1. Screen shots:
    1. System Information/Hardware/Audio/Intel High Definition Audio (not Devices)

MAC Overview.png
Display.png
Audio.png


    1. System Preferences/Sound/Output

Audio Output.png




  1. Chimera/Chameleon (if installed)
    1. Extra/org.chameleon.Boot.plist

View attachment org.chameleon.Boot.plist


Chamelon Plist.png


    1. DPCIManager/Misc/Boot Log

DPCIManager1.pngDPCIManager2.pngDPCIManager0.png


  1. Speakers and/or microphone
    1. Make and model

Soundbar that came with the Dell Monitor. It has been working fine for years AND has worked with Yosemite with VooDoo.


    1. Audio port connected (color, motherboard or case)

Port is Yellow/Green (I had Audio working from this Port at one time or another)
Audio Port.jpg



    1. Selection in System Preferences/Sound/Output or Input


Audio Output.png



Thanks in advance. I'm sorry if I left out any pertinent info.


TOLEDA RESPONDED - Attach IOReg/save a copy as...

View attachment MB Mac Pro.ioreg

and DPCIManager screenshot.

Not sure how many of the tabs you need screenshots of.

DPCIManager0.pngDPCIManager1.pngDPCIManager2.png


Voodoo likely was not removed completely

The only advice I could find on removing it was to Delete the Extension and to Delete the Preference Pane. I only removed these 2 files.

View attachment VoodooHDA.kext.zip
View attachment VoodooHDA.prefPane.zip


org.chameleon.Boot.plist shows MultiBeast/1150 audio was not installed properly

Not sure how else to Install ALC1150. As I wrote earlier, I Installed several ways using MultiBeast. Did the multiple-installation cause the AppleHDA to be configured incorrectly?
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I have done several steps for Audio that may have complicated the issue.

  • After successful install of Yosemite, I installed the ALC1150 driver by itself. I had no Audio.
  • I installed a VoodDoo driver. Audio worked.
  • Following Forum advice, I removed the VooDoo driver from the Extensions (and Pref Panes). Audio seems to have worked for a short time, but then stopped.
  • I re-installed ALC1150 WITH the 'Optional EFI Bootloader Support' (not realizing this was for Clover). No Audio.
  • I re-installed ALC1150 WITH 'Audio: ID 1'. No Audio.
Attach IOReg/save a copy as... and DPCIManager screenshot.
Voodoo likely was not removed completely
org.chameleon.Boot.plist shows MultiBeast/1150 audio was not installed properly
 
Joined
May 17, 2015
Messages
22
Motherboard
Gigabyte GA-Z97MX-GAMING 5
CPU
Intel Core i7-4790K
Graphics
EVGA Nvidia GeForce GT740 SC
Mobile Phone
  1. iOS
Thanks. Hope this is all correct.

Attach IOReg/save a copy as...

View attachment MB Mac Pro.ioreg

and DPCIManager screenshot.

Not sure how many of the tabs you need screenshots of.

DPCIManager1.pngDPCIManager2.pngDPCIManager0.png

Voodoo likely was not removed completely

The only advice I could find on removing it was to Delete the Extension and to Delete the Preference Pane. I only removed these 2 files.

View attachment VoodooHDA.kext.zip
View attachment VoodooHDA.prefPane.zip

org.chameleon.Boot.plist shows MultiBeast/1150 audio was not installed properly

Not sure how else to Install ALC1150. As I wrote earlier, I Installed several ways using MultiBeast. Did the multiple-installation cause the AppleHDA to be configured incorrectly?
 

Attachments

  • MB Mac Pro.zip
    3.6 MB · Views: 53
Joined
Oct 11, 2010
Messages
728
Motherboard
X299-WU8
CPU
i9-9880XE
Graphics
Vega 64
Mac
  1. iMac
  2. Mac Pro
{The X99 audio ssdt enables HDEF and HDAU without dsdt edits. Special edits are required for HDMI audio on the second graphics card.}


Thanks Tolida.
 
Joined
Feb 20, 2012
Messages
9
Mac
Classic Mac
Mobile Phone
Audio is configured properly. Big problems in config.plist.
config.plist/Boot/Arguments/-v -xcpm kext-dev-mode=1 work, remove the others/not Clover supported
config.plist/ACPI/DSDT/Fixes/NO, set all to NO.
Front panel mutes rear green port.
Thank you toleda for your help. I applied the fixes you mentioned. My audio now works; however, only three channels are detected: Internal speakers (green port), Line out (orange port) and Line out (black port). My motherboard supports 7.1 audio, so I should be able to use another channel. How can I fix that?
Also, I was wondering, is it possible to control via software wether the green rear panel port is muted and the front one activated? I think my case doesn't support sensing the audio connector.

Thanks.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I should be able to use another channel. How can I fix that?
is it possible to control via software wether the green rear panel port is muted and the front one activated?
Gray requires AppleHDA.kext edits, see 6. Add Line Out (Gray/Rear -Rear Speakers) for analog 7.1 Surround Sound in Customization - Realtek ALC AppleHDA_v2 [Guide].pdf
Front pane/green mutes motherboard/green, see 3. Manual Speaker and Headphone Selection, same guide
Note: gray or green edits, not both
 
Status
Not open for further replies.
Top