Contribute
Register

No Sound - Realtek ALC AppleHDA [Guide]

Status
Not open for further replies.

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,448
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Same, IOReg shows no audio source connected to the selected audio device.
Does the system boot without -f?
Try Orange/1st line Out and Black/2nd Line Out; reply with an IOReg for each
Are you dual booting with Windows? If yes, are Realtek drivers installed?
No Windows - OS X is only drive connected. Had everything working previously with 10.10.2 and Clover, but 10.10.3 could not boot after upgrade due to AptioFix not working - tried building newest Clover with Clover Grower Pro but same problem - can't get past this point whether I use AptioFix version 1 or version 2 when making the boot USB and if the USB doesn't work then no boot to desktop.

System boots without -f and with UseKernelCache=Yes with no problem - modified org.chameleon.boot.plist accordingly and rebooted for these tests - shutdown, move audio jack, boot up each time.

View attachment AudioBlack.zip
View attachment AudioOrange.zip
View attachment org.chameleon.Boot.plist.zip
 
Joined
Mar 26, 2012
Messages
19
Motherboard
MSI X299M GAMING PRO CARBON AC
CPU
i9-7900X
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
X99M Killer with Clover - No sound

Hi,

X99-M Killer (ALC1150)
Core i7-5820K
Radeon HD 5450
Clover bootloader

I have devices listed and volume control functions but no sound. iTunes and youtube will not play.

Selected Headphones with headphones inserted in front output or rear green socket.

Thanks for your help!
 

Attachments

  • IOReg.ioreg
    5.2 MB · Views: 76
  • AppleHDA.kext.zip
    1.1 MB · Views: 67
  • SystemPrefsAudioOut.jpg
    SystemPrefsAudioOut.jpg
    44.7 KB · Views: 81
  • SystemInfoAudio.jpg
    SystemInfoAudio.jpg
    119.7 KB · Views: 80
  • Console Assertions.log
    54 KB · Views: 82
  • config.plist
    4.3 KB · Views: 183
  • BootLog.txt
    29.4 KB · Views: 80

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,448
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
10.10.2 audio? AirPlay audio devices?
10.10.2 was working booting Clover. Audio through the green jack or through the optical output and also HDMI. When nVidia posted 10.10.3 driver updates I updated OS X and Clover no longer works. Hangs at Aptiofixdrv and no value of slide I tried worked so I gave up on it and went to UniBeast and Chimera.

Also had 10.9.5 working with Clover and the nVidia drivers for the GTX980 - audio worked there too, green jack, optical and HDMI.

Followed your Clover guide on the 10.9.5, 10.10.0/.1/.2 with no problems until I hit the Aptio thing with 10.10.3.
 
Joined
Mar 26, 2012
Messages
19
Motherboard
MSI X299M GAMING PRO CARBON AC
CPU
i9-7900X
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
config.plist/ACPI/DSDT/Fixes/YES = no sound.
Set all fixes to NO or delete Fixes
AppleHDA.kext is not patched for x99
What x99 audio guide did you use?

I can't boot after deleting all DSDT fixes. The AppleHDA.kext I'm using is the ALC1150 one from latest Multibeast.
I didn't use an audio guide, just the X99 Clover installer with defaults for config.plist, then installed AppleHDA.kext into S/L/E after following your No sound guide. Thanks!
 
Joined
Mar 26, 2012
Messages
19
Motherboard
MSI X299M GAMING PRO CARBON AC
CPU
i9-7900X
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
OS X does not support X99 anything. For X99 audio fix, see Post #1, Realtek ALC AppleHDA.

Hi, have followed instructions from X99 linked thread, however altering config.plist as you suggest means the HDA outputs other than HDMI no longer show up in System Info, and Codec ID disappears from DPCIManager. Patched Vanilla 10.10.3 AppleHDA.kext causes kernel panic.

Thanks again for your help with this!
 

Attachments

  • config.plist
    4.7 KB · Views: 198
Status
Not open for further replies.
Top