Contribute
Register

No Sound - Realtek ALC AppleHDA [Guide]

Status
Not open for further replies.

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,460
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Try this ssdt. In iTunes, is the timer working? Stuck?
Reply with new IOReg.

Still no sound.
iTunes never comes off 0:0 counter on the left side, so I assume it is not initializing to play the file.
Thought it might be the .mp3 so tried with a CD - same results - no sound

Screen Shot 2015-06-02 at 5.48.39 PM.png

The title banner does scroll, though, if it makes a difference.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,962
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Installed SSDT - no help, still no sound
Incorrect ssdt. Install the ssdt from Post #454.
Install the attached AppleHDA.kext.
Reply with new IOReg and tableset.
 

Attachments

  • AppleHDA.kext.zip
    1.1 MB · Views: 43

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,460
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Incorrect ssdt. Install the ssdt from Post #454.
Install the attached AppleHDA.kext.
Reply with new IOReg and tableset.
OK, AppleHDA installed with Kext Wizard, repair perms/update caches
SSDT from post 454 in /Extra renamed from SSDT,aml.aml to SSDT.aml
Reboot with -f. Everything looks as if audio ought to work, but no sound output. Even tried different speakers and optical - still nothing. It feels like it is something simple I am failing to remember to do but can't for the life of me figure out what that is.

View attachment X99MKiller.zip
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,962
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Reboot with -f.
-f is not necessary unless there is a cache problem. Boot without -f.
Onboard, same issue, internal speakers selected, iTunes does not connect to the audio device.
HDMI: ssdt is working, connect a HDMI device to the graphics card, select HDMI, verify sound.
Reply with IOReg.
 
Joined
Feb 20, 2012
Messages
9
Mac
Classic Mac
Mobile Phone
Hello. I've been trying to make my onboard ALC892 sound card work, but to no avail. I've tried all the methods available, but to no avail. The only thing that's working on my computer is VoodooHDA, but it only makes my front panel port work.

Here is the all the information you need:
1) The devices are shown in System Preferences and in Audio MIDI Setup, but no sound can be played through them (it's as if they were muted). Also, even though my motherboard is 7.1 compatible, only three channels are actually detected.
2) 10.10.3 / Gigabyte GA-Z87MX-D3H / F7 / Pentium G3420 (Haswell) / NViIDIA GT 610
3) All the methods have been tried. cloverALC makes at least the devices show up in System Preferences.
11) Two pairs of analog speakers, one connected to the rear green port, and one to the front panel (which is the only port I was able to make it work with VoodooHDA).


Thanks a lot in advance, any help you may give me is much appreciated!
 

Attachments

  • Information requested.zip
    2.2 MB · Views: 65

toleda

Moderator
Joined
May 19, 2010
Messages
22,962
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
trying to make my onboard ALC892 sound card work, but to no avail.
Audio is configured properly. Big problems in config.plist.
config.plist/Boot/Arguments/-v -xcpm kext-dev-mode=1 work, remove the others/not Clover supported
config.plist/ACPI/DSDT/Fixes/NO, set all to NO.
Front panel mutes rear green port.
 
Status
Not open for further replies.
Top