Contribute
Register

No Sound - Realtek ALC AppleHDA [Guide]

Status
Not open for further replies.

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,460
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
IOReg shows Internal Speakers selected and no audio player. What audio source and player are you using to test for sound?

System preferences->sound->output device->internal speakers
Using the output sound effects for the test and an mp3 file - soundtrack from The Magnificent Seven.
Quick player will not play mp3 files - double-click on the file, QP opens but shows the start triangle in the center; click on it and nothing changes - still shows triangle. Downloaded VLC player and tried with it - double-click on mp3 file - player locks up with spinning beachball of death, seconds display on clock ceases to change. 10 minutes later still locked up, so powered off and re-booted.

There are a pair of Bose Companion2 desktop speakers plugged into the green audio port on the back panel.

Speakers do work - connected then to the Z87I build sitting on the other end of the table and they work just fine.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,962
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
The SSDT-1 did not work at all - no HDEF in IOREG, so tested with MB selections
HDAEnabler1.kext is present in both IORegs making the experiments invalid for the tests described.
With HDAEnabler1.kext (WOHDAEnablerdylib files), valid, iTunes did not attach to Internal Speakers, fail.

Two New Experiments (remove S/L/E/HDAEnabler1.kext)
1. With HDAEnablerdylib/iTunes
2. With SSDT-1 (WO HDAEnablerdylib)/iTunes.

BTW, the 1150 codec is HDEF@1B. Nvidia HDMI audio codec is @0,1.
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,460
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
HDAEnabler1.kext is present in both IORegs making the experiments invalid for the tests described.
With HDAEnabler1.kext (WOHDAEnablerdylib files), valid, iTunes did not attach to Internal Speakers, fail.

Two New Experiments (remove S/L/E/HDAEnabler1.kext)
1. With HDAEnablerdylib/iTunes
2. With SSDT-1 (WO HDAEnablerdylib)/iTunes.

BTW, the 1150 codec is HDEF@1B. Nvidia HDMI audio codec is @0,1.
Removing HDAEnabler1.kext results in no audio devices.
SSDT-1 also results in no audio device, with or without HDAEnabler.dylib
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,962
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Removing HDAEnabler1.kext results in no audio devices.
SSDT-1 also results in no audio device, with or without HDAEnabler.dylib
My mistake, HDAEnabler.dylib does not work with x99 (ALSA instead of HDEF). If no Extra/ssdt.aml, rename ssdt-1.aml to ssdt.aml and install in Extra. Restart and attach IOReg, bdmesg/boot.log and MaciASL/tableset.
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,460
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
My mistake, HDAEnabler.dylib does not work with x99 (ALSA instead of HDEF). If no Extra/ssdt.aml, rename ssdt-1.aml to ssdt.aml and install in Extra. Restart and attach IOReg, bdmesg/boot.log and MaciASL/tableset.
Changing SSDT-1 to SSDT gets output devices back, but still no audible sounds.

View attachment X99M-SSDT.zip
 
Status
Not open for further replies.
Top