Contribute
Register

No Sound - Realtek ALC AppleHDA [Guide]

Status
Not open for further replies.
Joined
Sep 10, 2014
Messages
2
Mac
Classic Mac
Mobile Phone
Ok i've gone through this and i have a problem.

EVERY time i reboot i have to reselect internal speaker. I have no option to select rear green output like i did with voodo.

i can only guess that i've mucked up something.

my motheroard:

gigabyte z87x-ud3h (bios version F9 - latest) on an i5-4670k (3.4gz)

The onboard sound is an Realtek® ALC898 codec


my options:
digital out
headphones (always default when i reboot)
internal speakers

i have to change it every time. iv'e tried every option 1, 2, 3, 7, 11, (and a couple of others but sitll no rear green output option)

i can give more info.
 
Joined
Aug 8, 2012
Messages
58
Motherboard
Gigabyte GA-H55-USB3: F5
CPU
i7-870
Graphics
GTX 960
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thanks in advance for your help.

So, while I was gathering requested information, my computer went to sleep a few times and did not wake. The information was completely gathered after several restarts.

1.) No sound out of anything. Headphones, 2 Line Outs, Digital Out available (no Internal Speakers available), but no sound out of anything . Pressing Volume keys moves Volume animation, but no sound comes out. Have selected Headphones (and connected speaker to Headphone port) but nothing there either.

2.) 10.12.2 / GA-H55-USB3 / F5 / 2.93 GHz Intel Core i7 / GeForce GTX 960

3.) Sierra Desktop/Realtek AppleHDA Audio [Guide] / CloverALC

Terminal saved output attached

4.) attached

5.) attached

6.) Not installed

7.) Can’t find any kernel sound assertions. Used Find command.

8.) Attached

9.) N/A

10.) Attached

11.) Logitech x-230
green, motherboard
no ‘Internal Speakers’ showing up. Tried both front port and rear port. Also tried Digital Out.
Logitech HD Pro Webcam mic not showing up in Sound Preferences.
 

Attachments

  • DPCIManager Boot Log.pdf
    56.6 KB · Views: 175
  • System Info HD Audio.png
    System Info HD Audio.png
    125.7 KB · Views: 121
  • System Pref Sound Output.png
    System Pref Sound Output.png
    58.9 KB · Views: 80
  • DCPI Manager.png
    DCPI Manager.png
    114.1 KB · Views: 98
  • RobsMacPro.ioreg
    2.9 MB · Views: 74
  • Terminal Saved Output.txt
    3 KB · Views: 73
  • config.plist
    6.1 KB · Views: 176
  • AppleHDA kext upload error.png
    AppleHDA kext upload error.png
    33.5 KB · Views: 85

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
The information was completely gathered after several restarts
Not helpful. System Information/Hardware/Audio and System Preference/Sound/Output screenshots; impossible.

Remove Headphone
Set config.plist/ACPI/DSDT/Fixes/FixHDA_8000/NO
Install ssdt_hdef-1-with_ioreg:azal.zip
Compress AppleHDA.kext
Save boot log as .txt, .pdf cuts off important info.
Save, restart, reply with new files, same boot.
 
Last edited:
Joined
Aug 8, 2012
Messages
58
Motherboard
Gigabyte GA-H55-USB3: F5
CPU
i7-870
Graphics
GTX 960
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Way off track, not necessary
...Only do what is requested.

Hard for a non-tech to know sometimes. : ) So I need to back track. In config.plist I had checked and made a change or two. Could you verify:

ACPI/DSDT/Fixes
AddDTGP_0001 is set to YES

ACPI/DSDT
Debug is set to YES (I think it was NO)
 
Last edited:
Joined
Aug 8, 2012
Messages
58
Motherboard
Gigabyte GA-H55-USB3: F5
CPU
i7-870
Graphics
GTX 960
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
1.) No sound out of anything. 3 Line Outs, Digital Out available (no Internal Speakers available), but no sound out of anything.
2.) 10.12.2 / GA-H55-USB3 / F5 / 2.93 GHz Intel Core i7 / GeForce GTX 960
3.) Sierra Desktop/Realtek AppleHDA Audio [Guide] / CloverALC
Terminal saved output attached
4.) attached
5.) attached
6.) Not installed
7.) Can’t find any kernel sound assertions. Used Find command.
8.) Attached
9.) N/A
10.) Attached
11.) Logitech x-230 speakers
green, motherboard
no ‘Internal Speakers’ showing up. Tried both front port and rear port. Also tried Digital Out.
Logitech HD Pro Webcam mic not showing up in Sound Preferences.
 

Attachments

  • System Pref Sound Output.png
    System Pref Sound Output.png
    54.4 KB · Views: 71
  • System Info Audio.png
    System Info Audio.png
    130.3 KB · Views: 96
  • DPCIManager Status.png
    DPCIManager Status.png
    117.3 KB · Views: 86
  • DPCIManager Boot Log.txt
    25.4 KB · Views: 182
  • config.plist
    6.1 KB · Views: 109
  • AppleHDA.kext.zip
    1.7 MB · Views: 63
  • Terminal Saved Output.txt
    3 KB · Views: 90
  • RobsMacPro.ioreg
    2.9 MB · Views: 87
Status
Not open for further replies.
Top