Contribute
Register

No sound El captain p5q-e mother board

Joined
Dec 28, 2015
Messages
8
Mac
Classic Mac
Mobile Phone
Hello, I have a p5q-e mother board. Everything is working perfectly except for sound. I know the driver is SoundMAX 2000B Audio Driver V6.10.2.6585, but i would probably need a kext file to replace it. Any ideas to help me complet my first system:)? Thanks!
 
Joined
Oct 8, 2010
Messages
576
Motherboard
Z77E-ITX
CPU
Intel® Core™ i7-3770
Graphics
GTX650Ti
Mac
iMac
Classic Mac
Mobile Phone
iOS
Hello, I have a p5q-e mother board. Everything is working perfectly except for sound. I know the driver is SoundMAX 2000B Audio Driver V6.10.2.6585, but i would probably need a kext file to replace it. Any ideas to help me complet my first system:)? Thanks!
You have to provide more info about your installation. Are you using a DSDT? if no, how have you configured your config for audio? If you want provide your config.plist and a virgin DSDT. Do you have the latest El Cap 10.11.2?
 
Joined
Dec 28, 2015
Messages
8
Mac
Classic Mac
Mobile Phone
Hello, I have installed everything in Legacy mode. After using multi beast, i did not installed any audio drivers from multi beast and either no network drivers. I did have a problem with ethernet that as been solved with a .kext. Other then this, yes I have El captain 10.11.2.. Is it helping? Thanks!
 
Joined
Oct 8, 2010
Messages
576
Motherboard
Z77E-ITX
CPU
Intel® Core™ i7-3770
Graphics
GTX650Ti
Mac
iMac
Classic Mac
Mobile Phone
iOS
There are more ways to achieve Audio, in your case the simplest is to use an HDAEnabler and a patched AppleHDA, but this way you have to replace the kext at every Update. Using Clover is better to use his abilty to patch kext on the fly.
That's the same for your ethernet. If you want try the attached kext. Install the (original) IONetworkingFamily.kext in S/L/E (use kext wizard or similar App to do it, don't put it manually ) and copy Marvell88E8056.kext in EFI/CLOVER/kexts/10.11, repair permissions and rebuild cache and rebooot. This method will survive every update.
Attach your config.plist for audio edits
 

Attachments

Joined
Dec 28, 2015
Messages
8
Mac
Classic Mac
Mobile Phone
Hello,

I reinstalled the OS from scratch, in legacy mode. I also enabled a an appleHDA (voodooHDA) with multi beast. After i installed de 2 kext previously recommended. Ethernet is perfect but no audio can be recognize. I have regular desktop speakers. What shoul I do next or did i missed a step? Thanks!
 
Joined
Oct 8, 2010
Messages
576
Motherboard
Z77E-ITX
CPU
Intel® Core™ i7-3770
Graphics
GTX650Ti
Mac
iMac
Classic Mac
Mobile Phone
iOS
Post you config. plist (zipped) for audio edits (to do it click on "Manage attachments", chose your file and hit "Upload"). In the meantime delete VoodooHDA and the relative HDADisabler.
 
Joined
Oct 8, 2010
Messages
576
Motherboard
Z77E-ITX
CPU
Intel® Core™ i7-3770
Graphics
GTX650Ti
Mac
iMac
Classic Mac
Mobile Phone
iOS
Hello, Here is the original config.plist. I did not saved after installing multibeast. Can I provide you another file. Thanks for your help.View attachment 170360
What do you mean with "the original"? I need the one you are using now. You find it in EFI/CLOVER. If you have installed Clover in the ESP, first you have to mount your (hidden) EFI partition (use EFI mounter to do it).
Have you deleted Voodoo and HDADisabler?
 
Joined
Oct 8, 2010
Messages
576
Motherboard
Z77E-ITX
CPU
Intel® Core™ i7-3770
Graphics
GTX650Ti
Mac
iMac
Classic Mac
Mobile Phone
iOS
Be sure to have deleted even the HDADisabler.kext. Than replace your config in EFI/CLOVER with the one attached, install aDummy.kext with your preferred App in S/L/E. (The attached AppleHDA is the original for 10.11.2, should you have patched/modified your). Reboot and go in System preferences/ Sound und chose your output.
 

Attachments

Top