Contribute
Register

No sound after reboot laptop from windows 10 to macos

Joined
Nov 6, 2019
Messages
10
Motherboard
Asus
CPU
i5-8250u
Graphics
uhd 620 mx150
My sound chip is Realtek ALC256.I use AppleALC.kext and layout-id 13 can make sound working.When I reboot laptop from macos to macos,the sound works fine.But when I reboot to windows 10 and reboot to macos again,the sound isn't working.Sound setting can still identify my output and input devices and input level exists.But no sound output. When I reboot macos several times,the sound works again.
Tried methods
1.Complied AppleALC by myself and used configdata from my laptop
2.Changed other ALC256's layout-id(it caused my sound chip not working completely except layout-id=13)
3.Changed AppleALC and AppleHDA to other versions
4.Used CodecCommander,ALCPlugFix or ComboJack
 

Attachments

  • EFI.zip
    43.9 MB · Views: 96
Joined
Sep 6, 2012
Messages
130
Motherboard
Dell 5482
CPU
i5-8265U
Graphics
UHD 620
Mobile Phone
  1. iOS
I don't remember the technical jargon The legendary Rehabman used, but he said it had to with Windows not releasing some hardware protocols from the bios ,and ithis is what causes us to not have sound after a reboot.

so this is a known issue that we all face.
 
Joined
Jun 19, 2019
Messages
6
Motherboard
Medion Akoya S6445 i5-8265U
CPU
i5-8265U
Graphics
UHD 620
Hi, i have this exact problem, but mi sound card is ALC 235, there is a workaround with codeccomander.
I tried to edit codeccomander with ALC668 fix but doesnt fix for me (i get no sound or strange beviahours), i think we need to fix for each codec or sound card manually, if anyone can do a litle explanation to edit codeccomander with fix or litle guide, would be nice, for all people i think, cya.
 
Joined
Mar 13, 2013
Messages
1
Motherboard
osx
CPU
i3
Graphics
4000
Mac
Classic Mac
Mobile Phone
Hi, try that:
"the problem could be due to the “fast startup” feature on Windows.
With this feature enabled, Windows don't really shut down the entire system, but leaves things partially running so you can start the machine faster again. Try to disable this option, on Windows 10 it should be in “Control Panel→Hardware and Sound→Power Options→System Settings”. Select “Chooose what the power buttons do” to access the System Settings from the Power Options. Then disable the “Fast Startup” option in “Shutdown Settings”. This will cause Windows to fully shutdown and may solve the issue."
 
Joined
Apr 30, 2013
Messages
7
Motherboard
MSI Modern 14 A10RB
CPU
i5-10210U
Graphics
Intel UHD GT-2
Mobile Phone
  1. Android
Try to uninstall realtek high definition audio driver, just use default windows driver. It works for me
 
Top