Contribute
Register

No LAN after new build with Sierra

Joined
May 12, 2014
Messages
3
Motherboard
Gigabyte Z390 I AORUS Pro WiFi
CPU
Intel i7-8700
Hello everyone,
2nd time Hackintosher here. My last machine worked great for 5 years then something blew on the motherboard, so now putting together a new system:

Gigabyte Z390 AORUS I Pro WiFi
Intel i7-8700
No PCIe cards. Right now just want to use built in ethernet and video.

So far, I've run into 3 problems, 2 of which I've worked around but the last has stumped me, so I'm hoping someone can help:

1. (SOLVED) "Prohibited" sign when I used the Sierra USB boot drive created with Unibeast. The issue was with the OSxAptioFix2Drv, which I was able to replace by loading the USB EFI partition on another Mac and replacing with OSxAptioFix2Drv-free2000 from:
X99 Hackintosh OsxAptioFixDrv: AllocateRelocBlock Error Updatehttps://nickwoodhams.com/x99-hackintosh-osxaptiofixdrv-allocaterelocblock-error-u...

2. (Mostly SOLVED) No sound output devices in control panel. The issue was twofold:
a. With HDMI video to my monitor, it defaulted to HDMI sound as well. Needed to switch monitor to Line In.
b. Using Multibeast 10.4 for Sierra and the Realtek ALC1220 kext which matched my board didn't work.
c. Removing that kext and installing AppleALC + 100/200/300 Series Audio Support (HDAS -> HDEF) instead via MultiBeast 11.2.1 for Mojave did the trick.
d. Mildly annoying residual problem: for some reason I constantly hear low level noise from speakers that seems to mimic drive activity. Some kind of interference?

3. Please help! After installing the OS, during setup I have to choose "This computer is not connected to the internet" - otherwise it never completes set up, just gets caught in an infinite loop of restarting and going through setup again. So fine, I'm now trying to set up internet connectivity after OS setup. The motherboard has Intel I219V network interface. Looks like the kext that should work for my board is IntelMausiEthernet 2.4. I've installed this one, also via MultiBeast 11.2.1, but I get absolutely nothing. System Preferences/Network panel is completely blank. If I try to add anything, says "There was an error in Network preferences". Can't use the assistant to set anything up - it's asking for dial-up info. No idea where to go from here despite spending last couple of days searching for the answer and trying re-install several times. Any assistance greatly appreciated!

Thanks!
 
Top