Contribute
Register

No HDMI Audio on my HYSTOU P06B i3

Status
Not open for further replies.
Joined
Jan 12, 2019
Messages
11
Motherboard
hystou p06
CPU
i3-7100u
Graphics
intel hd620
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Hi i have just corrected my error about con1. I don't have any more the problem of strange pink hue colors. But It still have not HDMI audio.

Thanks again for your precious support.

Best regards.
 

Attachments

  • Hystou - Minimac3.tar.zip
    2.1 MB · Views: 59

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
But It still have not HDMI audio.
Why config,plist/Devices/Properties/PciRoot(0x0)/Pci(0x1f,0x3)/alc-layout-id/<05000000>? Remove
No Intel HDMI audio codec available, enable in BIOS
Restart, reply with new files
 
Joined
Jan 12, 2019
Messages
11
Motherboard
hystou p06
CPU
i3-7100u
Graphics
intel hd620
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Hi,

I add "alc-layout-id" because I have just noticed that without this properties, I haven't any sound present into macos System if i didn't add this option.

Do you mind that there is an option into my bios that I have to modify ? I have tried you find into my bios option if I could see some options link to HDMI but I didn't see anything. Maybe I don't understand all options present into my bios :)



But It strange that if I unplug than plug my HDMI screen after booting ... I could get the HDMI audio...


Before unplug/plug screen:
==================
MiniMac:~ jpc$ ioreg -rxn IOHDACodecDevice | grep VendorID
| "IOHDACodecVendorID" = 0x10ec0892



After unplug/plug screen:
==================
MiniMac:~ jpc$ ioreg -rxn IOHDACodecDevice | grep VendorID
| "IOHDACodecVendorID" = 0x10ec0892
| "IOHDACodecVendorID" = 0xffffffff8086280b


Best regards
 

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I add "alc-layout-id" because I have just noticed that without this properties, I haven't any sound present into macos System if i didn't add this option.
Internal AppleALC.kext property, usually 7. 2nd request, remove.
To figure out why layout-id does not work, attach all files.
But It strange that if I unplug than plug my HDMI screen after booting ... I could get the HDMI audio...
Not strange, something is not set properly
Attach both IORegs.
 
Joined
Jan 12, 2019
Messages
11
Motherboard
hystou p06
CPU
i3-7100u
Graphics
intel hd620
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Hi,

I have just removed "alc-layout-id" from config.plist and reboot. I haven't any sound.

best regards
 

Attachments

  • Hystou - Minimac4.tar.zip
    2.1 MB · Views: 76

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I haven't any sound
Intel HDMI codec has disappeared, enabled?
framebuffer-con1-type=<00080000>, not working?
Download latest AppleALC.kext and Lilu.kext and install
Restart and reply with new files
 
Joined
Jan 12, 2019
Messages
11
Motherboard
hystou p06
CPU
i3-7100u
Graphics
intel hd620
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Hi,

Thanks again for your support. How I could control that "Intel HDMI codec is enabled"? I didn't touch any thing on Bios configuration..May I have ?
How I could check if "framebuffer-con1-type=<00080000>" is working ? Because all seems good on my graphic display...

I have just dowloaded and installed the last version of AppleALC & Lilu into EFI/CLOVER/kexts/Other to replace the old version... but after rebooting I still have not sound...:(

Best regards.
 

Attachments

  • Hystou - Minimac5.tar.zip
    2.1 MB · Views: 54

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
How I could control that "Intel HDMI codec is enabled"?
BIOS setting (i.e., Maximus VII Impact: Advanced/System Agent Configuration/CPU Display Audio/Enabled)
How I could check if "framebuffer-con1-type=<00080000>" is working ?
IOReg:
387525
 
Joined
Jun 15, 2015
Messages
217
Motherboard
P5WE0
CPU
i5-2450M
Graphics
HD 3000
Mac
  1. MacBook Air
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
I have the 7500u version of this device. I had to patch my DSDT to and add audio. This device is basically a laptop motherboard stuck inside a small aluminum chassis. It is an alc892 board. Use Headkaze's "Hackintool" to add layout id 4 to your clover plist. I'll attach mine for reference.
 

Attachments

  • config-i7-7500 Hystou.plist
    19.9 KB · Views: 221
Joined
Mar 8, 2019
Messages
11
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
Config worked great on same machine (Hystou 7500U). Both video ports (had trouble using Hackintool to get those working), sleep, wake, shutdown. Thanks!

$ l EFI/clover/kexts/Other/ EFI/clover/ACPI/patched/ EFI/clover/drivers64UEFI/
EFI/clover/ACPI/patched/:
./ ../ SSDT-EC.aml*

EFI/clover/drivers64UEFI/:
./ AppleKeyAggregator-64.efi* AptioMemoryFix-64.efi* FirmwareVolume-64.efi* VBoxHfs-64.efi*
../ AppleKeyFeeder-64.efi* AudioDxe-64.efi* HashServiceFix-64.efi*
ApfsDriverLoader-64.efi* AppleUITheme-64.efi* DataHubDxe-64.efi* PartitionDxe-64.efi*
AppleImageCodec-64.efi* AptioInputFix-64.efi* FSInject-64.efi* SMCHelper-64.efi*

EFI/clover/kexts/Other/:
./ ../ AppleALC.kext/ FakeSMC.kext/ Lilu.kext/ RealtekRTL8111.kext/ USBPorts.kext/ WhateverGreen.kext/
 
Last edited:
Status
Not open for further replies.
Top