Contribute
Register

No handler for Region [ECOR] after EC patching and stuck apfs_module_start:1683

Joined
Jun 13, 2015
Messages
10
Motherboard
Lenovo L390 Yoga
CPU
i7-8565U
Graphics
UHD 620
Hello,

I'm currently trying to install the latest macOS Catalina on my Lenovo L390 Yoga laptop. As per advised, I renamed my H_EC device to EC after being stuck on apfs_module_start:1683 (or 1334 when trying the latest Mojave). I have also installed USBInjectAll and XHCI-unsupported on my kext folder.

However, even after patching, I still get stuck on apfs_module_start, and get thrown the ACPI error region ECOR has no handler (checking the DSDT, ECOR is dependent on H_EC).

My EFI folder and DSDT are attached.
Kexts and drivers folders are as follows:

Code:
KEXTS>OTHER:
AirportBrcmFixup.kext
AppleALC.kext
IntelMausi.kext
Lilu.kext
SMCBatteryManager.kext
SMCProcessor.kext
USBInjectAll.kext
VirtualSMC.kext
WhateverGreen.kext
XHCI-unsupported.kext

Code:
DRIVERS>UEFI:
ApfsDriverLoader.efi
DataHubDxe.efi
EmuVariableUefi.efi
HFSPlus.efi
NTFS.efi
NvmExpressDxe.efi
OsxAptioFix3Drv.efi

Edit: Woops, I had the fake EC patch SSDT-EC in the ACPI folder from an earlier try, but removing it still kept it all the same.
 

Attachments

Last edited:
Joined
Jun 13, 2015
Messages
10
Motherboard
Lenovo L390 Yoga
CPU
i7-8565U
Graphics
UHD 620
The apfs_module_error seems to be the result of an incompatible NVMe (Samsung PM981), so no hackintosh until it's replaced.

As for the EC patching, I have no way of knowing whether the patch worked or not regardless of the ACPI error, since Clover still tries to load the NVMe even when it's disabled through BIOS/UEFI.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,392
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
The apfs_module_error seems to be the result of an incompatible NVMe (Samsung PM981), so no hackintosh until it's replaced.

As for the EC patching, I have no way of knowing whether the patch worked or not regardless of the ACPI error, since Clover still tries to load the NVMe even when it's disabled through BIOS/UEFI.
apfs_module_start:1683 error is due to lack off SSDT-EC.aml in acpi/patched

but as you have also found out that Samsung PM981 is not supported and won't even boot to the installer
 
Joined
Jun 13, 2015
Messages
10
Motherboard
Lenovo L390 Yoga
CPU
i7-8565U
Graphics
UHD 620
apfs_module_start:1683 error is due to lack off SSDT-EC.aml in acpi/patched

but as you have also found out that Samsung PM981 is not supported and won't even boot to the installer
SSDT-EC in acpi/patched isn't an option since the laptop does have a working EC (doesn't return zero), only option is to patch all entries of H_EC (in my case) on ACPI through Clover. My question is knowing whether Clover patching is enough, since my chipset has an ECDT, which points to H_EC instead of EC.
 
Joined
Feb 18, 2017
Messages
29
Motherboard
Lenovo MIIX720
CPU
i5 7200U
Graphics
HD 620
Mobile Phone
Android, iOS
SSDT-EC in acpi/patched isn't an option since the laptop does have a working EC (doesn't return zero), only option is to patch all entries of H_EC (in my case) on ACPI through Clover. My question is knowing whether Clover patching is enough, since my chipset has an ECDT, which points to H_EC instead of EC.
Have you solved this issue?
I’m facing the same issue. Although I can boot up, but battery status is not working.
 
Top