Contribute
Register

No GPU Power Managment

Joined
May 19, 2013
Messages
53
Motherboard
Asus Rog Maximius Hero z370
CPU
I7-8700K
Graphics
NVIDIA GeForce GTX 1080 Ti Hydro 11 GB
Mac
MacBook Pro
Mobile Phone
iOS
Well, it's true there is still a bug. But for the system I am running, the improvement is huge.

For others, well..your mileage may vary.
 
Joined
Mar 9, 2013
Messages
5
Motherboard
Z370 Aorus Gaming 5
CPU
i7 8700k
Graphics
GTX 970
Mac
MacBook Pro
Mobile Phone
iOS
I updated to the latest beta, thinking nothing was fixed and I experienced the same problem when using HWMonitor. But the problem was HWMonitor. Now after using another temperature monitor the GPU scales back how it should, but clocks right up when preview app is opened
 
Joined
Apr 1, 2013
Messages
4
Motherboard
GA-Z87X-UD5H
CPU
i7-4770K
Graphics
GTX 760
I updated to the latest beta, thinking nothing was fixed and I experienced the same problem when using HWMonitor. But the problem was HWMonitor. Now after using another temperature monitor the GPU scales back how it should, but clocks right up when preview app is opened
What temp. monitor are you using?
 
Joined
May 30, 2013
Messages
51
Motherboard
Mavericks 10.9.4
CPU
Intel Core i5-3570K @ 4.42GHz
Graphics
Asus GeForce GTX 760 2GB 2-Way SLI
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Some people have reported that disabling OpenCL for GPU fixes the issue.

http://www.tonymacx86.com/graphics/122777-fix-opencl-crash-gk110b-based-cards.html

EDIT : It works ! I've been opening and closing quick look for the past 5 minutes and the GPU core speed goes down everytime. Sometimes, it doesn't even moves. I've noticed that sometimes the GPU Memory clock get stucks at high frequency but only for 30 seconds or so.

Screenshot : graph when opening and closing quick view around 10 times.
 

Attachments

Joined
Dec 13, 2012
Messages
27
Motherboard
Yosemite 10.10.3
CPU
i5 4670k
Graphics
MSI GTX 760 Itx 2gb & HD 4600 Dual
Mac
MacBook Air
Mobile Phone
iOS
Some people have reported that disabling OpenCL for GPU fixes the issue.

http://www.tonymacx86.com/graphics/122777-fix-opencl-crash-gk110b-based-cards.html

EDIT : It works ! I've been opening and closing quick look for the past 5 minutes and the GPU core speed goes down everytime. Sometimes, it doesn't even moves. I've noticed that sometimes the GPU Memory clock get stucks at high frequency but only for 30 seconds or so.

Screenshot : graph when opening and closing quick view around 10 times.
Second this! I am running on a gtx 760 and clock run up and down like they should. (especially when using quicklook and preview for pictures)
 
Joined
Aug 10, 2013
Messages
29
Motherboard
GA-Z87M-D3H
CPU
Intel Core i5 4760K
Graphics
NVIDIA GeForce GTX 760 2048MB
Mac
Classic Mac
Power Mac
Mobile Phone
iOS
wow, cool to hear about this message! Means that, our Mavericks systems have no disadvantages in contrast to ML builds? Everything works like it should?
If yes, I want to know, how you do it. Like described in the thread of the guide?
 
Joined
May 30, 2013
Messages
51
Motherboard
Mavericks 10.9.4
CPU
Intel Core i5-3570K @ 4.42GHz
Graphics
Asus GeForce GTX 760 2GB 2-Way SLI
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
wow, cool to hear about this message! Means that, our Mavericks systems have no disadvantages in contrast to ML builds? Everything works like it should?
If yes, I want to know, how you do it. Like described in the thread of the guide?
This is a workaround, and no it's not fixed. For those of us who don't need GPU OpenCL, it would seems like its fixed. But for people using OpenCL application like some adobe applications this will cause other troubles.

I only make music production with OSX and I game with Windows 7 so I really don't have a problem disabling that.

If you want to apply the fix, you just need to do what is said on the guide. However, you don't need Xcode. When creating your certificate, OSX will tell you that it's missing a plugin and will download it.
I would suggest however to repair your permissions prior to the reboot.
 
Joined
Mar 16, 2011
Messages
39
Motherboard
GA-Z77MX-D3H
CPU
i7-3770
Graphics
Asus GTX 970
Did anybody tried this with GTX 670 (GK 104 ?) ? Or is this just for GK 110b-cards ?
And does this means, photoshop won't work anymore or will crash ?
 
Joined
Jul 23, 2012
Messages
22
Motherboard
GA-Z77X-UP5 TH
CPU
Core i7 3770K
Graphics
EVGA GTX 970
Mac
MacBook Pro, Mac mini
Classic Mac
PowerBook
Did anybody tried this with GTX 670 (GK 104 ?) ? Or is this just for GK 110b-cards ?
And does this means, photoshop won't work anymore or will crash ?
Yes, it worked with my 670. See my post in the other thread: http://www.tonymacx86.com/graphics/122777-fix-opencl-crash-gk110b-based-cards-5.html#post751819

Apps continue to work. OpenCL code can be run on the CPU or on the GPU. Running OpenCL code on the GPU seems to be responsible for causing the GPU clock to get stuck. This patch basically forces OS X to run all OpenCL code on the CPU, and the bug with the GPU doesn't get triggered.
 
Top