Contribute
Register

No Ethernet on Intel NUC - Is this problem worth scrapping Hackintosh?

Joined
Apr 13, 2017
Messages
15
Motherboard
Intel NUC 5i3RYH + Clover
CPU
i3-5010U/NUC motherboard?
Graphics
Intel HD 5500, 2560x1440
Ethernet has been broken since installing Hackintosh on my NUC 3 weeks ago.

1. I have switched the ethernet cable.

2. I've successfully installed High Sierra following this guide by rehabman: https://www.tonymacx86.com/threads/...clover-uefi-nuc5i5mhye-nuc5i3myhe-etc.233256/

3. Rehabman's guide incorporates this Clover installation guide: https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

4. After following the guides and installing IntelMausiEthernet.kext, internet did not work.

5. So I ran Multibeast an tried to install IntelMausiEthernet.kext from that installation.

6. I manually erased the ethernet kexts and manually reinstalled IntelMausiEthernet.kext with Kextbeast from Tonymacx86's downloads page.

7. Still no luck. Internet preferences shows ethernet is disconnected.

I am very disillusioned because this appeared to be the last obstacle to using my Hackintosh. This was my first try using Hackintosh, and I am curious if the community believes that this ethernet problem is too difficult to solve, and it's worth turning away from Hackintosh.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,395
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Ethernet has been broken since installing Hackintosh on my NUC 3 weeks ago.

1. I have switched the ethernet cable.

2. I've successfully installed High Sierra following this guide by rehabman: https://www.tonymacx86.com/threads/...clover-uefi-nuc5i5mhye-nuc5i3myhe-etc.233256/

3. Rehabman's guide incorporates this Clover installation guide: https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

4. After following the guides and installing IntelMausiEthernet.kext, internet did not work.

5. So I ran Multibeast an tried to install IntelMausiEthernet.kext from that installation.

6. I manually erased the ethernet kexts and manually reinstalled IntelMausiEthernet.kext with Kextbeast from Tonymacx86's downloads page.

7. Still no luck. Internet preferences shows ethernet is disconnected.

I am very disillusioned because this appeared to be the last obstacle to using my Hackintosh. This was my first try using Hackintosh, and I am curious if the community believes that this ethernet problem is too difficult to solve, and it's worth turning away from Hackintosh.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Apr 20, 2018
Messages
11
Motherboard
B360
CPU
8500
Graphics
1050TI
@RehabMan
I use the newest intelMausiEthernet2.4.0 kext on b360,but i have a problem,Network(I219-V) is not working on 10.12.6 . On 10.13.3,Network(I219-V) is working. I love 10.12.6 ,But it is not supported on 10.12.6. Can you help me?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,395
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
@RehabMan
I use the newest intelMausiEthernet2.4.0 kext on b360,but i have a problem,Network(I219-V) is not working on 10.12.6 . On 10.13.3,Network(I219-V) is working. I love 10.12.6 ,But it is not supported on 10.12.6. Can you help me?
Off-topic.
This thread is specific to the NUC.
You seem to be asking a question regarding some other hardware.
 
Joined
Apr 13, 2017
Messages
15
Motherboard
Intel NUC 5i3RYH + Clover
CPU
i3-5010U/NUC motherboard?
Graphics
Intel HD 5500, 2560x1440
Hello RehabMan,

Thank you for the instructions regarding problem reporting. I have been away from the hackintosh project while I've been starting a business. I got a chance to collect the problem reporting files today. They're attached here.

The one area I was not able to understand is the "Attach EFI/Clover folder as ZIP (press F2 then F4 at main Clover screen just before collecting)." I pressed F2 and F4, as well as navigating manually to the options through the F1 menu, and was not able to get any result. Perhaps there could be a more detailed explanation in the instructions. Are you able to deduce enough about the problem in the problem reporting files I sent you? If not, could you provide some more details on how to generate the EFI/Clover report?

Thanks for your help.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,395
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello RehabMan,

Thank you for the instructions regarding problem reporting. I have been away from the hackintosh project while I've been starting a business. I got a chance to collect the problem reporting files today. They're attached here.

The one area I was not able to understand is the "Attach EFI/Clover folder as ZIP (press F2 then F4 at main Clover screen just before collecting)." I pressed F2 and F4, as well as navigating manually to the options through the F1 menu, and was not able to get any result. Perhaps there could be a more detailed explanation in the instructions. Are you able to deduce enough about the problem in the problem reporting files I sent you? If not, could you provide some more details on how to generate the EFI/Clover report?

Thanks for your help.
F1 "navigation" and selection does nothing.
You must actually press the keys from the main Clover screen.
You should not expect anything "on screen"... just the fact that misc/preboot.log and ACPI/origin/* files are created.
 
Joined
Apr 13, 2017
Messages
15
Motherboard
Intel NUC 5i3RYH + Clover
CPU
i3-5010U/NUC motherboard?
Graphics
Intel HD 5500, 2560x1440
Thanks for the quick reply. Yes, I also simply pressed the keys in the main Clover screen. In which directory are the misc/preboot.log and ACPI/origin/ files created in?

Do the other log files I uploaded provide any insight to you about the ethernet problems?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,395
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thanks for the quick reply. Yes, I also simply pressed the keys in the main Clover screen. In which directory are the misc/preboot.log and ACPI/origin/ files created in?
EFI/Clover on your EFI partition, of course.

Do the other log files I uploaded provide any insight to you about the ethernet problems?
I will not look at any files until the requested files are complete.
 
Joined
Apr 13, 2017
Messages
15
Motherboard
Intel NUC 5i3RYH + Clover
CPU
i3-5010U/NUC motherboard?
Graphics
Intel HD 5500, 2560x1440
Hi Rehabman,

I was able to successfully find the EFI partition and save the preboot files. I'm learning slowly but surely. I've bundled them in with the other previous files. You can find it all here. I look forward to see what you can find from viewing these files.

Thanks.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,395
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi Rehabman,

I was able to successfully find the EFI partition and save the preboot files. I'm learning slowly but surely. I've bundled them in with the other previous files. You can find it all here. I look forward to see what you can find from viewing these files.

Thanks.
As per FAQ, you must use site attachments.
Refer to post #2 and the related text in the FAQ.
 
Top