Contribute
Register

No Bluetooth with Fenvi FV-T919 on Mojave

Joined
Mar 22, 2011
Messages
84
Motherboard
Gigabyte Z370 AORUS ULTRA GAMING WIFI
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
  1. iOS
I've actually decided to just purchase a new motherboard rather than try to modify this one. I haven't purchased a new one yet, but I'll post my results here when I do.

Let us know if you decide to modify yours and if it works!


One of the admin sent me a diagram of the MB and indicated that the wifi card was as M2 card. So I went ahead trying to take our that troublesome card ;-) ...

It was a pain since the the screws to I/O back plate is at the other side of the MB but I was able to unhook the video card, cables, took MB out of the case. From there I took the M2 card out (only 2 screws on the back side of MB), put back the MB ,cable, VD installed the Fenvi card in about an hour.

Now bluetooth and wifi are working.

ttb1263
 
Joined
Aug 10, 2012
Messages
440
Motherboard
Asus Rog Strix Z370-G GAMING (WI-Fi AC)
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
  1. iOS
https://www.tonymacx86.com/threads/no-bluetooth-with-fenvi-fv-t919-on-mojave.263238


One of the admin sent me a diagram of the MB and indicated that the wifi card was as M2 card. So I went ahead trying to take our that troublesome card ;-) ...

It was a pain since the the screws to I/O back plate is at the other side of the MB but I was able to unhook the video card, cables, took MB out of the case. From there I took the M2 card out (only 2 screws on the back side of MB), put back the MB ,cable, VD installed the Fenvi card in about an hour.

Now bluetooth and wifi are working.

ttb1263

I did the same with my Asus Rog Strix Z370-G GAMING (WI-Fi AC) although Pastrychef suggested to swap the build in with this (I already owned a Fenvi FV-T919):
https://www.amazon.com/dp/B01L6YWGXW/?tag=tonymacx86com-20
using an adaptor
https://www.amazon.com/dp/B01KHRJVXW/?tag=tonymacx86com-20

There's though the advantage using his advice that you'll have an extra PCI slot

https://www.tonymacx86.com/threads/...wi-fi-ac-build-w-i9-9900k-amd-vega-56.239969/
 
Last edited:
Joined
Feb 28, 2019
Messages
1
Motherboard
Gigabyte Z390 AORUS Pro
CPU
i7-8700K
Graphics
RX 480
Mac
  1. MacBook
  2. Mac Pro
Mobile Phone
  1. iOS
This worked for me. Goto the Fenvi site and download the drivers for Windows. Install and boot into Windows then, boot in your Hackintosh. Don't have to remove BT card on Motherboard.
 
Joined
Oct 27, 2013
Messages
4
Motherboard
MSI z270 Tomahawk
CPU
i7-6700K
Graphics
Vega 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi, try resolution from section BT - change ID to 0x8289 - 33417

SIP should be disabled. Copy & paste:

XML:
        <key>Broadcom2046FamilyUSBBluetoothHCIController_52_FAVI</key>
        <dict>
            <key>CFBundleIdentifier</key>
            <string>com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport</string>
            <key>IOClass</key>
            <string>BroadcomBluetoothHostControllerUSBTransport</string>
            <key>IOProviderClass</key>
            <string>IOUSBHostDevice</string>
            <key>LMPLoggingEnabled</key>
            <true/>
            <key>idProduct</key>
            <integer>33417</integer>
            <key>idVendor</key>
            <integer>1452</integer>
        </dict>

or add in in Clover Configurator (or change config.plist):
XML:
    <key>KernelAndKextPatches</key>
    <dict>
        <key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>Eneble BT on Fenvi FV-T919</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                PGludGVnZXI+MzM0MjM8L2ludGVnZXI+
                </data>
                <key>InfoPlistPatch</key>
                <true/>
                <key>MatchOS</key>
                <string>10.14.x</string>
                <key>Name</key>
                <string>com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport</string>
                <key>Replace</key>
                <data>
                PGludGVnZXI+MzM0MTc8L2ludGVnZXI+
                </data>
            </dict>
        </array>
    </dict>
</dict>
 
Last edited:
Joined
Mar 14, 2015
Messages
12
Motherboard
Asus M11HW
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
The FV-T919 BT and Wifi worked out of the box for me on Mojave 10.14.5 with Max11Hero(wifi) and 9900K. onboard wifi and BT disabled via bios.
 
Joined
Mar 14, 2015
Messages
12
Motherboard
Asus M11HW
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
also want to add a note that the antenna for bluetooth is the one labeled JP5 on the PCB.
 

Attachments

  • FV-T919-Dual-band-802-11AC-Desktop-Wifi-Card-802-11-A-B-G-N-AC.jpg
    FV-T919-Dual-band-802-11AC-Desktop-Wifi-Card-802-11-A-B-G-N-AC.jpg
    129.1 KB · Views: 309
Joined
Jul 10, 2013
Messages
398
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10900X
Graphics
RX 5500 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. PowerBook
Mobile Phone
  1. Android
FV-T919 works OoB, I have tried like, hundred of those, no probs with any, unless BT module is broken, had some of those too.
Other problem would be related to USB, proper XHCI implementation is needed indeed. check @headkaze post for reference on how to create usb.kext for your mobo.

Good luck
 
Joined
May 25, 2011
Messages
25
Motherboard
ASUS Sabertoot Z77
CPU
i5-3450
Graphics
2x R9 280X
Mobile Phone
  1. iOS
Hallo Guys

Ik got the FV-T919, freshly installed Mojave.. Bluetooth works but the wifi isn't going on. Ik got a Asus Sabertooth z77 Mobo... Does anybody got a clue what is wrong?
 
Joined
Jun 18, 2019
Messages
70
Motherboard
HP Z220 CMT Workstation | Asus ZenBook UX310UA-FC329T
CPU
i7-3770 | i5 - 7200U
Graphics
RX 480 | HD 620
Mobile Phone
  1. Android
  2. iOS
  3. Other
This card works out of the box in Mojave, no need for any kext. Check if wifi / bleutooth works in Ubuntu using a live usb.
Make sure you have connected the extra connector that goes into a usb header on your motherboard (had the same problem yesterday)
 

Attachments

  • IMG_20190704_064232__01.jpg
    IMG_20190704_064232__01.jpg
    6 MB · Views: 262
  • IMG_20190704_064238__01.jpg
    IMG_20190704_064238__01.jpg
    6.6 MB · Views: 255
Last edited:
Top