Contribute
Register

<< Solved >> No Bluetooth with BCM94352Z

Status
Not open for further replies.

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,672
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Joined
May 5, 2014
Messages
189
Motherboard
X1 Carbon 6th
CPU
i7-8550U
Graphics
UHD620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Sorry for re-opening this solved thread. DW1560 & DW1830 has also been my headache since upgrade to Catalina.

One of the confusing thing is the chipset for DW1830, according to WikiDevi archieved here, both BCM2045A0 and BCM20703A1 can be found in DW1830, but not in DW1820 @amthbt .

Previously, SysPrep indicates my DW1830's BT as BCM20703A1 after boot, but after wakeup claims to be BCM2045A0 under USB, which makes Airdrop not working anymore (yet BT mouse/handsoff works). I don't know whether this relates to firmware image injection...

Currently I swap back to DW1560, all issue solved.( BT lost after wake from sleep)

Sorry, my bad.
DW1820A BCM94350

What Wi-Fi/Bluetooth card are you using? I've never seen BCM2045A0...
 
Last edited:
Joined
Sep 22, 2011
Messages
1,527
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I don't think your keyboard is USB based. Audio is definitely not USB based. Therefore, USB should not affect either.

@pastrychef Agreed that audio and bluetooth don't appear to be related, but I have found that the use of AppleALC on my Latitude E6410 (Nvidia graphics) interferes with my Brcm combo Wi-Fi/Bluetooth operation. Specifically, with AppleALC, my laptop won't acquire Wi-Fi until a minute or two after booting. I switched to VoodooHDA and Wi-Fi works perfectly (no delay in acquiring Wi-Fi access point). I examined IORegistryExplorer to try to figure this out and noticed with AppleALC that Wi-Fi would connect only after I observed an AppleHDA event in IORegistryExplorer. I suspect that VoodooHDA "fixes" the problem when it installs AppleHDADisabler.

Long story short... I needed to use VoodooHDA and not AppleALC on my Latitude E6410 (Nvidia) running Catalina 10.15.3. My debug files are attached and my system is as listed below.
  • Laptop: Dell Latitude E6410 (Nvidia 3100m, 8GB DDR3, i7-620m)
  • OS: Catalina 10.15.3 (patched with DosDude patcher for Nvidia Legacy graphics acceleration)
  • Mini-pcie combo Wi-Fi / Bluetooth Broadcom BCM 94352HMB (Bluetooth: 0a5c:21fb, Wi-Fi: pci14e4,43b1)
  • The following kexts installed in /Library/Extensions
    • Lilu.kext 1.4.1
    • AirportBrcmFixup.kext 2.0.6
    • BrcmFirmwareRepo.kext 2.5.1
    • BrcmBluetoothInjector.kext 2.5.1
    • BrcmPatchRAM3.kext 2.5.1
A complete description of my system can be found by googling "Catalina Latitude E6410" (my name in the other forum is tonyx86).
 

Attachments

  • debug_2195.zip
    1.7 MB · Views: 73

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,516
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks a lot, Bluetooth bcm94352Z working
if you run hackintool and click on Extensions, then click the refresh button, you may find there are updated ones
 
Joined
Nov 20, 2015
Messages
47
Motherboard
GA H170N WIFI
CPU
I7 6700
Graphics
Sapphire Radeon RX 580 8GB
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
if you run hackintool and click on Extensions, then click the refresh button, you may find there are updated ones

Well it seems I was too fast... Bluetooth is active in the menubar, but I cannot connect to my items.
Will try updating Extensions.
 
Joined
Aug 15, 2020
Messages
1
Motherboard
z270 P
CPU
7400 i5
Graphics
rx570
Hi, I did follow the step in this thread, i manage to make my bluetooth work with correct firmware v14 c5862. the issue is, after i shutdown my computer. my firmware revert back to v14 c4096, which my firmware not loading properly. i compare the working log to non working the difference is BrcmPatchRAM: uploadFirmware could not open the device!. Any Advice out there. Thank you kindly.
 
Status
Not open for further replies.
Top