Contribute
Register

No Audio in OS X Yosemite | ALC898

Status
Not open for further replies.
Joined
Jul 6, 2014
Messages
83
Motherboard
GA-Z87X-UD3H
CPU
Intel Core i5 4670k
Graphics
EVGA GTX 750 Ti
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
For some reason, when I went to install my audio driver in Multibeast I could not get it to work. I installed the audio driver itself no problem, but when I restarted my computer it did not work. Any ideas on how to fix?
 
Joined
May 6, 2012
Messages
63
Motherboard
Asus Maximus GENE V z77
CPU
Intel Core i3 3570k
Graphics
Nvidia GTX 770
Mac
Classic Mac
Mobile Phone
you should download Multibeast 6.2.2 and install "Without DSDT/ HDAEnabler"
 
Joined
Aug 31, 2012
Messages
108
Motherboard
Z77X-UD5H
CPU
I7-3770K
Graphics
5700 XT
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Internal Speakers has been selected. No difference. :(

also,

the volume toggle, by default, doesn't make a clicking noise anymore.. go to your sound preferences and enable play feedback when volume changes.
 
Joined
Jul 6, 2014
Messages
83
Motherboard
GA-Z87X-UD3H
CPU
Intel Core i5 4670k
Graphics
EVGA GTX 750 Ti
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
you should download Multibeast 6.2.2 and install "Without DSDT/ HDAEnabler"
Installing it right now. I will keep you guys updated on how it goes.

UPDATE: Using MultiBeast 6.2.2 and "Without DSDT/ HDAEnabler" Did not seem to do the trick. I will say, that in my efforts to fix this issue, I installed a file called "VoodooHDA-v2.8.4.Lion" and that removed the option for built in output. I don't know if this applies to the current situation, but if it does then let me know how to change it back.
 
Last edited:
Joined
Oct 18, 2013
Messages
40
Motherboard
Z87X-UD5 TH
CPU
4770k
Graphics
Intel HD 4600
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
I am having the same problem. No devices available to select on my sound output preferences pane. Installed ALC898. When trying to turn volume up/down a "prohibited" sign appears under the volume icon
 
Joined
Oct 18, 2013
Messages
40
Motherboard
Z87X-UD5 TH
CPU
4770k
Graphics
Intel HD 4600
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
For some reason, when I went to install my audio driver in Multibeast I could not get it to work. I installed the audio driver itself no problem, but when I restarted my computer it did not work. Any ideas on how to fix?

Download Multibeast 6.2.2 and check Realtek ALCxxx/Without DSDT/ALC898
Then HDAEnabler will be checked automatically. Don't check anything else and install. Then restart and on the Sound Output Preferences Pane select Internal Speakers.

I tried this a minute ago and it worked!! I had already tried too many option to maintain my hope before. This works. Just make sure in case you have installed ALC898 from the Yosemite Multibeast before to delete AppleHDA from Extensions folder and remove the flags on your org.chameleon.boot.plist before you install from 6.2.2.
 
Joined
Jul 6, 2014
Messages
83
Motherboard
GA-Z87X-UD3H
CPU
Intel Core i5 4670k
Graphics
EVGA GTX 750 Ti
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Download Multibeast 6.2.2 and check Realtek ALCxxx/Without DSDT/ALC898
Then HDAEnabler will be checked automatically. Don't check anything else and install. Then restart and on the Sound Output Preferences Pane select Internal Speakers.

I tried this a minute ago and it worked!! I had already tried too many option to maintain my hope before. This works. Just make sure in case you have installed ALC898 from the Yosemite Multibeast before to delete AppleHDA from Extensions folder and remove the flags on your org.chameleon.boot.plist before you install from 6.2.2.
Alright I am doing what you said. One good piece of news is that iTunes music works but is very quiet. I will keep you updated.

UPDATE: No luck. I couldn't find what to delete out of org.chameleon.boot.plist but I tried it anyway (I was able to find the applehda.kext, however). Like I said before, I downloaded a file from the internet as someone else's suggestion called "2746VoodooHDA-v2" in attempts to fix the problem (I installed the file called "VoodooHDA-v2.8.4.Lion.pkg" form the folder). This removed "Internal Speakers" From my list of audio sources and replaced it with "Line Out (Green Rear). So does anyone know how to get back the "Internal Speakers" audio device?:roll2:
 
Status
Not open for further replies.
Top