Contribute
Register

No Audio Devices - Realtek ALC AppleHDA [Guide]

Status
Not open for further replies.

toleda

Moderator
Joined
May 19, 2010
Messages
22,921
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I have followed your suggestions and attached the new IOReg file as requested.
Did 887 audio ever work? If yes, what OS X and AppleHDA.kext versions?
The codec version became available years after your motherboard was build; neither version works and fail with same problem. No other ideas at this time.
 
Joined
Aug 12, 2012
Messages
6
Motherboard
Gigabyte G41M Combo (Rev 2.0)
CPU
Intel Core 2 Quad Q8200
Graphics
Sparkle GeForce GTX 260
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
Yes audio was working in snow leopard, lion, mountain lion, and mavericks. During one of the mavericks updates audio ceased working, if i remember correctly the audio died at 10.9.5 and hasn't worked since (although it may have been 10.9.4, i'm not certain). It definitely worked in mountain lion.

Also the sound card is working as I am able to hear audio in Windows.

I'm not sure what kext versions. Previously I used to perform the combo updates when released, select alc887 legacy in multibeast and all would work. I never did any audio injection or had to make dsdt modifications in earlier versions of OS X. Only in recent months something must have changed...

Do you have any alternative audio suggestions, perhaps I should try Voodoo.

Thanks anyway for your help, you have been most helpful.

Vamsi.
 
Joined
Feb 7, 2012
Messages
7
Motherboard
Gigabyte GA-Z97X-UD5H
CPU
Intel Core i5-4690K
Graphics
ATI Radeon HD 6770
Hi,

I have an ALC889 on a Gigabyte GA X58A UD3R rev. 2 motherboard.
I'm running Chimera 4.
I installed the 889 AppleHDA patch using MultiBeast, but it didn't work.
It worked on 10.9 along with HDAEnabler but there is no HDAEnabler in MultiBeast 7.

Here is the org.chameleon.Boot.plist:
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>IGPEnabler</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>kext-dev-mode=1 PCIRootUID=1</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>HDEFLayoutID</key>
<string>01000000</string>
<key>HDAEnabler</key>
<string>Yes</string>
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,921
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Jul 31, 2012
Messages
94
Motherboard
GA-Z97X-UD5H rev1.1
CPU
i5 4690K
Graphics
intel HD 4600
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hey toleda, i've been using this file you gave me for audio in mavricks

http://www.tonymacx86.com/audio/112461-mavericks-no-audio-realtek-alc-applehda-guide-48.html

Now that I upgraded to yosemite, it doesn't seem to work. Here are the files.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>IGPEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>1</string>
<key>HDEFLayoutID</key>
<string>01000000</string>
<key>UseKernelCache</key>
<string>Yes</string>
<key>HDAEnabler</key>
<string>Yes</string>
</dict>
</plist>

My pc is an hp p6334f

Thanks

View attachment Mac Audio.ioreg
 
Joined
Jan 8, 2012
Messages
23
Motherboard
Hackintosh G5 Case
CPU
Intel Core i5 3350P 3.10GHz
Graphics
Gigabyte Geforce GTX650TI 1GB GDDR5
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
MSI motherboards, pre Sandy Bridge
Workaround: 6/7/8 Series upgrade

Hmm i see toleda.

Will there ever been made a patch for this problem?


-->>EDIT / UPDATE!<<--

My sound is WORKING with standard ALC892 kext from toleda!
The sound was disabled in system preferences!
 
Joined
May 15, 2012
Messages
39
Motherboard
GA-Z77X-UP5 TH (F12) / Powermac G4 case
CPU
Core i7 3770
Graphics
MSI GTX 670
Mac
  1. Mac mini
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Having some trouble.

1) No devices appear in System Prefs > Sound > Output.

(Audio devices were available and audio was functioning after Multibeast installation of ALC898 + Optional EFI Installed Bootloader Support, but audio devices disappeared after adding serial/system definitions in Clover config.plist. Not sure if this is the actual cause, but that’s all I recall doing, while trying to get that stuff straight for purposes iCloud/App Store login.)

2) Clover EFI installation of OS X 10.10 (fresh install) / GA-Z77X-UP5 TH (F12) / Core i7 3770 / MSI GTX 670

3) Multibeast 7.0 > ALC898 and Optional EFI Installed Bootloader Support

Files attached
 

Attachments

  • quaternio IOReg.ioreg
    3.2 MB · Views: 139
  • AppleHDA.kext.zip
    908.4 KB · Views: 246
  • Console kernal Sound assertions.log
    648 bytes · Views: 160
  • Screen Shot 2014-10-18 at 7.05.25 PM.png
    Screen Shot 2014-10-18 at 7.05.25 PM.png
    95.8 KB · Views: 734
  • Screen Shot 2014-10-18 at 7.06.05 PM.png
    Screen Shot 2014-10-18 at 7.06.05 PM.png
    132.7 KB · Views: 711
  • config.plist
    2.9 KB · Views: 381
  • debug.log
    23.2 KB · Views: 134

toleda

Moderator
Joined
May 19, 2010
Messages
22,921
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I upgraded to yosemite, it doesn't seem to work.
Did not read/try Post #1, evidence
Items 1 and 2 explain why audio doesn't work.
  1. 10.10
  2. HDEF Verification
Problem Reporting requests 12 files, 2 attached

You have to do the work to fix your audio problem.
 
Status
Not open for further replies.
Top