Contribute
Register

No Audio Devices - AppleHDA Realtek Audio

Joined
Aug 16, 2017
Messages
412
Motherboard
ASUS MAXIMUS X HERO WI-FI AC
CPU
i9-9900K
Graphics
Radeon VII
Mac
Mac mini
Mobile Phone
iOS
Yes

See Post #1/IV. Problem Reporting; attach all requested files
  1. Description of audio problem : no sound, unrecognized , aodio onle over DP
  2. OS X version/motherboard model/BIOS version/processor/graphics : Mojave 10.14.1 / MB ASUS Maximux Hero XI WIFI AC / bios version 0604 / Processor I9-9900K / graphic Sapphire Vega 56 Pulse
  3. Procedure/Guide Used : all procedures encountered on this forum or others , inclusive No Audio Devices - Realtek ALC AppleHDA [Guide]
  4. Copy of IOReg - IOReg_v2.1/File/Save a Copy As…, verify file (Tools 2.) Attached
  5. Terminal/diskutil list - attach Terminal output Attached
  6. Installed S/L/E/AppleHDA.kext (10.11 and newer, search: show hidden files) Attached
  7. Screen shots:
    1. DPCIManager/Status (Tools 3.) Attached
    2. System Information/Hardware/Audio/Intel High Definition Audio (not Devices) Attached
    3. System Preferences/Sound/Input Attached
    4. System Preferences/Sound/Output Attached
  8. Terminal/Shell/Export Test As. . . (if script used) Sorry I didn't understand this step.
    1. audio_cloverALC-x0.command
  9. Clover
    1. EFI/CLOVER/config.plist Attached
    2. DPCIManager/Misc/Boot Log (Tools 3.) Attached
    3. EFI/CLOVER/ACPI/Patched/dsdt.aml (if installed) No file in this directory
    4. EFI/CLOVER/ACP/Patched/ssdt(s).aml (if installed)No file in this directory
  10. Put all files in a folder, compress and attach to Post Please check out the attachment
 

Attachments

toleda

Moderator
Joined
May 20, 2010
Messages
24,297
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Why is config.plist/SystemParameters/NoCaches set?
New ALC1220 revision.
Try attached AppleALC.kext
Reply with new files.

12/21/18: AppleALC.kext_v1.3.4 and newer, supported
AppleALC
 
Last edited:
Joined
Aug 16, 2017
Messages
412
Motherboard
ASUS MAXIMUS X HERO WI-FI AC
CPU
i9-9900K
Graphics
Radeon VII
Mac
Mac mini
Mobile Phone
iOS
Why is config.plist/SystemParameters/NoCaches set?
may be from too many trying I've made ... somewhere I've found it...and I forgot ...
Try attached AppleALC.kext
New ALC1220 revision.
You save my life and money ...I intend to go back to Hero X... It is working ... I noticed that this is a new version 1.3.4 ... I still download it as the last one version 1.3.3
Reply with new files.
need you my new files , if it is working ?

AND THANK YOU ... I'm very happy ...after a couple days of crying ...
 
Last edited:
Joined
Nov 8, 2018
Messages
4
Motherboard
Gigabyte Z370M D3H
CPU
i5-8400
Graphics
UHD 630
Mobile Phone
Android
Wrong conclusion. Pin detect not working is clearly hardware.
macOS does not support AC97 audio, no pin detect; Windows does.
Fix/replace front panel connector.
Oh, that's the issue! I had no idea about the AC97 and HD audio connectors before. Just learned it by doing some research after getting your reply. HD audio connector is not available in my local market. So, need to be replaced my casing for that.

Thanks anyway. I appreciate your support.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,297
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
noticed that this is a new version 1.3.4
Special build with new ALC1220 version; not submitted and not available from AppleALC repo.
need you my new files , if it is working ?
Yes, IOReg only. Required to verify fix before submitting change.
 
Top